add folly::FixedString, a constexpr-usable string with a fixed-size internal buffer
[folly.git] / folly / configure.ac
index d4acc99bbf3efc1237878bf51494e991f5a087e5..3f4968e02c5d0e421dcbba9366447a1337cdf230 100644 (file)
@@ -182,7 +182,7 @@ if test "$folly_cv_prog_cc_int128" = "yes"; then
 #include <type_traits>
 static_assert(
   ::std::is_same<::std::make_signed<unsigned __int128>::type, __int128>::value,
-  "signed form of `unsigned __uint128` must be `__int128`.");
+  "signed form of \`unsigned __uint128\` must be \`__int128\`.");
       ]])],
       [folly_cv_prog_cc_int128traits=yes],
       [folly_cv_prog_cc_int128traits=no])
@@ -559,7 +559,7 @@ AC_CHECK_HEADER([lz4.h], AC_CHECK_LIB([lz4], [LZ4_decompress_safe]))
 AC_CHECK_HEADER([snappy.h], AC_CHECK_LIB([snappy], [main]))
 AC_CHECK_HEADER([zlib.h], AC_CHECK_LIB([z], [main]))
 AC_CHECK_HEADER([lzma.h], AC_CHECK_LIB([lzma], [main]))
-AC_CHECK_HEADER([zstd.h], AC_CHECK_LIB([zstd], [main]))
+AC_CHECK_HEADER([zstd.h], AC_CHECK_LIB([zstd], [ZSTD_compressStream]))
 AC_CHECK_HEADER([linux/membarrier.h], AC_DEFINE([HAVE_LINUX_MEMBARRIER_H], [1], [Define to 1 if membarrier.h is available]))
 
 AC_ARG_ENABLE([follytestmain],
@@ -568,12 +568,11 @@ AC_ARG_ENABLE([follytestmain],
 
 use_follytestmain=yes
 # libdwarf used to install in /usr/include, now installs in /usr/include/libdwarf.
-AC_SEARCH_LIBS([dwarf_init], [dwarf])
 AC_CHECK_HEADERS([libdwarf/dwarf.h dwarf.h], [break])
 # Check whether we have both the library and the header
 have_libdwarf=no
-AS_IF([test "x${ac_cv_search_dwarf_init}" != xno && test "x${ac_cv_header_libdwarf_dwarf_h}" = xyes], [have_libdwarf=yes])
-AS_IF([test "x${ac_cv_search_dwarf_init}" != xno && test "x${ac_cv_header_dwarf_h}" = xyes], [have_libdwarf=yes])
+AS_IF([test "x${ac_cv_header_libdwarf_dwarf_h}" = xyes], [have_libdwarf=yes])
+AS_IF([test "x${ac_cv_header_dwarf_h}" = xyes], [have_libdwarf=yes])
 if test "x${follytestmain}" = "xyes"; then
    AS_IF([test "x${have_libdwarf}" = xno], [AC_MSG_ERROR([Please install libdwarf development library and headers])])
    AC_CHECK_HEADERS([elf.h],, AC_MSG_ERROR([Please install libelf development package]))