Apply clang-format to folly/ssl/
[folly.git] / folly / Makefile.am
index 558a48596139771dd507c0a27180180364415849..fdd23e640dc90cb941dc64a2434ccef309c761b6 100644 (file)
@@ -2,7 +2,10 @@ if FOLLY_TESTMAIN
 MAYBE_INIT = init
 endif
 
-SUBDIRS = . experimental $(MAYBE_INIT) test io/test stats/test
+# Note that the order of SUBDIRS matters.
+# Many subdirectories depend on libfollytest from the test directory,
+# so it must appear before other directories
+SUBDIRS = . test experimental $(MAYBE_INIT) io/test stats/test
 
 ACLOCAL_AMFLAGS = -I m4
 
@@ -53,12 +56,12 @@ nobase_follyinclude_HEADERS = \
        CppAttributes.h \
        CpuId.h \
        CPortability.h \
+       concurrency/CacheLocality.h \
        concurrency/CoreCachedSharedPtr.h \
        detail/AtomicHashUtils.h \
        detail/AtomicUnorderedMapUtils.h \
        detail/AtomicUtils.h \
        detail/BitIteratorDetail.h \
-       detail/CacheLocality.h \
        detail/CachelinePaddedImpl.h \
        detail/ChecksumDetail.h \
        detail/DiscriminatedPtrDetail.h \
@@ -94,9 +97,9 @@ nobase_follyinclude_HEADERS = \
        ExceptionWrapper-inl.h \
        Executor.h \
        Expected.h \
+       concurrency/AtomicSharedPtr.h \
+       concurrency/detail/AtomicSharedPtr-detail.h \
        experimental/AsymmetricMemoryBarrier.h \
-       experimental/AtomicSharedPtr.h \
-       experimental/detail/AtomicSharedPtr-detail.h \
        experimental/AutoTimer.h \
        experimental/ThreadedRepeatingFunctionRunner.h \
        experimental/Bits.h \
@@ -136,6 +139,7 @@ nobase_follyinclude_HEADERS = \
        experimental/logging/LogStream.h \
        experimental/logging/LogStreamProcessor.h \
        experimental/logging/LogWriter.h \
+       experimental/logging/printf.h \
        experimental/logging/RateLimiter.h \
        experimental/logging/StandardLogHandler.h \
        experimental/logging/xlog.h \
@@ -192,7 +196,6 @@ nobase_follyinclude_HEADERS = \
        futures/FutureSplitter.h \
        futures/InlineExecutor.h \
        futures/ManualExecutor.h \
-       futures/OpaqueCallbackShunt.h \
        futures/Promise-inl.h \
        futures/Promise.h \
        futures/QueuedImmediateExecutor.h \
@@ -333,6 +336,7 @@ nobase_follyinclude_HEADERS = \
        portability/Memory.h \
        portability/OpenSSL.h \
        portability/PThread.h \
+       portability/Semaphore.h \
        portability/Sockets.h \
        portability/Stdio.h \
        portability/Stdlib.h \
@@ -447,7 +451,6 @@ libfollybase_la_SOURCES = \
        FormatTables.cpp \
        MallctlHelper.cpp \
        portability/BitsFunctexcept.cpp \
-       StringBase.cpp \
        String.cpp \
        Unicode.cpp
 
@@ -455,7 +458,7 @@ libfolly_la_SOURCES = \
        Assume.cpp \
        Checksum.cpp \
        ClockGettimeWrappers.cpp \
-       detail/CacheLocality.cpp \
+       concurrency/CacheLocality.cpp \
        detail/IPAddress.cpp \
        dynamic.cpp \
        ExceptionWrapper.cpp \