Fix folly/ThreadLocal with clang after PthreadKeyUnregister change
[folly.git] / folly / Makefile.am
index 5b1775e475e70519aa6afd1dac6c6b4e7c22753f..ed749242fa4bcf78b1f90b6b8e4e5633055a32af 100644 (file)
@@ -21,6 +21,7 @@ nobase_follyinclude_HEADERS = \
        ApplyTuple.h \
        Arena.h \
        Arena-inl.h \
+       Assume.h \
        AtomicBitSet.h \
        AtomicHashArray.h \
        AtomicHashArray-inl.h \
@@ -28,17 +29,19 @@ nobase_follyinclude_HEADERS = \
        AtomicHashMap-inl.h \
        AtomicLinkedList.h \
        AtomicStruct.h \
+       AtomicUnorderedMap.h \
        Baton.h \
        Benchmark.h \
        Bits.h \
        Checksum.h \
-       Chrono.h \
        ConcurrentSkipList.h \
        ConcurrentSkipList-inl.h \
+       ContainerTraits.h \
        Conv.h \
        CpuId.h \
        CPortability.h \
        detail/AtomicHashUtils.h \
+       detail/AtomicUnorderedMapUtils.h \
        detail/BitIteratorDetail.h \
        detail/BitsDetail.h \
        detail/CacheLocality.h \
@@ -55,6 +58,9 @@ nobase_follyinclude_HEADERS = \
        detail/Malloc.h \
        detail/MemoryIdler.h \
        detail/MPMCPipelineDetail.h \
+       detail/RangeCommon.h \
+       detail/RangeSse42.h \
+       detail/Sleeper.h \
        detail/SlowFingerprint.h \
        detail/SpinLockImpl.h \
        detail/Stats.h \
@@ -72,9 +78,11 @@ nobase_follyinclude_HEADERS = \
        EvictingCacheMap.h \
        experimental/AutoTimer.h \
        experimental/Bits.h \
+       experimental/BitVectorCoding.h \
        experimental/ExecutionObserver.h \
        experimental/EliasFanoCoding.h \
        experimental/EventCount.h \
+       experimental/Instructions.h \
        experimental/fibers/AddTasks.h \
        experimental/fibers/AddTasks-inl.h \
        experimental/fibers/Baton.h \
@@ -106,13 +114,15 @@ nobase_follyinclude_HEADERS = \
        experimental/io/FsUtil.h \
        experimental/JSONSchema.h \
        experimental/LockFreeRingBuffer.h \
+       experimental/NestedCommandLineApp.h \
+       experimental/ProgramOptions.h \
        experimental/Select64.h \
-       experimental/SharedMutex.h \
        experimental/StringKeyedCommon.h \
        experimental/StringKeyedUnorderedMap.h \
        experimental/StringKeyedUnorderedSet.h \
        experimental/TestUtil.h \
        experimental/TupleOps.h \
+       SparseByteSet.h \
        FBString.h \
        FBVector.h \
        File.h \
@@ -121,9 +131,11 @@ nobase_follyinclude_HEADERS = \
        folly-config.h \
        Foreach.h \
        FormatArg.h \
+       FormatTraits.h \
        Format.h \
        Format-inl.h \
-       futures/Deprecated.h \
+       futures/Barrier.h \
+       futures/ThreadedExecutor.h \
        futures/DrivableExecutor.h \
        futures/Future-pre.h \
        futures/helpers.h \
@@ -139,13 +151,13 @@ nobase_follyinclude_HEADERS = \
        futures/ScheduledExecutor.h \
        futures/SharedPromise.h \
        futures/SharedPromise-inl.h \
+       futures/ThreadWheelTimekeeper.h \
        futures/Timekeeper.h \
        futures/Try-inl.h \
        futures/Try.h \
        futures/Unit.h \
        futures/detail/Core.h \
        futures/detail/FSM.h \
-       futures/detail/ThreadWheelTimekeeper.h \
        futures/detail/Types.h \
        gen/Base.h \
        gen/Base-inl.h \
@@ -177,6 +189,7 @@ nobase_follyinclude_HEADERS = \
        io/RecordIO-inl.h \
        io/TypedIOBuf.h \
        io/ShutdownSocketSet.h \
+       io/async/AsyncPipe.h \
        io/async/AsyncTimeout.h \
        io/async/AsyncTransport.h \
        io/async/AsyncUDPServerSocket.h \
@@ -187,8 +200,10 @@ nobase_follyinclude_HEADERS = \
        io/async/AsyncSocketBase.h \
        io/async/AsyncSSLSocket.h \
        io/async/AsyncSocketException.h \
+       io/async/DelayedDestructionBase.h \
        io/async/DelayedDestruction.h \
        io/async/EventBase.h \
+       io/async/EventBaseLocal.h \
        io/async/EventBaseManager.h \
        io/async/EventFDWrapper.h \
        io/async/EventHandler.h \
@@ -197,6 +212,7 @@ nobase_follyinclude_HEADERS = \
        io/async/HHWheelTimer.h \
        io/async/Request.h \
        io/async/SSLContext.h \
+       io/async/ScopedEventBaseThread.h \
        io/async/TimeoutManager.h \
        io/async/test/AsyncSSLSocketTest.h \
        io/async/test/BlockingSocket.h \
@@ -204,6 +220,8 @@ nobase_follyinclude_HEADERS = \
        io/async/test/MockAsyncServerSocket.h \
        io/async/test/MockAsyncSSLSocket.h \
        io/async/test/MockAsyncTransport.h \
+       io/async/test/MockAsyncUDPSocket.h \
+       io/async/test/SocketPair.h \
        io/async/test/TimeUtil.h \
        io/async/test/UndelayedDestruction.h \
        io/async/test/Util.h \
@@ -217,20 +235,24 @@ nobase_follyinclude_HEADERS = \
        MapUtil.h \
        Memory.h \
        MemoryMapping.h \
+       MicroSpinLock.h \
        MoveWrapper.h \
        MPMCPipeline.h \
        MPMCQueue.h \
        Optional.h \
        PackedSyncPtr.h \
        Padded.h \
+       PicoSpinLock.h \
        Portability.h \
        Preprocessor.h \
        ProducerConsumerQueue.h \
        Random.h \
        Random-inl.h \
        Range.h \
+       ReadMostlySharedPtr.h \
        RWSpinLock.h \
        ScopeGuard.h \
+       SharedMutex.h \
        Singleton.h \
        Singleton-inl.h \
        SmallLocks.h \
@@ -266,61 +288,7 @@ nobase_follyinclude_HEADERS = \
        Uri.h \
        Uri-inl.h \
        Varint.h \
-       VersionCheck.h \
-       wangle/acceptor/Acceptor.h \
-       wangle/acceptor/ConnectionCounter.h \
-       wangle/acceptor/ConnectionManager.h \
-       wangle/acceptor/DomainNameMisc.h \
-       wangle/acceptor/LoadShedConfiguration.h \
-       wangle/acceptor/ManagedConnection.h \
-       wangle/acceptor/NetworkAddress.h \
-       wangle/acceptor/ServerSocketConfig.h \
-       wangle/acceptor/SocketOptions.h \
-       wangle/acceptor/TransportInfo.h \
-       wangle/bootstrap/ServerBootstrap.h \
-       wangle/bootstrap/ServerBootstrap-inl.h \
-       wangle/bootstrap/ServerSocketFactory.h \
-       wangle/bootstrap/ClientBootstrap.h \
-       wangle/channel/AsyncSocketHandler.h \
-       wangle/channel/EventBaseHandler.h \
-       wangle/channel/FileRegion.h \
-       wangle/channel/Handler.h \
-       wangle/channel/HandlerContext.h \
-       wangle/channel/HandlerContext-inl.h \
-       wangle/channel/OutputBufferingHandler.h \
-       wangle/channel/Pipeline.h \
-       wangle/channel/Pipeline-inl.h \
-       wangle/channel/StaticPipeline.h \
-       wangle/concurrent/BlockingQueue.h \
-       wangle/concurrent/Codel.h \
-       wangle/concurrent/CPUThreadPoolExecutor.h \
-       wangle/concurrent/FiberIOExecutor.h \
-       wangle/concurrent/FutureExecutor.h \
-       wangle/concurrent/IOExecutor.h \
-       wangle/concurrent/IOObjectCache.h \
-       wangle/concurrent/IOThreadPoolExecutor.h \
-       wangle/concurrent/GlobalExecutor.h \
-       wangle/concurrent/LifoSemMPMCQueue.h \
-       wangle/concurrent/NamedThreadFactory.h \
-       wangle/concurrent/ThreadFactory.h \
-       wangle/concurrent/ThreadPoolExecutor.h \
-       wangle/rx/Observable.h \
-       wangle/rx/Observer.h \
-       wangle/rx/Subject.h \
-       wangle/rx/Subscription.h \
-       wangle/rx/types.h \
-       wangle/ssl/ClientHelloExtStats.h \
-       wangle/ssl/DHParam.h \
-       wangle/ssl/PasswordInFile.h \
-       wangle/ssl/SSLCacheOptions.h \
-       wangle/ssl/SSLCacheProvider.h \
-       wangle/ssl/SSLContextConfig.h \
-       wangle/ssl/SSLContextManager.h \
-       wangle/ssl/SSLSessionCacheManager.h \
-       wangle/ssl/SSLStats.h \
-       wangle/ssl/SSLUtil.h \
-       wangle/ssl/TLSTicketKeyManager.h \
-       wangle/ssl/TLSTicketKeySeeds.h
+       VersionCheck.h
 
 FormatTables.cpp: build/generate_format_tables.py
        $(PYTHON) build/generate_format_tables.py
@@ -337,28 +305,32 @@ CLEANFILES += GroupVarintTables.cpp
 libfollybase_la_SOURCES = \
        Conv.cpp \
        Demangle.cpp \
+       detail/RangeCommon.cpp \
+       detail/RangeSse42.cpp \
        EscapeTables.cpp \
        Format.cpp \
        FormatTables.cpp \
-       Malloc.cpp \
-       Range.cpp \
        StringBase.cpp \
        String.cpp \
        Unicode.cpp
 
 libfolly_la_SOURCES = \
        Bits.cpp \
+       Checksum.cpp \
        detail/CacheLocality.cpp \
        dynamic.cpp \
        File.cpp \
        FileUtil.cpp \
        FingerprintTables.cpp \
-       futures/detail/ThreadWheelTimekeeper.cpp \
+       futures/Barrier.cpp \
+       futures/ThreadedExecutor.cpp \
        futures/Future.cpp \
        futures/InlineExecutor.cpp \
        futures/ManualExecutor.cpp \
        futures/QueuedImmediateExecutor.cpp \
+       futures/ThreadWheelTimekeeper.cpp \
        detail/Futex.cpp \
+       detail/ThreadLocalDetail.cpp \
        GroupVarint.cpp \
        GroupVarintTables.cpp \
        IPAddress.cpp \
@@ -370,6 +342,7 @@ libfolly_la_SOURCES = \
        io/IOBufQueue.cpp \
        io/RecordIO.cpp \
        io/ShutdownSocketSet.cpp \
+       io/async/AsyncPipe.cpp \
        io/async/AsyncTimeout.cpp \
        io/async/AsyncUDPSocket.cpp \
        io/async/AsyncServerSocket.cpp \
@@ -377,10 +350,13 @@ libfolly_la_SOURCES = \
        io/async/AsyncSocket.cpp \
        io/async/AsyncSSLSocket.cpp \
        io/async/EventBase.cpp \
+       io/async/EventBaseLocal.cpp \
        io/async/EventBaseManager.cpp \
        io/async/EventHandler.cpp \
        io/async/SSLContext.cpp \
+       io/async/ScopedEventBaseThread.cpp \
        io/async/HHWheelTimer.cpp \
+       io/async/test/SocketPair.cpp \
        io/async/test/TimeUtil.cpp \
        json.cpp \
        detail/MemoryIdler.cpp \
@@ -388,8 +364,9 @@ libfolly_la_SOURCES = \
        MemoryMapping.cpp \
        Random.cpp \
        SafeAssert.cpp \
-       SocketAddress.cpp \
+       SharedMutex.cpp \
        Singleton.cpp \
+       SocketAddress.cpp \
        SpookyHashV1.cpp \
        SpookyHashV2.cpp \
        stats/Instantiations.cpp \
@@ -407,26 +384,10 @@ libfolly_la_SOURCES = \
        experimental/FunctionScheduler.cpp \
        experimental/io/FsUtil.cpp \
        experimental/JSONSchema.cpp \
+       experimental/NestedCommandLineApp.cpp \
+       experimental/ProgramOptions.cpp \
        experimental/Select64.cpp \
-       experimental/SharedMutex.cpp \
-       experimental/TestUtil.cpp \
-       wangle/acceptor/Acceptor.cpp \
-       wangle/acceptor/ConnectionManager.cpp \
-       wangle/acceptor/LoadShedConfiguration.cpp \
-       wangle/acceptor/ManagedConnection.cpp \
-       wangle/acceptor/SocketOptions.cpp \
-       wangle/acceptor/TransportInfo.cpp \
-       wangle/bootstrap/ServerBootstrap.cpp \
-       wangle/concurrent/CPUThreadPoolExecutor.cpp \
-       wangle/concurrent/Codel.cpp \
-       wangle/concurrent/IOThreadPoolExecutor.cpp \
-       wangle/concurrent/GlobalExecutor.cpp \
-       wangle/concurrent/ThreadPoolExecutor.cpp \
-       wangle/ssl/PasswordInFile.cpp \
-       wangle/ssl/SSLContextManager.cpp \
-       wangle/ssl/SSLSessionCacheManager.cpp \
-       wangle/ssl/SSLUtil.cpp \
-       wangle/ssl/TLSTicketKeyManager.cpp
+       experimental/TestUtil.cpp
 
 if HAVE_LINUX
 nobase_follyinclude_HEADERS += \