Remove template helper constants
[folly.git] / folly / Makefile.am
index aa1a473c648e01c7655c373730160c4246dfdc3d..e629366f12ca74ff6346ed6469465abb082a93dd 100644 (file)
@@ -2,7 +2,10 @@ if FOLLY_TESTMAIN
 MAYBE_INIT = init
 endif
 
-SUBDIRS = . experimental $(MAYBE_INIT) test io/test stats/test
+# Note that the order of SUBDIRS matters.
+# Many subdirectories depend on libfollytest from the test directory,
+# so it must appear before other directories
+SUBDIRS = . test experimental $(MAYBE_INIT) io/test stats/test
 
 ACLOCAL_AMFLAGS = -I m4
 
@@ -53,13 +56,12 @@ nobase_follyinclude_HEADERS = \
        CppAttributes.h \
        CpuId.h \
        CPortability.h \
+       concurrency/CacheLocality.h \
        concurrency/CoreCachedSharedPtr.h \
        detail/AtomicHashUtils.h \
        detail/AtomicUnorderedMapUtils.h \
        detail/AtomicUtils.h \
        detail/BitIteratorDetail.h \
-       detail/CacheLocality.h \
-       detail/CachelinePaddedImpl.h \
        detail/ChecksumDetail.h \
        detail/DiscriminatedPtrDetail.h \
        detail/FileUtilDetail.h \
@@ -94,9 +96,9 @@ nobase_follyinclude_HEADERS = \
        ExceptionWrapper-inl.h \
        Executor.h \
        Expected.h \
+       concurrency/AtomicSharedPtr.h \
+       concurrency/detail/AtomicSharedPtr-detail.h \
        experimental/AsymmetricMemoryBarrier.h \
-       experimental/AtomicSharedPtr.h \
-       experimental/detail/AtomicSharedPtr-detail.h \
        experimental/AutoTimer.h \
        experimental/ThreadedRepeatingFunctionRunner.h \
        experimental/Bits.h \
@@ -122,7 +124,9 @@ nobase_follyinclude_HEADERS = \
        experimental/JSONSchema.h \
        experimental/LockFreeRingBuffer.h \
        experimental/logging/AsyncFileWriter.h \
+       experimental/logging/GlogStyleFormatter.h \
        experimental/logging/ImmediateFileWriter.h \
+       experimental/logging/Init.h \
        experimental/logging/LogCategory.h \
        experimental/logging/LogFormatter.h \
        experimental/logging/Logger.h \
@@ -134,6 +138,7 @@ nobase_follyinclude_HEADERS = \
        experimental/logging/LogStream.h \
        experimental/logging/LogStreamProcessor.h \
        experimental/logging/LogWriter.h \
+       experimental/logging/printf.h \
        experimental/logging/RateLimiter.h \
        experimental/logging/StandardLogHandler.h \
        experimental/logging/xlog.h \
@@ -190,7 +195,6 @@ nobase_follyinclude_HEADERS = \
        futures/FutureSplitter.h \
        futures/InlineExecutor.h \
        futures/ManualExecutor.h \
-       futures/OpaqueCallbackShunt.h \
        futures/Promise-inl.h \
        futures/Promise.h \
        futures/QueuedImmediateExecutor.h \
@@ -203,6 +207,8 @@ nobase_follyinclude_HEADERS = \
        futures/detail/FSM.h \
        futures/detail/Types.h \
        futures/test/TestExecutor.h \
+       hash/SpookyHashV1.h \
+       hash/SpookyHashV2.h \
        gen/Base.h \
        gen/Base-inl.h \
        gen/Combine.h \
@@ -265,6 +271,7 @@ nobase_follyinclude_HEADERS = \
        io/async/ssl/TLSDefinitions.h \
        io/async/Request.h \
        io/async/SSLContext.h \
+       io/async/SSLOptions.h \
        io/async/ScopedEventBaseThread.h \
        io/async/TimeoutManager.h \
        io/async/VirtualEventBase.h \
@@ -286,6 +293,7 @@ nobase_follyinclude_HEADERS = \
        io/async/test/Util.h \
        Iterator.h \
        json.h \
+       Launder.h \
        Lazy.h \
        LifoSem.h \
        Likely.h \
@@ -331,6 +339,7 @@ nobase_follyinclude_HEADERS = \
        portability/Memory.h \
        portability/OpenSSL.h \
        portability/PThread.h \
+       portability/Semaphore.h \
        portability/Sockets.h \
        portability/Stdio.h \
        portability/Stdlib.h \
@@ -355,6 +364,7 @@ nobase_follyinclude_HEADERS = \
        Random.h \
        Random-inl.h \
        Range.h \
+       Replaceable.h \
        RWSpinLock.h \
        SafeAssert.h \
        ScopeGuard.h \
@@ -369,13 +379,14 @@ nobase_follyinclude_HEADERS = \
        sorted_vector_types.h \
        SparseByteSet.h \
        SpinLock.h \
-       SpookyHashV1.h \
-       SpookyHashV2.h \
+       ssl/Init.h \
        ssl/OpenSSLCertUtils.h \
        ssl/OpenSSLHash.h \
        ssl/OpenSSLPtrTypes.h \
        ssl/OpenSSLVersionFinder.h \
        ssl/SSLSession.h \
+       ssl/OpenSSLLockTypes.h \
+       ssl/detail/OpenSSLThreading.h \
        ssl/detail/SSLSessionImpl.h \
        stats/detail/Bucket.h \
        stats/BucketedTimeSeries-defs.h \
@@ -433,6 +444,7 @@ GroupVarintTables.cpp: build/generate_varint_tables.py
 CLEANFILES += GroupVarintTables.cpp
 
 libfollybasesse42_la_SOURCES = \
+       detail/Crc32cDetail.cpp \
        detail/ChecksumDetail.cpp \
        detail/RangeSse42.cpp
 
@@ -442,10 +454,10 @@ libfollybase_la_SOURCES = \
        detail/RangeCommon.cpp \
        EscapeTables.cpp \
        Format.cpp \
+       FormatArg.cpp \
        FormatTables.cpp \
        MallctlHelper.cpp \
        portability/BitsFunctexcept.cpp \
-       StringBase.cpp \
        String.cpp \
        Unicode.cpp
 
@@ -453,7 +465,7 @@ libfolly_la_SOURCES = \
        Assume.cpp \
        Checksum.cpp \
        ClockGettimeWrappers.cpp \
-       detail/CacheLocality.cpp \
+       concurrency/CacheLocality.cpp \
        detail/IPAddress.cpp \
        dynamic.cpp \
        ExceptionWrapper.cpp \
@@ -463,6 +475,7 @@ libfolly_la_SOURCES = \
        FingerprintTables.cpp \
        futures/Barrier.cpp \
        futures/Future.cpp \
+       futures/FutureException.cpp \
        futures/ManualExecutor.cpp \
        futures/QueuedImmediateExecutor.cpp \
        futures/ThreadWheelTimekeeper.cpp \
@@ -470,6 +483,8 @@ libfolly_la_SOURCES = \
        detail/Futex.cpp \
        detail/StaticSingletonManager.cpp \
        detail/ThreadLocalDetail.cpp \
+       hash/SpookyHashV1.cpp \
+       hash/SpookyHashV2.cpp \
        GroupVarint.cpp \
        GroupVarintTables.cpp \
        IPAddress.cpp \
@@ -497,6 +512,7 @@ libfolly_la_SOURCES = \
        io/async/EventHandler.cpp \
        io/async/Request.cpp \
        io/async/SSLContext.cpp \
+       io/async/SSLOptions.cpp \
        io/async/ScopedEventBaseThread.cpp \
        io/async/VirtualEventBase.cpp \
        io/async/HHWheelTimer.cpp \
@@ -540,10 +556,10 @@ libfolly_la_SOURCES = \
        Optional.cpp \
        Singleton.cpp \
        SocketAddress.cpp \
-       SpookyHashV1.cpp \
-       SpookyHashV2.cpp \
+       ssl/Init.cpp \
        ssl/OpenSSLCertUtils.cpp \
        ssl/OpenSSLHash.cpp \
+       ssl/detail/OpenSSLThreading.cpp \
        ssl/detail/SSLSessionImpl.cpp \
        stats/BucketedTimeSeries.cpp \
        stats/Histogram.cpp \
@@ -553,6 +569,7 @@ libfolly_la_SOURCES = \
        ThreadCachedArena.cpp \
        ThreadName.cpp \
        TimeoutQueue.cpp \
+       Try.cpp \
        Uri.cpp \
        Version.cpp \
        experimental/AsymmetricMemoryBarrier.cpp \