make it really clear that wangle/rx is deprecated
[folly.git] / folly / Makefile.am
index 5b1775e475e70519aa6afd1dac6c6b4e7c22753f..d85c052d8ceaea1a322b40c1d3f57758bf841f24 100644 (file)
@@ -28,6 +28,7 @@ nobase_follyinclude_HEADERS = \
        AtomicHashMap-inl.h \
        AtomicLinkedList.h \
        AtomicStruct.h \
+       AtomicUnorderedMap.h \
        Baton.h \
        Benchmark.h \
        Bits.h \
@@ -39,6 +40,7 @@ nobase_follyinclude_HEADERS = \
        CpuId.h \
        CPortability.h \
        detail/AtomicHashUtils.h \
+       detail/AtomicUnorderedMapUtils.h \
        detail/BitIteratorDetail.h \
        detail/BitsDetail.h \
        detail/CacheLocality.h \
@@ -75,6 +77,7 @@ nobase_follyinclude_HEADERS = \
        experimental/ExecutionObserver.h \
        experimental/EliasFanoCoding.h \
        experimental/EventCount.h \
+       experimental/Instructions.h \
        experimental/fibers/AddTasks.h \
        experimental/fibers/AddTasks-inl.h \
        experimental/fibers/Baton.h \
@@ -107,7 +110,6 @@ nobase_follyinclude_HEADERS = \
        experimental/JSONSchema.h \
        experimental/LockFreeRingBuffer.h \
        experimental/Select64.h \
-       experimental/SharedMutex.h \
        experimental/StringKeyedCommon.h \
        experimental/StringKeyedUnorderedMap.h \
        experimental/StringKeyedUnorderedSet.h \
@@ -121,6 +123,7 @@ nobase_follyinclude_HEADERS = \
        folly-config.h \
        Foreach.h \
        FormatArg.h \
+       FormatTraits.h \
        Format.h \
        Format-inl.h \
        futures/Deprecated.h \
@@ -231,6 +234,7 @@ nobase_follyinclude_HEADERS = \
        Range.h \
        RWSpinLock.h \
        ScopeGuard.h \
+       SharedMutex.h \
        Singleton.h \
        Singleton-inl.h \
        SmallLocks.h \
@@ -304,11 +308,11 @@ nobase_follyinclude_HEADERS = \
        wangle/concurrent/NamedThreadFactory.h \
        wangle/concurrent/ThreadFactory.h \
        wangle/concurrent/ThreadPoolExecutor.h \
-       wangle/rx/Observable.h \
-       wangle/rx/Observer.h \
-       wangle/rx/Subject.h \
-       wangle/rx/Subscription.h \
-       wangle/rx/types.h \
+       wangle/deprecated/rx/Observable.h \
+       wangle/deprecated/rx/Observer.h \
+       wangle/deprecated/rx/Subject.h \
+       wangle/deprecated/rx/Subscription.h \
+       wangle/deprecated/rx/types.h \
        wangle/ssl/ClientHelloExtStats.h \
        wangle/ssl/DHParam.h \
        wangle/ssl/PasswordInFile.h \
@@ -388,8 +392,9 @@ libfolly_la_SOURCES = \
        MemoryMapping.cpp \
        Random.cpp \
        SafeAssert.cpp \
-       SocketAddress.cpp \
+       SharedMutex.cpp \
        Singleton.cpp \
+       SocketAddress.cpp \
        SpookyHashV1.cpp \
        SpookyHashV2.cpp \
        stats/Instantiations.cpp \
@@ -408,7 +413,6 @@ libfolly_la_SOURCES = \
        experimental/io/FsUtil.cpp \
        experimental/JSONSchema.cpp \
        experimental/Select64.cpp \
-       experimental/SharedMutex.cpp \
        experimental/TestUtil.cpp \
        wangle/acceptor/Acceptor.cpp \
        wangle/acceptor/ConnectionManager.cpp \
@@ -417,6 +421,7 @@ libfolly_la_SOURCES = \
        wangle/acceptor/SocketOptions.cpp \
        wangle/acceptor/TransportInfo.cpp \
        wangle/bootstrap/ServerBootstrap.cpp \
+       wangle/channel/Pipeline.cpp \
        wangle/concurrent/CPUThreadPoolExecutor.cpp \
        wangle/concurrent/Codel.cpp \
        wangle/concurrent/IOThreadPoolExecutor.cpp \