folly: add bser encode/decode for dynamic
[folly.git] / folly / Makefile.am
index e52b52bcd4694c3f221ddb5c864beb93496b16e3..d37966b3845faaa774edbdbf0dc3a1cf9be32ac2 100644 (file)
@@ -1,4 +1,8 @@
+if FOLLY_TESTMAIN
+SUBDIRS = . experimental init test
+else
 SUBDIRS = . test
+endif
 
 ACLOCAL_AMFLAGS = -I m4
 
@@ -27,9 +31,11 @@ nobase_follyinclude_HEADERS = \
        AtomicHashArray-inl.h \
        AtomicHashMap.h \
        AtomicHashMap-inl.h \
+       AtomicIntrusiveLinkedList.h \
        AtomicLinkedList.h \
        AtomicStruct.h \
        AtomicUnorderedMap.h \
+       CppAttributes.h \
        Baton.h \
        Benchmark.h \
        Bits.h \
@@ -83,6 +89,7 @@ nobase_follyinclude_HEADERS = \
        experimental/EliasFanoCoding.h \
        experimental/EventCount.h \
        experimental/Instructions.h \
+       experimental/bser/Bser.h \
        experimental/fibers/AddTasks.h \
        experimental/fibers/AddTasks-inl.h \
        experimental/fibers/Baton.h \
@@ -116,11 +123,20 @@ nobase_follyinclude_HEADERS = \
        experimental/LockFreeRingBuffer.h \
        experimental/NestedCommandLineApp.h \
        experimental/ProgramOptions.h \
+       experimental/ReadMostlySharedPtr.h \
+       experimental/symbolizer/Elf.h \
+       experimental/symbolizer/ElfCache.h \
+       experimental/symbolizer/Dwarf.h \
+       experimental/symbolizer/LineReader.h \
+       experimental/symbolizer/SignalHandler.h \
+       experimental/symbolizer/StackTrace.cpp \
+       experimental/symbolizer/Symbolizer.h \
        experimental/Select64.h \
        experimental/StringKeyedCommon.h \
        experimental/StringKeyedUnorderedMap.h \
        experimental/StringKeyedUnorderedSet.h \
        experimental/TestUtil.h \
+       experimental/TLRefCount.h \
        experimental/TupleOps.h \
        SparseByteSet.h \
        FBString.h \
@@ -180,6 +196,7 @@ nobase_follyinclude_HEADERS = \
        IPAddressV6.h \
        IPAddressException.h \
        IndexedMemPool.h \
+       init/Init.h \
        IntrusiveList.h \
        io/Compression.h \
        io/Cursor.h \
@@ -210,6 +227,7 @@ nobase_follyinclude_HEADERS = \
        io/async/EventUtil.h \
        io/async/NotificationQueue.h \
        io/async/HHWheelTimer.h \
+       io/async/OpenSSLPtrTypes.h \
        io/async/Request.h \
        io/async/SSLContext.h \
        io/async/ScopedEventBaseThread.h \
@@ -244,12 +262,12 @@ nobase_follyinclude_HEADERS = \
        Padded.h \
        PicoSpinLock.h \
        Portability.h \
+       portability/Syscall.h \
        Preprocessor.h \
        ProducerConsumerQueue.h \
        Random.h \
        Random-inl.h \
        Range.h \
-       ReadMostlySharedPtr.h \
        RWSpinLock.h \
        ScopeGuard.h \
        SharedMutex.h \
@@ -280,6 +298,7 @@ nobase_follyinclude_HEADERS = \
        test/function_benchmark/test_functions.h \
        test/SynchronizedTestLib.h \
        test/SynchronizedTestLib-inl.h \
+       test/TestUtils.h \
        ThreadCachedArena.h \
        ThreadCachedInt.h \
        ThreadLocal.h \
@@ -377,6 +396,8 @@ libfolly_la_SOURCES = \
        TimeoutQueue.cpp \
        Uri.cpp \
        Version.cpp \
+       experimental/bser/Dump.cpp \
+       experimental/bser/Load.cpp \
        experimental/fibers/Baton.cpp \
        experimental/fibers/Fiber.cpp \
        experimental/fibers/FiberManager.cpp \