folly: add bser encode/decode for dynamic
[folly.git] / folly / Makefile.am
index 6509a3a91ca8eecc2d5dfe17ec5eb1e185eea5d2..d37966b3845faaa774edbdbf0dc3a1cf9be32ac2 100644 (file)
@@ -1,4 +1,8 @@
+if FOLLY_TESTMAIN
+SUBDIRS = . experimental init test
+else
 SUBDIRS = . test
+endif
 
 ACLOCAL_AMFLAGS = -I m4
 
@@ -21,21 +25,24 @@ nobase_follyinclude_HEADERS = \
        ApplyTuple.h \
        Arena.h \
        Arena-inl.h \
+       Assume.h \
        AtomicBitSet.h \
        AtomicHashArray.h \
        AtomicHashArray-inl.h \
        AtomicHashMap.h \
        AtomicHashMap-inl.h \
+       AtomicIntrusiveLinkedList.h \
        AtomicLinkedList.h \
        AtomicStruct.h \
        AtomicUnorderedMap.h \
+       CppAttributes.h \
        Baton.h \
        Benchmark.h \
        Bits.h \
        Checksum.h \
-       Chrono.h \
        ConcurrentSkipList.h \
        ConcurrentSkipList-inl.h \
+       ContainerTraits.h \
        Conv.h \
        CpuId.h \
        CPortability.h \
@@ -57,6 +64,8 @@ nobase_follyinclude_HEADERS = \
        detail/Malloc.h \
        detail/MemoryIdler.h \
        detail/MPMCPipelineDetail.h \
+       detail/RangeCommon.h \
+       detail/RangeSse42.h \
        detail/Sleeper.h \
        detail/SlowFingerprint.h \
        detail/SpinLockImpl.h \
@@ -80,6 +89,7 @@ nobase_follyinclude_HEADERS = \
        experimental/EliasFanoCoding.h \
        experimental/EventCount.h \
        experimental/Instructions.h \
+       experimental/bser/Bser.h \
        experimental/fibers/AddTasks.h \
        experimental/fibers/AddTasks-inl.h \
        experimental/fibers/Baton.h \
@@ -113,12 +123,22 @@ nobase_follyinclude_HEADERS = \
        experimental/LockFreeRingBuffer.h \
        experimental/NestedCommandLineApp.h \
        experimental/ProgramOptions.h \
+       experimental/ReadMostlySharedPtr.h \
+       experimental/symbolizer/Elf.h \
+       experimental/symbolizer/ElfCache.h \
+       experimental/symbolizer/Dwarf.h \
+       experimental/symbolizer/LineReader.h \
+       experimental/symbolizer/SignalHandler.h \
+       experimental/symbolizer/StackTrace.cpp \
+       experimental/symbolizer/Symbolizer.h \
        experimental/Select64.h \
        experimental/StringKeyedCommon.h \
        experimental/StringKeyedUnorderedMap.h \
        experimental/StringKeyedUnorderedSet.h \
        experimental/TestUtil.h \
+       experimental/TLRefCount.h \
        experimental/TupleOps.h \
+       SparseByteSet.h \
        FBString.h \
        FBVector.h \
        File.h \
@@ -131,7 +151,6 @@ nobase_follyinclude_HEADERS = \
        Format.h \
        Format-inl.h \
        futures/Barrier.h \
-       futures/Deprecated.h \
        futures/ThreadedExecutor.h \
        futures/DrivableExecutor.h \
        futures/Future-pre.h \
@@ -148,13 +167,13 @@ nobase_follyinclude_HEADERS = \
        futures/ScheduledExecutor.h \
        futures/SharedPromise.h \
        futures/SharedPromise-inl.h \
+       futures/ThreadWheelTimekeeper.h \
        futures/Timekeeper.h \
        futures/Try-inl.h \
        futures/Try.h \
        futures/Unit.h \
        futures/detail/Core.h \
        futures/detail/FSM.h \
-       futures/detail/ThreadWheelTimekeeper.h \
        futures/detail/Types.h \
        gen/Base.h \
        gen/Base-inl.h \
@@ -177,6 +196,7 @@ nobase_follyinclude_HEADERS = \
        IPAddressV6.h \
        IPAddressException.h \
        IndexedMemPool.h \
+       init/Init.h \
        IntrusiveList.h \
        io/Compression.h \
        io/Cursor.h \
@@ -186,6 +206,7 @@ nobase_follyinclude_HEADERS = \
        io/RecordIO-inl.h \
        io/TypedIOBuf.h \
        io/ShutdownSocketSet.h \
+       io/async/AsyncPipe.h \
        io/async/AsyncTimeout.h \
        io/async/AsyncTransport.h \
        io/async/AsyncUDPServerSocket.h \
@@ -199,12 +220,14 @@ nobase_follyinclude_HEADERS = \
        io/async/DelayedDestructionBase.h \
        io/async/DelayedDestruction.h \
        io/async/EventBase.h \
+       io/async/EventBaseLocal.h \
        io/async/EventBaseManager.h \
        io/async/EventFDWrapper.h \
        io/async/EventHandler.h \
        io/async/EventUtil.h \
        io/async/NotificationQueue.h \
        io/async/HHWheelTimer.h \
+       io/async/OpenSSLPtrTypes.h \
        io/async/Request.h \
        io/async/SSLContext.h \
        io/async/ScopedEventBaseThread.h \
@@ -215,6 +238,7 @@ nobase_follyinclude_HEADERS = \
        io/async/test/MockAsyncServerSocket.h \
        io/async/test/MockAsyncSSLSocket.h \
        io/async/test/MockAsyncTransport.h \
+       io/async/test/MockAsyncUDPSocket.h \
        io/async/test/SocketPair.h \
        io/async/test/TimeUtil.h \
        io/async/test/UndelayedDestruction.h \
@@ -238,6 +262,7 @@ nobase_follyinclude_HEADERS = \
        Padded.h \
        PicoSpinLock.h \
        Portability.h \
+       portability/Syscall.h \
        Preprocessor.h \
        ProducerConsumerQueue.h \
        Random.h \
@@ -261,6 +286,8 @@ nobase_follyinclude_HEADERS = \
        stats/Histogram.h \
        stats/MultiLevelTimeSeries-defs.h \
        stats/MultiLevelTimeSeries.h \
+       stats/TimeseriesHistogram-defs.h \
+       stats/TimeseriesHistogram.h \
        String.h \
        String-inl.h \
        Subprocess.h \
@@ -271,6 +298,7 @@ nobase_follyinclude_HEADERS = \
        test/function_benchmark/test_functions.h \
        test/SynchronizedTestLib.h \
        test/SynchronizedTestLib-inl.h \
+       test/TestUtils.h \
        ThreadCachedArena.h \
        ThreadCachedInt.h \
        ThreadLocal.h \
@@ -298,30 +326,32 @@ CLEANFILES += GroupVarintTables.cpp
 libfollybase_la_SOURCES = \
        Conv.cpp \
        Demangle.cpp \
+       detail/RangeCommon.cpp \
+       detail/RangeSse42.cpp \
        EscapeTables.cpp \
        Format.cpp \
        FormatTables.cpp \
-       Malloc.cpp \
-       Range.cpp \
        StringBase.cpp \
        String.cpp \
        Unicode.cpp
 
 libfolly_la_SOURCES = \
        Bits.cpp \
+       Checksum.cpp \
        detail/CacheLocality.cpp \
        dynamic.cpp \
        File.cpp \
        FileUtil.cpp \
        FingerprintTables.cpp \
-       futures/detail/ThreadWheelTimekeeper.cpp \
        futures/Barrier.cpp \
        futures/ThreadedExecutor.cpp \
        futures/Future.cpp \
        futures/InlineExecutor.cpp \
        futures/ManualExecutor.cpp \
        futures/QueuedImmediateExecutor.cpp \
+       futures/ThreadWheelTimekeeper.cpp \
        detail/Futex.cpp \
+       detail/ThreadLocalDetail.cpp \
        GroupVarint.cpp \
        GroupVarintTables.cpp \
        IPAddress.cpp \
@@ -333,6 +363,7 @@ libfolly_la_SOURCES = \
        io/IOBufQueue.cpp \
        io/RecordIO.cpp \
        io/ShutdownSocketSet.cpp \
+       io/async/AsyncPipe.cpp \
        io/async/AsyncTimeout.cpp \
        io/async/AsyncUDPSocket.cpp \
        io/async/AsyncServerSocket.cpp \
@@ -340,6 +371,7 @@ libfolly_la_SOURCES = \
        io/async/AsyncSocket.cpp \
        io/async/AsyncSSLSocket.cpp \
        io/async/EventBase.cpp \
+       io/async/EventBaseLocal.cpp \
        io/async/EventBaseManager.cpp \
        io/async/EventHandler.cpp \
        io/async/SSLContext.cpp \
@@ -364,6 +396,8 @@ libfolly_la_SOURCES = \
        TimeoutQueue.cpp \
        Uri.cpp \
        Version.cpp \
+       experimental/bser/Dump.cpp \
+       experimental/bser/Load.cpp \
        experimental/fibers/Baton.cpp \
        experimental/fibers/Fiber.cpp \
        experimental/fibers/FiberManager.cpp \