folly: add bser encode/decode for dynamic
[folly.git] / folly / Makefile.am
index 4a044257a47c91d4f8b1d4468e603d49acc4b31d..d37966b3845faaa774edbdbf0dc3a1cf9be32ac2 100644 (file)
@@ -1,4 +1,8 @@
+if FOLLY_TESTMAIN
+SUBDIRS = . experimental init test
+else
 SUBDIRS = . test
+endif
 
 ACLOCAL_AMFLAGS = -I m4
 
@@ -21,23 +25,29 @@ nobase_follyinclude_HEADERS = \
        ApplyTuple.h \
        Arena.h \
        Arena-inl.h \
+       Assume.h \
        AtomicBitSet.h \
        AtomicHashArray.h \
        AtomicHashArray-inl.h \
        AtomicHashMap.h \
        AtomicHashMap-inl.h \
+       AtomicIntrusiveLinkedList.h \
+       AtomicLinkedList.h \
        AtomicStruct.h \
+       AtomicUnorderedMap.h \
+       CppAttributes.h \
        Baton.h \
        Benchmark.h \
        Bits.h \
        Checksum.h \
-       Chrono.h \
        ConcurrentSkipList.h \
        ConcurrentSkipList-inl.h \
+       ContainerTraits.h \
        Conv.h \
        CpuId.h \
        CPortability.h \
        detail/AtomicHashUtils.h \
+       detail/AtomicUnorderedMapUtils.h \
        detail/BitIteratorDetail.h \
        detail/BitsDetail.h \
        detail/CacheLocality.h \
@@ -54,10 +64,14 @@ nobase_follyinclude_HEADERS = \
        detail/Malloc.h \
        detail/MemoryIdler.h \
        detail/MPMCPipelineDetail.h \
+       detail/RangeCommon.h \
+       detail/RangeSse42.h \
+       detail/Sleeper.h \
        detail/SlowFingerprint.h \
        detail/SpinLockImpl.h \
        detail/Stats.h \
        detail/ThreadLocalDetail.h \
+       detail/TurnSequencer.h \
        detail/UncaughtExceptionCounter.h \
        Demangle.h \
        DiscriminatedPtr.h \
@@ -68,55 +82,63 @@ nobase_follyinclude_HEADERS = \
        ExceptionWrapper.h \
        Executor.h \
        EvictingCacheMap.h \
+       experimental/AutoTimer.h \
        experimental/Bits.h \
+       experimental/BitVectorCoding.h \
+       experimental/ExecutionObserver.h \
        experimental/EliasFanoCoding.h \
        experimental/EventCount.h \
+       experimental/Instructions.h \
+       experimental/bser/Bser.h \
+       experimental/fibers/AddTasks.h \
+       experimental/fibers/AddTasks-inl.h \
+       experimental/fibers/Baton.h \
+       experimental/fibers/Baton-inl.h \
+       experimental/fibers/BoostContextCompatibility.h \
+       experimental/fibers/EventBaseLoopController.h \
+       experimental/fibers/EventBaseLoopController-inl.h \
+       experimental/fibers/Fiber.h \
+       experimental/fibers/Fiber-inl.h \
+       experimental/fibers/FiberManager.h \
+       experimental/fibers/FiberManager-inl.h \
+       experimental/fibers/FiberManagerMap.h \
+       experimental/fibers/ForEach.h \
+       experimental/fibers/ForEach-inl.h \
+       experimental/fibers/GenericBaton.h \
+       experimental/fibers/GuardPageAllocator.h \
+       experimental/fibers/LoopController.h \
+       experimental/fibers/Promise.h \
+       experimental/fibers/Promise-inl.h \
+       experimental/fibers/SimpleLoopController.h \
+       experimental/fibers/TimedMutex.h \
+       experimental/fibers/TimedMutex-inl.h \
+       experimental/fibers/TimeoutController.h \
+       experimental/fibers/traits.h \
+       experimental/fibers/WhenN.h \
+       experimental/fibers/WhenN-inl.h \
+       experimental/FunctionScheduler.h \
+       experimental/FutureDAG.h \
        experimental/io/FsUtil.h \
-       experimental/Singleton.h \
+       experimental/JSONSchema.h \
+       experimental/LockFreeRingBuffer.h \
+       experimental/NestedCommandLineApp.h \
+       experimental/ProgramOptions.h \
+       experimental/ReadMostlySharedPtr.h \
+       experimental/symbolizer/Elf.h \
+       experimental/symbolizer/ElfCache.h \
+       experimental/symbolizer/Dwarf.h \
+       experimental/symbolizer/LineReader.h \
+       experimental/symbolizer/SignalHandler.h \
+       experimental/symbolizer/StackTrace.cpp \
+       experimental/symbolizer/Symbolizer.h \
+       experimental/Select64.h \
+       experimental/StringKeyedCommon.h \
+       experimental/StringKeyedUnorderedMap.h \
+       experimental/StringKeyedUnorderedSet.h \
        experimental/TestUtil.h \
-       experimental/wangle/channel/AsyncSocketHandler.h \
-       experimental/wangle/channel/ChannelHandler.h \
-       experimental/wangle/channel/ChannelHandlerContext.h \
-       experimental/wangle/channel/ChannelPipeline.h \
-       experimental/wangle/channel/OutputBufferingHandler.h \
-       experimental/wangle/concurrent/BlockingQueue.h \
-       experimental/wangle/concurrent/Codel.h \
-       experimental/wangle/concurrent/CPUThreadPoolExecutor.h \
-       experimental/wangle/concurrent/FutureExecutor.h \
-       experimental/wangle/concurrent/GlobalExecutor.h \
-       experimental/wangle/concurrent/IOExecutor.h \
-       experimental/wangle/concurrent/IOThreadPoolExecutor.h \
-       experimental/wangle/concurrent/LifoSemMPMCQueue.h \
-       experimental/wangle/concurrent/NamedThreadFactory.h \
-       experimental/wangle/concurrent/ThreadFactory.h \
-       experimental/wangle/concurrent/ThreadPoolExecutor.h \
-       experimental/wangle/rx/Observable.h \
-       experimental/wangle/rx/Observer.h \
-       experimental/wangle/rx/Subject.h \
-       experimental/wangle/rx/Subscription.h \
-       experimental/wangle/rx/types.h \
-       experimental/wangle/ConnectionManager.h \
-       experimental/wangle/ManagedConnection.h \
-       experimental/wangle/acceptor/Acceptor.h \
-       experimental/wangle/acceptor/ConnectionCounter.h \
-       experimental/wangle/acceptor/SocketOptions.h \
-       experimental/wangle/acceptor/DomainNameMisc.h \
-       experimental/wangle/acceptor/LoadShedConfiguration.h \
-       experimental/wangle/acceptor/NetworkAddress.h \
-       experimental/wangle/acceptor/ServerSocketConfig.h \
-       experimental/wangle/acceptor/TransportInfo.h \
-       experimental/wangle/ssl/ClientHelloExtStats.h \
-       experimental/wangle/ssl/DHParam.h \
-       experimental/wangle/ssl/PasswordInFile.h \
-       experimental/wangle/ssl/SSLCacheOptions.h \
-       experimental/wangle/ssl/SSLCacheProvider.h \
-       experimental/wangle/ssl/SSLContextConfig.h \
-       experimental/wangle/ssl/SSLContextManager.h \
-       experimental/wangle/ssl/SSLSessionCacheManager.h \
-       experimental/wangle/ssl/SSLStats.h \
-       experimental/wangle/ssl/SSLUtil.h \
-       experimental/wangle/ssl/TLSTicketKeyManager.h \
-       experimental/wangle/ssl/TLSTicketKeySeeds.h \
+       experimental/TLRefCount.h \
+       experimental/TupleOps.h \
+       SparseByteSet.h \
        FBString.h \
        FBVector.h \
        File.h \
@@ -125,8 +147,34 @@ nobase_follyinclude_HEADERS = \
        folly-config.h \
        Foreach.h \
        FormatArg.h \
+       FormatTraits.h \
        Format.h \
        Format-inl.h \
+       futures/Barrier.h \
+       futures/ThreadedExecutor.h \
+       futures/DrivableExecutor.h \
+       futures/Future-pre.h \
+       futures/helpers.h \
+       futures/Future.h \
+       futures/Future-inl.h \
+       futures/FutureException.h \
+       futures/InlineExecutor.h \
+       futures/ManualExecutor.h \
+       futures/OpaqueCallbackShunt.h \
+       futures/Promise-inl.h \
+       futures/Promise.h \
+       futures/QueuedImmediateExecutor.h \
+       futures/ScheduledExecutor.h \
+       futures/SharedPromise.h \
+       futures/SharedPromise-inl.h \
+       futures/ThreadWheelTimekeeper.h \
+       futures/Timekeeper.h \
+       futures/Try-inl.h \
+       futures/Try.h \
+       futures/Unit.h \
+       futures/detail/Core.h \
+       futures/detail/FSM.h \
+       futures/detail/Types.h \
        gen/Base.h \
        gen/Base-inl.h \
        gen/Combine.h \
@@ -148,6 +196,7 @@ nobase_follyinclude_HEADERS = \
        IPAddressV6.h \
        IPAddressException.h \
        IndexedMemPool.h \
+       init/Init.h \
        IntrusiveList.h \
        io/Compression.h \
        io/Cursor.h \
@@ -157,26 +206,40 @@ nobase_follyinclude_HEADERS = \
        io/RecordIO-inl.h \
        io/TypedIOBuf.h \
        io/ShutdownSocketSet.h \
+       io/async/AsyncPipe.h \
        io/async/AsyncTimeout.h \
        io/async/AsyncTransport.h \
        io/async/AsyncUDPServerSocket.h \
        io/async/AsyncUDPSocket.h \
        io/async/AsyncServerSocket.h \
-       io/async/AsyncSSLServerSocket.h \
+       io/async/AsyncSignalHandler.h \
        io/async/AsyncSocket.h \
+       io/async/AsyncSocketBase.h \
        io/async/AsyncSSLSocket.h \
        io/async/AsyncSocketException.h \
+       io/async/DelayedDestructionBase.h \
        io/async/DelayedDestruction.h \
        io/async/EventBase.h \
+       io/async/EventBaseLocal.h \
        io/async/EventBaseManager.h \
        io/async/EventFDWrapper.h \
        io/async/EventHandler.h \
        io/async/EventUtil.h \
        io/async/NotificationQueue.h \
        io/async/HHWheelTimer.h \
+       io/async/OpenSSLPtrTypes.h \
        io/async/Request.h \
        io/async/SSLContext.h \
+       io/async/ScopedEventBaseThread.h \
        io/async/TimeoutManager.h \
+       io/async/test/AsyncSSLSocketTest.h \
+       io/async/test/BlockingSocket.h \
+       io/async/test/MockAsyncSocket.h \
+       io/async/test/MockAsyncServerSocket.h \
+       io/async/test/MockAsyncSSLSocket.h \
+       io/async/test/MockAsyncTransport.h \
+       io/async/test/MockAsyncUDPSocket.h \
+       io/async/test/SocketPair.h \
        io/async/test/TimeUtil.h \
        io/async/test/UndelayedDestruction.h \
        io/async/test/Util.h \
@@ -190,13 +253,16 @@ nobase_follyinclude_HEADERS = \
        MapUtil.h \
        Memory.h \
        MemoryMapping.h \
+       MicroSpinLock.h \
        MoveWrapper.h \
        MPMCPipeline.h \
        MPMCQueue.h \
        Optional.h \
        PackedSyncPtr.h \
        Padded.h \
+       PicoSpinLock.h \
        Portability.h \
+       portability/Syscall.h \
        Preprocessor.h \
        ProducerConsumerQueue.h \
        Random.h \
@@ -204,6 +270,9 @@ nobase_follyinclude_HEADERS = \
        Range.h \
        RWSpinLock.h \
        ScopeGuard.h \
+       SharedMutex.h \
+       Singleton.h \
+       Singleton-inl.h \
        SmallLocks.h \
        small_vector.h \
        SocketAddress.h \
@@ -217,6 +286,8 @@ nobase_follyinclude_HEADERS = \
        stats/Histogram.h \
        stats/MultiLevelTimeSeries-defs.h \
        stats/MultiLevelTimeSeries.h \
+       stats/TimeseriesHistogram-defs.h \
+       stats/TimeseriesHistogram.h \
        String.h \
        String-inl.h \
        Subprocess.h \
@@ -227,6 +298,7 @@ nobase_follyinclude_HEADERS = \
        test/function_benchmark/test_functions.h \
        test/SynchronizedTestLib.h \
        test/SynchronizedTestLib-inl.h \
+       test/TestUtils.h \
        ThreadCachedArena.h \
        ThreadCachedInt.h \
        ThreadLocal.h \
@@ -237,54 +309,49 @@ nobase_follyinclude_HEADERS = \
        Uri.h \
        Uri-inl.h \
        Varint.h \
-       VersionCheck.h \
-       wangle/futures/Deprecated.h \
-       wangle/futures/Future-inl.h \
-       wangle/futures/Future.h \
-       wangle/futures/InlineExecutor.h \
-       wangle/futures/ManualExecutor.h \
-       wangle/futures/OpaqueCallbackShunt.h \
-       wangle/futures/Promise-inl.h \
-       wangle/futures/Promise.h \
-       wangle/futures/QueuedImmediateExecutor.h \
-       wangle/futures/ScheduledExecutor.h \
-       wangle/futures/Try-inl.h \
-       wangle/futures/Try.h \
-       wangle/futures/WangleException.h \
-       wangle/futures/detail/Core.h \
-       wangle/futures/detail/FSM.h
+       VersionCheck.h
 
 FormatTables.cpp: build/generate_format_tables.py
-       build/generate_format_tables.py
+       $(PYTHON) build/generate_format_tables.py
 CLEANFILES += FormatTables.cpp
 
 EscapeTables.cpp: build/generate_escape_tables.py
-       build/generate_escape_tables.py
+       $(PYTHON) build/generate_escape_tables.py
 CLEANFILES += EscapeTables.cpp
 
 GroupVarintTables.cpp: build/generate_varint_tables.py
-       build/generate_varint_tables.py
+       $(PYTHON) build/generate_varint_tables.py
 CLEANFILES += GroupVarintTables.cpp
 
 libfollybase_la_SOURCES = \
        Conv.cpp \
        Demangle.cpp \
+       detail/RangeCommon.cpp \
+       detail/RangeSse42.cpp \
        EscapeTables.cpp \
        Format.cpp \
        FormatTables.cpp \
-       Malloc.cpp \
-       Range.cpp \
+       StringBase.cpp \
        String.cpp \
        Unicode.cpp
 
 libfolly_la_SOURCES = \
        Bits.cpp \
+       Checksum.cpp \
        detail/CacheLocality.cpp \
        dynamic.cpp \
        File.cpp \
        FileUtil.cpp \
        FingerprintTables.cpp \
+       futures/Barrier.cpp \
+       futures/ThreadedExecutor.cpp \
+       futures/Future.cpp \
+       futures/InlineExecutor.cpp \
+       futures/ManualExecutor.cpp \
+       futures/QueuedImmediateExecutor.cpp \
+       futures/ThreadWheelTimekeeper.cpp \
        detail/Futex.cpp \
+       detail/ThreadLocalDetail.cpp \
        GroupVarint.cpp \
        GroupVarintTables.cpp \
        IPAddress.cpp \
@@ -296,18 +363,21 @@ libfolly_la_SOURCES = \
        io/IOBufQueue.cpp \
        io/RecordIO.cpp \
        io/ShutdownSocketSet.cpp \
+       io/async/AsyncPipe.cpp \
        io/async/AsyncTimeout.cpp \
        io/async/AsyncUDPSocket.cpp \
        io/async/AsyncServerSocket.cpp \
-       io/async/AsyncSSLServerSocket.cpp \
+       io/async/AsyncSignalHandler.cpp \
        io/async/AsyncSocket.cpp \
        io/async/AsyncSSLSocket.cpp \
        io/async/EventBase.cpp \
+       io/async/EventBaseLocal.cpp \
        io/async/EventBaseManager.cpp \
        io/async/EventHandler.cpp \
-       io/async/Request.cpp \
        io/async/SSLContext.cpp \
+       io/async/ScopedEventBaseThread.cpp \
        io/async/HHWheelTimer.cpp \
+       io/async/test/SocketPair.cpp \
        io/async/test/TimeUtil.cpp \
        json.cpp \
        detail/MemoryIdler.cpp \
@@ -315,6 +385,8 @@ libfolly_la_SOURCES = \
        MemoryMapping.cpp \
        Random.cpp \
        SafeAssert.cpp \
+       SharedMutex.cpp \
+       Singleton.cpp \
        SocketAddress.cpp \
        SpookyHashV1.cpp \
        SpookyHashV2.cpp \
@@ -324,28 +396,21 @@ libfolly_la_SOURCES = \
        TimeoutQueue.cpp \
        Uri.cpp \
        Version.cpp \
-       wangle/futures/InlineExecutor.cpp \
-       wangle/futures/ManualExecutor.cpp \
+       experimental/bser/Dump.cpp \
+       experimental/bser/Load.cpp \
+       experimental/fibers/Baton.cpp \
+       experimental/fibers/Fiber.cpp \
+       experimental/fibers/FiberManager.cpp \
+       experimental/fibers/FiberManagerMap.cpp \
+       experimental/fibers/GuardPageAllocator.cpp \
+       experimental/fibers/TimeoutController.cpp \
+       experimental/FunctionScheduler.cpp \
        experimental/io/FsUtil.cpp \
-       experimental/Singleton.cpp \
-       experimental/TestUtil.cpp \
-       experimental/wangle/concurrent/CPUThreadPoolExecutor.cpp \
-       experimental/wangle/concurrent/Codel.cpp \
-       experimental/wangle/concurrent/GlobalExecutor.cpp \
-       experimental/wangle/concurrent/IOExecutor.cpp \
-       experimental/wangle/concurrent/IOThreadPoolExecutor.cpp \
-       experimental/wangle/concurrent/ThreadPoolExecutor.cpp \
-       experimental/wangle/ConnectionManager.cpp \
-       experimental/wangle/ManagedConnection.cpp \
-       experimental/wangle/acceptor/Acceptor.cpp \
-       experimental/wangle/acceptor/SocketOptions.cpp \
-       experimental/wangle/acceptor/LoadShedConfiguration.cpp \
-       experimental/wangle/acceptor/TransportInfo.cpp \
-       experimental/wangle/ssl/PasswordInFile.cpp \
-       experimental/wangle/ssl/SSLContextManager.cpp \
-       experimental/wangle/ssl/SSLSessionCacheManager.cpp \
-       experimental/wangle/ssl/SSLUtil.cpp \
-       experimental/wangle/ssl/TLSTicketKeyManager.cpp
+       experimental/JSONSchema.cpp \
+       experimental/NestedCommandLineApp.cpp \
+       experimental/ProgramOptions.cpp \
+       experimental/Select64.cpp \
+       experimental/TestUtil.cpp
 
 if HAVE_LINUX
 nobase_follyinclude_HEADERS += \
@@ -355,7 +420,6 @@ libfolly_la_SOURCES += \
 endif
 
 if !HAVE_LINUX
-nobase_follyinclude_HEADERS += detail/Clock.h
 libfollybase_la_SOURCES += detail/Clock.cpp
 endif