fix Makefile.am formatting
[folly.git] / folly / Makefile.am
index ce7f1e5015e9e562223c3a7a0c48bd550e036c39..cc14e3ece43f581a563f208a4ca35826988dacbf 100644 (file)
@@ -68,11 +68,17 @@ nobase_follyinclude_HEADERS = \
        ExceptionWrapper.h \
        Executor.h \
        EvictingCacheMap.h \
        ExceptionWrapper.h \
        Executor.h \
        EvictingCacheMap.h \
+       experimental/AutoTimer.h \
        experimental/Bits.h \
        experimental/EliasFanoCoding.h \
        experimental/EventCount.h \
        experimental/Bits.h \
        experimental/EliasFanoCoding.h \
        experimental/EventCount.h \
+       experimental/FunctionScheduler.h \
        experimental/io/FsUtil.h \
        experimental/io/FsUtil.h \
+       experimental/JSONSchema.h \
+       experimental/Select64.h \
+       experimental/SharedMutex.h \
        experimental/Singleton.h \
        experimental/Singleton.h \
+       experimental/Singleton-inl.h \
        experimental/TestUtil.h \
        FBString.h \
        FBVector.h \
        experimental/TestUtil.h \
        FBString.h \
        FBVector.h \
@@ -85,6 +91,7 @@ nobase_follyinclude_HEADERS = \
        Format.h \
        Format-inl.h \
        futures/Deprecated.h \
        Format.h \
        Format-inl.h \
        futures/Deprecated.h \
+       futures/DrivableExecutor.h \
        futures/Future-inl.h \
        futures/Future.h \
        futures/FutureException.h \
        futures/Future-inl.h \
        futures/Future.h \
        futures/FutureException.h \
@@ -137,7 +144,6 @@ nobase_follyinclude_HEADERS = \
        io/async/AsyncUDPServerSocket.h \
        io/async/AsyncUDPSocket.h \
        io/async/AsyncServerSocket.h \
        io/async/AsyncUDPServerSocket.h \
        io/async/AsyncUDPSocket.h \
        io/async/AsyncServerSocket.h \
-       io/async/AsyncSSLServerSocket.h \
        io/async/AsyncSocket.h \
        io/async/AsyncSSLSocket.h \
        io/async/AsyncSocketException.h \
        io/async/AsyncSocket.h \
        io/async/AsyncSSLSocket.h \
        io/async/AsyncSocketException.h \
@@ -223,6 +229,9 @@ nobase_follyinclude_HEADERS = \
        wangle/acceptor/ServerSocketConfig.h \
        wangle/acceptor/SocketOptions.h \
        wangle/acceptor/TransportInfo.h \
        wangle/acceptor/ServerSocketConfig.h \
        wangle/acceptor/SocketOptions.h \
        wangle/acceptor/TransportInfo.h \
+       wangle/bootstrap/ServerBootstrap.h \
+       wangle/bootstrap/ServerBootstrap-inl.h \
+       wangle/bootstrap/ClientBootstrap.h \
        wangle/channel/AsyncSocketHandler.h \
        wangle/channel/ChannelHandler.h \
        wangle/channel/ChannelHandlerContext.h \
        wangle/channel/AsyncSocketHandler.h \
        wangle/channel/ChannelHandler.h \
        wangle/channel/ChannelHandlerContext.h \
@@ -307,7 +316,6 @@ libfolly_la_SOURCES = \
        io/async/AsyncTimeout.cpp \
        io/async/AsyncUDPSocket.cpp \
        io/async/AsyncServerSocket.cpp \
        io/async/AsyncTimeout.cpp \
        io/async/AsyncUDPSocket.cpp \
        io/async/AsyncServerSocket.cpp \
-       io/async/AsyncSSLServerSocket.cpp \
        io/async/AsyncSocket.cpp \
        io/async/AsyncSSLSocket.cpp \
        io/async/EventBase.cpp \
        io/async/AsyncSocket.cpp \
        io/async/AsyncSSLSocket.cpp \
        io/async/EventBase.cpp \
@@ -332,7 +340,11 @@ libfolly_la_SOURCES = \
        TimeoutQueue.cpp \
        Uri.cpp \
        Version.cpp \
        TimeoutQueue.cpp \
        Uri.cpp \
        Version.cpp \
+       experimental/FunctionScheduler.cpp \
        experimental/io/FsUtil.cpp \
        experimental/io/FsUtil.cpp \
+       experimental/JSONSchema.cpp \
+       experimental/Select64.cpp \
+       experimental/SharedMutex.cpp \
        experimental/Singleton.cpp \
        experimental/TestUtil.cpp \
        wangle/acceptor/Acceptor.cpp \
        experimental/Singleton.cpp \
        experimental/TestUtil.cpp \
        wangle/acceptor/Acceptor.cpp \
@@ -341,6 +353,7 @@ libfolly_la_SOURCES = \
        wangle/acceptor/ManagedConnection.cpp \
        wangle/acceptor/SocketOptions.cpp \
        wangle/acceptor/TransportInfo.cpp \
        wangle/acceptor/ManagedConnection.cpp \
        wangle/acceptor/SocketOptions.cpp \
        wangle/acceptor/TransportInfo.cpp \
+       wangle/bootstrap/ServerBootstrap.cpp \
        wangle/concurrent/CPUThreadPoolExecutor.cpp \
        wangle/concurrent/Codel.cpp \
        wangle/concurrent/IOThreadPoolExecutor.cpp \
        wangle/concurrent/CPUThreadPoolExecutor.cpp \
        wangle/concurrent/Codel.cpp \
        wangle/concurrent/IOThreadPoolExecutor.cpp \