fix Makefile.am formatting
[folly.git] / folly / Makefile.am
index 95cc3143ffb7d63ad1330661b05a6f0d2f54fcb3..cc14e3ece43f581a563f208a4ca35826988dacbf 100644 (file)
@@ -68,11 +68,17 @@ nobase_follyinclude_HEADERS = \
        ExceptionWrapper.h \
        Executor.h \
        EvictingCacheMap.h \
+       experimental/AutoTimer.h \
        experimental/Bits.h \
        experimental/EliasFanoCoding.h \
        experimental/EventCount.h \
+       experimental/FunctionScheduler.h \
        experimental/io/FsUtil.h \
+       experimental/JSONSchema.h \
+       experimental/Select64.h \
+       experimental/SharedMutex.h \
        experimental/Singleton.h \
+       experimental/Singleton-inl.h \
        experimental/TestUtil.h \
        FBString.h \
        FBVector.h \
@@ -84,6 +90,25 @@ nobase_follyinclude_HEADERS = \
        FormatArg.h \
        Format.h \
        Format-inl.h \
+       futures/Deprecated.h \
+       futures/DrivableExecutor.h \
+       futures/Future-inl.h \
+       futures/Future.h \
+       futures/FutureException.h \
+       futures/InlineExecutor.h \
+       futures/ManualExecutor.h \
+       futures/OpaqueCallbackShunt.h \
+       futures/Promise-inl.h \
+       futures/Promise.h \
+       futures/QueuedImmediateExecutor.h \
+       futures/ScheduledExecutor.h \
+       futures/Timekeeper.h \
+       futures/Try-inl.h \
+       futures/Try.h \
+       futures/detail/Core.h \
+       futures/detail/FSM.h \
+       futures/detail/ThreadWheelTimekeeper.h \
+       futures/detail/Types.h \
        gen/Base.h \
        gen/Base-inl.h \
        gen/Combine.h \
@@ -119,7 +144,6 @@ nobase_follyinclude_HEADERS = \
        io/async/AsyncUDPServerSocket.h \
        io/async/AsyncUDPSocket.h \
        io/async/AsyncServerSocket.h \
-       io/async/AsyncSSLServerSocket.h \
        io/async/AsyncSocket.h \
        io/async/AsyncSSLSocket.h \
        io/async/AsyncSocketException.h \
@@ -205,6 +229,9 @@ nobase_follyinclude_HEADERS = \
        wangle/acceptor/ServerSocketConfig.h \
        wangle/acceptor/SocketOptions.h \
        wangle/acceptor/TransportInfo.h \
+       wangle/bootstrap/ServerBootstrap.h \
+       wangle/bootstrap/ServerBootstrap-inl.h \
+       wangle/bootstrap/ClientBootstrap.h \
        wangle/channel/AsyncSocketHandler.h \
        wangle/channel/ChannelHandler.h \
        wangle/channel/ChannelHandlerContext.h \
@@ -221,21 +248,6 @@ nobase_follyinclude_HEADERS = \
        wangle/concurrent/NamedThreadFactory.h \
        wangle/concurrent/ThreadFactory.h \
        wangle/concurrent/ThreadPoolExecutor.h \
-       wangle/futures/Deprecated.h \
-       wangle/futures/Future-inl.h \
-       wangle/futures/Future.h \
-       wangle/futures/InlineExecutor.h \
-       wangle/futures/ManualExecutor.h \
-       wangle/futures/OpaqueCallbackShunt.h \
-       wangle/futures/Promise-inl.h \
-       wangle/futures/Promise.h \
-       wangle/futures/QueuedImmediateExecutor.h \
-       wangle/futures/ScheduledExecutor.h \
-       wangle/futures/Try-inl.h \
-       wangle/futures/Try.h \
-       wangle/futures/WangleException.h \
-       wangle/futures/detail/Core.h \
-       wangle/futures/detail/FSM.h \
        wangle/rx/Observable.h \
        wangle/rx/Observer.h \
        wangle/rx/Subject.h \
@@ -284,6 +296,11 @@ libfolly_la_SOURCES = \
        File.cpp \
        FileUtil.cpp \
        FingerprintTables.cpp \
+       futures/detail/ThreadWheelTimekeeper.cpp \
+       futures/Future.cpp \
+       futures/InlineExecutor.cpp \
+       futures/ManualExecutor.cpp \
+       futures/QueuedImmediateExecutor.cpp \
        detail/Futex.cpp \
        GroupVarint.cpp \
        GroupVarintTables.cpp \
@@ -299,7 +316,6 @@ libfolly_la_SOURCES = \
        io/async/AsyncTimeout.cpp \
        io/async/AsyncUDPSocket.cpp \
        io/async/AsyncServerSocket.cpp \
-       io/async/AsyncSSLServerSocket.cpp \
        io/async/AsyncSocket.cpp \
        io/async/AsyncSSLSocket.cpp \
        io/async/EventBase.cpp \
@@ -324,7 +340,11 @@ libfolly_la_SOURCES = \
        TimeoutQueue.cpp \
        Uri.cpp \
        Version.cpp \
+       experimental/FunctionScheduler.cpp \
        experimental/io/FsUtil.cpp \
+       experimental/JSONSchema.cpp \
+       experimental/Select64.cpp \
+       experimental/SharedMutex.cpp \
        experimental/Singleton.cpp \
        experimental/TestUtil.cpp \
        wangle/acceptor/Acceptor.cpp \
@@ -333,14 +353,12 @@ libfolly_la_SOURCES = \
        wangle/acceptor/ManagedConnection.cpp \
        wangle/acceptor/SocketOptions.cpp \
        wangle/acceptor/TransportInfo.cpp \
+       wangle/bootstrap/ServerBootstrap.cpp \
        wangle/concurrent/CPUThreadPoolExecutor.cpp \
        wangle/concurrent/Codel.cpp \
-       wangle/concurrent/IOExecutor.cpp \
        wangle/concurrent/IOThreadPoolExecutor.cpp \
        wangle/concurrent/GlobalExecutor.cpp \
        wangle/concurrent/ThreadPoolExecutor.cpp \
-       wangle/futures/InlineExecutor.cpp \
-       wangle/futures/ManualExecutor.cpp \
        wangle/ssl/PasswordInFile.cpp \
        wangle/ssl/SSLContextManager.cpp \
        wangle/ssl/SSLSessionCacheManager.cpp \