fix Makefile.am formatting
[folly.git] / folly / Makefile.am
index 944fd36fafb08be3396ac12cda53ccd3f7a1416f..cc14e3ece43f581a563f208a4ca35826988dacbf 100644 (file)
@@ -55,6 +55,7 @@ nobase_follyinclude_HEADERS = \
        detail/MemoryIdler.h \
        detail/MPMCPipelineDetail.h \
        detail/SlowFingerprint.h \
+       detail/SpinLockImpl.h \
        detail/Stats.h \
        detail/ThreadLocalDetail.h \
        detail/UncaughtExceptionCounter.h \
@@ -67,55 +68,18 @@ nobase_follyinclude_HEADERS = \
        ExceptionWrapper.h \
        Executor.h \
        EvictingCacheMap.h \
+       experimental/AutoTimer.h \
        experimental/Bits.h \
        experimental/EliasFanoCoding.h \
        experimental/EventCount.h \
+       experimental/FunctionScheduler.h \
        experimental/io/FsUtil.h \
+       experimental/JSONSchema.h \
+       experimental/Select64.h \
+       experimental/SharedMutex.h \
        experimental/Singleton.h \
+       experimental/Singleton-inl.h \
        experimental/TestUtil.h \
-       experimental/wangle/channel/AsyncSocketHandler.h \
-       experimental/wangle/channel/ChannelHandler.h \
-       experimental/wangle/channel/ChannelHandlerContext.h \
-       experimental/wangle/channel/ChannelPipeline.h \
-       experimental/wangle/channel/OutputBufferingHandler.h \
-       experimental/wangle/concurrent/BlockingQueue.h \
-       experimental/wangle/concurrent/Codel.h \
-       experimental/wangle/concurrent/CPUThreadPoolExecutor.h \
-       experimental/wangle/concurrent/FutureExecutor.h \
-       experimental/wangle/concurrent/GlobalExecutor.h \
-       experimental/wangle/concurrent/IOExecutor.h \
-       experimental/wangle/concurrent/IOThreadPoolExecutor.h \
-       experimental/wangle/concurrent/LifoSemMPMCQueue.h \
-       experimental/wangle/concurrent/NamedThreadFactory.h \
-       experimental/wangle/concurrent/ThreadFactory.h \
-       experimental/wangle/concurrent/ThreadPoolExecutor.h \
-       experimental/wangle/rx/Observable.h \
-       experimental/wangle/rx/Observer.h \
-       experimental/wangle/rx/Subject.h \
-       experimental/wangle/rx/Subscription.h \
-       experimental/wangle/rx/types.h \
-       experimental/wangle/ConnectionManager.h \
-       experimental/wangle/ManagedConnection.h \
-       experimental/wangle/acceptor/Acceptor.h \
-       experimental/wangle/acceptor/ConnectionCounter.h \
-       experimental/wangle/acceptor/SocketOptions.h \
-       experimental/wangle/acceptor/DomainNameMisc.h \
-       experimental/wangle/acceptor/LoadShedConfiguration.h \
-       experimental/wangle/acceptor/NetworkAddress.h \
-       experimental/wangle/acceptor/ServerSocketConfig.h \
-       experimental/wangle/acceptor/TransportInfo.h \
-       experimental/wangle/ssl/ClientHelloExtStats.h \
-       experimental/wangle/ssl/DHParam.h \
-       experimental/wangle/ssl/PasswordInFile.h \
-       experimental/wangle/ssl/SSLCacheOptions.h \
-       experimental/wangle/ssl/SSLCacheProvider.h \
-       experimental/wangle/ssl/SSLContextConfig.h \
-       experimental/wangle/ssl/SSLContextManager.h \
-       experimental/wangle/ssl/SSLSessionCacheManager.h \
-       experimental/wangle/ssl/SSLStats.h \
-       experimental/wangle/ssl/SSLUtil.h \
-       experimental/wangle/ssl/TLSTicketKeyManager.h \
-       experimental/wangle/ssl/TLSTicketKeySeeds.h \
        FBString.h \
        FBVector.h \
        File.h \
@@ -126,6 +90,25 @@ nobase_follyinclude_HEADERS = \
        FormatArg.h \
        Format.h \
        Format-inl.h \
+       futures/Deprecated.h \
+       futures/DrivableExecutor.h \
+       futures/Future-inl.h \
+       futures/Future.h \
+       futures/FutureException.h \
+       futures/InlineExecutor.h \
+       futures/ManualExecutor.h \
+       futures/OpaqueCallbackShunt.h \
+       futures/Promise-inl.h \
+       futures/Promise.h \
+       futures/QueuedImmediateExecutor.h \
+       futures/ScheduledExecutor.h \
+       futures/Timekeeper.h \
+       futures/Try-inl.h \
+       futures/Try.h \
+       futures/detail/Core.h \
+       futures/detail/FSM.h \
+       futures/detail/ThreadWheelTimekeeper.h \
+       futures/detail/Types.h \
        gen/Base.h \
        gen/Base-inl.h \
        gen/Combine.h \
@@ -152,7 +135,6 @@ nobase_follyinclude_HEADERS = \
        io/Cursor.h \
        io/IOBuf.h \
        io/IOBufQueue.h \
-       io/PortableSpinLock.h \
        io/RecordIO.h \
        io/RecordIO-inl.h \
        io/TypedIOBuf.h \
@@ -162,7 +144,6 @@ nobase_follyinclude_HEADERS = \
        io/async/AsyncUDPServerSocket.h \
        io/async/AsyncUDPSocket.h \
        io/async/AsyncServerSocket.h \
-       io/async/AsyncSSLServerSocket.h \
        io/async/AsyncSocket.h \
        io/async/AsyncSSLSocket.h \
        io/async/AsyncSocketException.h \
@@ -238,21 +219,52 @@ nobase_follyinclude_HEADERS = \
        Uri-inl.h \
        Varint.h \
        VersionCheck.h \
-       wangle/futures/Deprecated.h \
-       wangle/futures/Future-inl.h \
-       wangle/futures/Future.h \
-       wangle/futures/InlineExecutor.h \
-       wangle/futures/ManualExecutor.h \
-       wangle/futures/OpaqueCallbackShunt.h \
-       wangle/futures/Promise-inl.h \
-       wangle/futures/Promise.h \
-       wangle/futures/QueuedImmediateExecutor.h \
-       wangle/futures/ScheduledExecutor.h \
-       wangle/futures/Try-inl.h \
-       wangle/futures/Try.h \
-       wangle/futures/WangleException.h \
-       wangle/futures/detail/Core.h \
-       wangle/futures/detail/FSM.h
+       wangle/acceptor/Acceptor.h \
+       wangle/acceptor/ConnectionCounter.h \
+       wangle/acceptor/ConnectionManager.h \
+       wangle/acceptor/DomainNameMisc.h \
+       wangle/acceptor/LoadShedConfiguration.h \
+       wangle/acceptor/ManagedConnection.h \
+       wangle/acceptor/NetworkAddress.h \
+       wangle/acceptor/ServerSocketConfig.h \
+       wangle/acceptor/SocketOptions.h \
+       wangle/acceptor/TransportInfo.h \
+       wangle/bootstrap/ServerBootstrap.h \
+       wangle/bootstrap/ServerBootstrap-inl.h \
+       wangle/bootstrap/ClientBootstrap.h \
+       wangle/channel/AsyncSocketHandler.h \
+       wangle/channel/ChannelHandler.h \
+       wangle/channel/ChannelHandlerContext.h \
+       wangle/channel/ChannelPipeline.h \
+       wangle/channel/OutputBufferingHandler.h \
+       wangle/concurrent/BlockingQueue.h \
+       wangle/concurrent/Codel.h \
+       wangle/concurrent/CPUThreadPoolExecutor.h \
+       wangle/concurrent/FutureExecutor.h \
+       wangle/concurrent/IOExecutor.h \
+       wangle/concurrent/IOThreadPoolExecutor.h \
+       wangle/concurrent/GlobalExecutor.h \
+       wangle/concurrent/LifoSemMPMCQueue.h \
+       wangle/concurrent/NamedThreadFactory.h \
+       wangle/concurrent/ThreadFactory.h \
+       wangle/concurrent/ThreadPoolExecutor.h \
+       wangle/rx/Observable.h \
+       wangle/rx/Observer.h \
+       wangle/rx/Subject.h \
+       wangle/rx/Subscription.h \
+       wangle/rx/types.h \
+       wangle/ssl/ClientHelloExtStats.h \
+       wangle/ssl/DHParam.h \
+       wangle/ssl/PasswordInFile.h \
+       wangle/ssl/SSLCacheOptions.h \
+       wangle/ssl/SSLCacheProvider.h \
+       wangle/ssl/SSLContextConfig.h \
+       wangle/ssl/SSLContextManager.h \
+       wangle/ssl/SSLSessionCacheManager.h \
+       wangle/ssl/SSLStats.h \
+       wangle/ssl/SSLUtil.h \
+       wangle/ssl/TLSTicketKeyManager.h \
+       wangle/ssl/TLSTicketKeySeeds.h
 
 FormatTables.cpp: build/generate_format_tables.py
        build/generate_format_tables.py
@@ -284,6 +296,11 @@ libfolly_la_SOURCES = \
        File.cpp \
        FileUtil.cpp \
        FingerprintTables.cpp \
+       futures/detail/ThreadWheelTimekeeper.cpp \
+       futures/Future.cpp \
+       futures/InlineExecutor.cpp \
+       futures/ManualExecutor.cpp \
+       futures/QueuedImmediateExecutor.cpp \
        detail/Futex.cpp \
        GroupVarint.cpp \
        GroupVarintTables.cpp \
@@ -299,7 +316,6 @@ libfolly_la_SOURCES = \
        io/async/AsyncTimeout.cpp \
        io/async/AsyncUDPSocket.cpp \
        io/async/AsyncServerSocket.cpp \
-       io/async/AsyncSSLServerSocket.cpp \
        io/async/AsyncSocket.cpp \
        io/async/AsyncSSLSocket.cpp \
        io/async/EventBase.cpp \
@@ -324,28 +340,30 @@ libfolly_la_SOURCES = \
        TimeoutQueue.cpp \
        Uri.cpp \
        Version.cpp \
-       wangle/futures/InlineExecutor.cpp \
-       wangle/futures/ManualExecutor.cpp \
+       experimental/FunctionScheduler.cpp \
        experimental/io/FsUtil.cpp \
+       experimental/JSONSchema.cpp \
+       experimental/Select64.cpp \
+       experimental/SharedMutex.cpp \
        experimental/Singleton.cpp \
        experimental/TestUtil.cpp \
-       experimental/wangle/concurrent/CPUThreadPoolExecutor.cpp \
-       experimental/wangle/concurrent/Codel.cpp \
-       experimental/wangle/concurrent/GlobalExecutor.cpp \
-       experimental/wangle/concurrent/IOExecutor.cpp \
-       experimental/wangle/concurrent/IOThreadPoolExecutor.cpp \
-       experimental/wangle/concurrent/ThreadPoolExecutor.cpp \
-       experimental/wangle/ConnectionManager.cpp \
-       experimental/wangle/ManagedConnection.cpp \
-       experimental/wangle/acceptor/Acceptor.cpp \
-       experimental/wangle/acceptor/SocketOptions.cpp \
-       experimental/wangle/acceptor/LoadShedConfiguration.cpp \
-       experimental/wangle/acceptor/TransportInfo.cpp \
-       experimental/wangle/ssl/PasswordInFile.cpp \
-       experimental/wangle/ssl/SSLContextManager.cpp \
-       experimental/wangle/ssl/SSLSessionCacheManager.cpp \
-       experimental/wangle/ssl/SSLUtil.cpp \
-       experimental/wangle/ssl/TLSTicketKeyManager.cpp
+       wangle/acceptor/Acceptor.cpp \
+       wangle/acceptor/ConnectionManager.cpp \
+       wangle/acceptor/LoadShedConfiguration.cpp \
+       wangle/acceptor/ManagedConnection.cpp \
+       wangle/acceptor/SocketOptions.cpp \
+       wangle/acceptor/TransportInfo.cpp \
+       wangle/bootstrap/ServerBootstrap.cpp \
+       wangle/concurrent/CPUThreadPoolExecutor.cpp \
+       wangle/concurrent/Codel.cpp \
+       wangle/concurrent/IOThreadPoolExecutor.cpp \
+       wangle/concurrent/GlobalExecutor.cpp \
+       wangle/concurrent/ThreadPoolExecutor.cpp \
+       wangle/ssl/PasswordInFile.cpp \
+       wangle/ssl/SSLContextManager.cpp \
+       wangle/ssl/SSLSessionCacheManager.cpp \
+       wangle/ssl/SSLUtil.cpp \
+       wangle/ssl/TLSTicketKeyManager.cpp
 
 if HAVE_LINUX
 nobase_follyinclude_HEADERS += \