add makeSystemError*() helper functions
[folly.git] / folly / Makefile.am
index e1c0e4645d632debfe9f28c636d328e9fd9957d8..be999f3c4720aa5f245fb651b12c2f4ad08fc14c 100644 (file)
@@ -5,7 +5,7 @@ endif
 # Note that the order of SUBDIRS matters.
 # Many subdirectories depend on libfollytest from the test directory,
 # so it must appear before other directories
-SUBDIRS = . test experimental $(MAYBE_INIT) io/test stats/test
+SUBDIRS = . test experimental $(MAYBE_INIT) chrono/test io/test stats/test
 
 ACLOCAL_AMFLAGS = -I m4
 
@@ -42,6 +42,7 @@ nobase_follyinclude_HEADERS = \
        Bits.h \
        CachelinePadded.h \
        Chrono.h \
+       chrono/Conv.h \
        ClockGettimeWrappers.h \
        ConcurrentSkipList.h \
        ConcurrentSkipList-inl.h \
@@ -56,6 +57,7 @@ nobase_follyinclude_HEADERS = \
        concurrency/ConcurrentHashMap.h \
        concurrency/CoreCachedSharedPtr.h \
        concurrency/detail/ConcurrentHashMap-detail.h \
+       container/Access.h \
        container/Array.h \
        container/Iterator.h \
        container/Enumerate.h \
@@ -64,6 +66,7 @@ nobase_follyinclude_HEADERS = \
        container/Foreach-inl.h \
        container/SparseByteSet.h \
        ConstexprMath.h \
+       detail/AtFork.h \
        detail/AtomicHashUtils.h \
        detail/AtomicUnorderedMapUtils.h \
        detail/BitIteratorDetail.h \
@@ -154,14 +157,20 @@ nobase_follyinclude_HEADERS = \
        experimental/JSONSchema.h \
        experimental/LockFreeRingBuffer.h \
        experimental/logging/AsyncFileWriter.h \
+       experimental/logging/FileHandlerFactory.h \
        experimental/logging/GlogStyleFormatter.h \
        experimental/logging/ImmediateFileWriter.h \
        experimental/logging/Init.h \
        experimental/logging/LogCategory.h \
+       experimental/logging/LogCategoryConfig.h \
+       experimental/logging/LogConfig.h \
+       experimental/logging/LogConfigParser.h \
        experimental/logging/LogFormatter.h \
        experimental/logging/Logger.h \
        experimental/logging/LoggerDB.h \
        experimental/logging/LogHandler.h \
+       experimental/logging/LogHandlerFactory.h \
+       experimental/logging/LogHandlerConfig.h \
        experimental/logging/LogLevel.h \
        experimental/logging/LogMessage.h \
        experimental/logging/LogName.h \
@@ -313,10 +322,11 @@ nobase_follyinclude_HEADERS = \
        io/async/test/Util.h \
        json.h \
        lang/Assume.h \
+       lang/ColdClass.h \
        lang/Launder.h \
+       lang/RValueReferenceWrapper.h \
        lang/SafeAssert.h \
        Lazy.h \
-       LifoSem.h \
        Likely.h \
        LockTraits.h \
        LockTraitsBoost.h \
@@ -423,6 +433,7 @@ nobase_follyinclude_HEADERS = \
        stats/TimeseriesHistogram.h \
        synchronization/AsymmetricMemoryBarrier.h \
        synchronization/CallOnce.h \
+       synchronization/LifoSem.h \
        synchronization/detail/AtomicUtils.h \
        system/MemoryMapping.h \
        system/Shell.h \
@@ -453,7 +464,6 @@ nobase_follyinclude_HEADERS = \
        Try.h \
        Unicode.h \
        Function.h \
-       Functional.h \
        UncaughtExceptions.h \
        Unit.h \
        Uri.h \
@@ -496,6 +506,7 @@ libfolly_la_SOURCES = \
        compression/Compression.cpp \
        compression/Zlib.cpp \
        concurrency/CacheLocality.cpp \
+       detail/AtFork.cpp \
        detail/Futex.cpp \
        detail/IPAddress.cpp \
        detail/StaticSingletonManager.cpp \
@@ -533,7 +544,6 @@ libfolly_la_SOURCES = \
        IPAddress.cpp \
        IPAddressV4.cpp \
        IPAddressV6.cpp \
-       LifoSem.cpp \
        init/Init.cpp \
        io/Cursor.cpp \
        io/IOBuf.cpp \
@@ -567,6 +577,7 @@ libfolly_la_SOURCES = \
        io/async/ssl/SSLErrors.cpp \
        json.cpp \
        lang/Assume.cpp \
+       lang/ColdClass.cpp \
        lang/SafeAssert.cpp \
        detail/MemoryIdler.cpp \
        detail/SocketFastOpen.cpp \
@@ -609,6 +620,7 @@ libfolly_la_SOURCES = \
        stats/MultiLevelTimeSeries.cpp \
        stats/TimeseriesHistogram.cpp \
        synchronization/AsymmetricMemoryBarrier.cpp \
+       synchronization/LifoSem.cpp \
        system/MemoryMapping.cpp \
        system/Shell.cpp \
        system/ThreadName.cpp \
@@ -726,6 +738,10 @@ libfollybase_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LT_VERSION)
 libfolly_la_LIBADD = libfollybase.la
 libfolly_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LT_VERSION) -lssl
 
+if USE_SYMBOLIZER
+libfolly_la_LDFLAGS += -lunwind
+endif
+
 FingerprintTables.cpp: generate_fingerprint_tables
        ./generate_fingerprint_tables
 CLEANFILES += FingerprintTables.cpp