move SharedMutex from folly/experimental to folly
[folly.git] / folly / Makefile.am
index d007fc686df887644eed507d0f1861939fe767ee..bdfbe6d541a3c58baab2858f7590fea7d415446b 100644 (file)
@@ -28,6 +28,7 @@ nobase_follyinclude_HEADERS = \
        AtomicHashMap-inl.h \
        AtomicLinkedList.h \
        AtomicStruct.h \
+       AtomicUnorderedMap.h \
        Baton.h \
        Benchmark.h \
        Bits.h \
@@ -39,6 +40,7 @@ nobase_follyinclude_HEADERS = \
        CpuId.h \
        CPortability.h \
        detail/AtomicHashUtils.h \
+       detail/AtomicUnorderedMapUtils.h \
        detail/BitIteratorDetail.h \
        detail/BitsDetail.h \
        detail/CacheLocality.h \
@@ -98,7 +100,6 @@ nobase_follyinclude_HEADERS = \
        experimental/fibers/TimedMutex.h \
        experimental/fibers/TimedMutex-inl.h \
        experimental/fibers/TimeoutController.h \
-       experimental/fibers/TimeoutController.h \
        experimental/fibers/traits.h \
        experimental/fibers/WhenN.h \
        experimental/fibers/WhenN-inl.h \
@@ -108,7 +109,6 @@ nobase_follyinclude_HEADERS = \
        experimental/JSONSchema.h \
        experimental/LockFreeRingBuffer.h \
        experimental/Select64.h \
-       experimental/SharedMutex.h \
        experimental/StringKeyedCommon.h \
        experimental/StringKeyedUnorderedMap.h \
        experimental/StringKeyedUnorderedSet.h \
@@ -232,6 +232,7 @@ nobase_follyinclude_HEADERS = \
        Range.h \
        RWSpinLock.h \
        ScopeGuard.h \
+       SharedMutex.h \
        Singleton.h \
        Singleton-inl.h \
        SmallLocks.h \
@@ -389,8 +390,9 @@ libfolly_la_SOURCES = \
        MemoryMapping.cpp \
        Random.cpp \
        SafeAssert.cpp \
-       SocketAddress.cpp \
+       SharedMutex.cpp \
        Singleton.cpp \
+       SocketAddress.cpp \
        SpookyHashV1.cpp \
        SpookyHashV2.cpp \
        stats/Instantiations.cpp \
@@ -409,7 +411,6 @@ libfolly_la_SOURCES = \
        experimental/io/FsUtil.cpp \
        experimental/JSONSchema.cpp \
        experimental/Select64.cpp \
-       experimental/SharedMutex.cpp \
        experimental/TestUtil.cpp \
        wangle/acceptor/Acceptor.cpp \
        wangle/acceptor/ConnectionManager.cpp \