move SharedMutex from folly/experimental to folly
[folly.git] / folly / Makefile.am
index ad215492296154bea5207e0f7fde886884ed0178..bdfbe6d541a3c58baab2858f7590fea7d415446b 100644 (file)
@@ -28,6 +28,7 @@ nobase_follyinclude_HEADERS = \
        AtomicHashMap-inl.h \
        AtomicLinkedList.h \
        AtomicStruct.h \
+       AtomicUnorderedMap.h \
        Baton.h \
        Benchmark.h \
        Bits.h \
@@ -39,6 +40,7 @@ nobase_follyinclude_HEADERS = \
        CpuId.h \
        CPortability.h \
        detail/AtomicHashUtils.h \
+       detail/AtomicUnorderedMapUtils.h \
        detail/BitIteratorDetail.h \
        detail/BitsDetail.h \
        detail/CacheLocality.h \
@@ -59,6 +61,7 @@ nobase_follyinclude_HEADERS = \
        detail/SpinLockImpl.h \
        detail/Stats.h \
        detail/ThreadLocalDetail.h \
+       detail/TurnSequencer.h \
        detail/UncaughtExceptionCounter.h \
        Demangle.h \
        DiscriminatedPtr.h \
@@ -71,6 +74,7 @@ nobase_follyinclude_HEADERS = \
        EvictingCacheMap.h \
        experimental/AutoTimer.h \
        experimental/Bits.h \
+       experimental/ExecutionObserver.h \
        experimental/EliasFanoCoding.h \
        experimental/EventCount.h \
        experimental/fibers/AddTasks.h \
@@ -80,10 +84,8 @@ nobase_follyinclude_HEADERS = \
        experimental/fibers/BoostContextCompatibility.h \
        experimental/fibers/EventBaseLoopController.h \
        experimental/fibers/EventBaseLoopController-inl.h \
-       experimental/fibers/ExecutionObserver.h \
        experimental/fibers/Fiber.h \
        experimental/fibers/Fiber-inl.h \
-       experimental/fibers/FiberIOExecutor.h \
        experimental/fibers/FiberManager.h \
        experimental/fibers/FiberManager-inl.h \
        experimental/fibers/FiberManagerMap.h \
@@ -91,24 +93,27 @@ nobase_follyinclude_HEADERS = \
        experimental/fibers/ForEach-inl.h \
        experimental/fibers/GenericBaton.h \
        experimental/fibers/GuardPageAllocator.h \
-       experimental/fibers/GuardPageAllocator-inl.h \
        experimental/fibers/LoopController.h \
        experimental/fibers/Promise.h \
        experimental/fibers/Promise-inl.h \
        experimental/fibers/SimpleLoopController.h \
+       experimental/fibers/TimedMutex.h \
+       experimental/fibers/TimedMutex-inl.h \
        experimental/fibers/TimeoutController.h \
        experimental/fibers/traits.h \
        experimental/fibers/WhenN.h \
        experimental/fibers/WhenN-inl.h \
        experimental/FunctionScheduler.h \
+       experimental/FutureDAG.h \
        experimental/io/FsUtil.h \
        experimental/JSONSchema.h \
+       experimental/LockFreeRingBuffer.h \
        experimental/Select64.h \
-       experimental/SharedMutex.h \
        experimental/StringKeyedCommon.h \
        experimental/StringKeyedUnorderedMap.h \
        experimental/StringKeyedUnorderedSet.h \
        experimental/TestUtil.h \
+       experimental/TupleOps.h \
        FBString.h \
        FBVector.h \
        File.h \
@@ -133,6 +138,8 @@ nobase_follyinclude_HEADERS = \
        futures/Promise.h \
        futures/QueuedImmediateExecutor.h \
        futures/ScheduledExecutor.h \
+       futures/SharedPromise.h \
+       futures/SharedPromise-inl.h \
        futures/Timekeeper.h \
        futures/Try-inl.h \
        futures/Try.h \
@@ -225,6 +232,7 @@ nobase_follyinclude_HEADERS = \
        Range.h \
        RWSpinLock.h \
        ScopeGuard.h \
+       SharedMutex.h \
        Singleton.h \
        Singleton-inl.h \
        SmallLocks.h \
@@ -277,6 +285,7 @@ nobase_follyinclude_HEADERS = \
        wangle/bootstrap/ClientBootstrap.h \
        wangle/channel/AsyncSocketHandler.h \
        wangle/channel/EventBaseHandler.h \
+       wangle/channel/FileRegion.h \
        wangle/channel/Handler.h \
        wangle/channel/HandlerContext.h \
        wangle/channel/HandlerContext-inl.h \
@@ -287,8 +296,10 @@ nobase_follyinclude_HEADERS = \
        wangle/concurrent/BlockingQueue.h \
        wangle/concurrent/Codel.h \
        wangle/concurrent/CPUThreadPoolExecutor.h \
+       wangle/concurrent/FiberIOExecutor.h \
        wangle/concurrent/FutureExecutor.h \
        wangle/concurrent/IOExecutor.h \
+       wangle/concurrent/IOObjectCache.h \
        wangle/concurrent/IOThreadPoolExecutor.h \
        wangle/concurrent/GlobalExecutor.h \
        wangle/concurrent/LifoSemMPMCQueue.h \
@@ -314,15 +325,15 @@ nobase_follyinclude_HEADERS = \
        wangle/ssl/TLSTicketKeySeeds.h
 
 FormatTables.cpp: build/generate_format_tables.py
-       build/generate_format_tables.py
+       $(PYTHON) build/generate_format_tables.py
 CLEANFILES += FormatTables.cpp
 
 EscapeTables.cpp: build/generate_escape_tables.py
-       build/generate_escape_tables.py
+       $(PYTHON) build/generate_escape_tables.py
 CLEANFILES += EscapeTables.cpp
 
 GroupVarintTables.cpp: build/generate_varint_tables.py
-       build/generate_varint_tables.py
+       $(PYTHON) build/generate_varint_tables.py
 CLEANFILES += GroupVarintTables.cpp
 
 libfollybase_la_SOURCES = \
@@ -333,6 +344,7 @@ libfollybase_la_SOURCES = \
        FormatTables.cpp \
        Malloc.cpp \
        Range.cpp \
+       StringBase.cpp \
        String.cpp \
        Unicode.cpp
 
@@ -369,7 +381,6 @@ libfolly_la_SOURCES = \
        io/async/EventBase.cpp \
        io/async/EventBaseManager.cpp \
        io/async/EventHandler.cpp \
-       io/async/Request.cpp \
        io/async/SSLContext.cpp \
        io/async/HHWheelTimer.cpp \
        io/async/test/TimeUtil.cpp \
@@ -379,8 +390,9 @@ libfolly_la_SOURCES = \
        MemoryMapping.cpp \
        Random.cpp \
        SafeAssert.cpp \
-       SocketAddress.cpp \
+       SharedMutex.cpp \
        Singleton.cpp \
+       SocketAddress.cpp \
        SpookyHashV1.cpp \
        SpookyHashV2.cpp \
        stats/Instantiations.cpp \
@@ -393,12 +405,12 @@ libfolly_la_SOURCES = \
        experimental/fibers/Fiber.cpp \
        experimental/fibers/FiberManager.cpp \
        experimental/fibers/FiberManagerMap.cpp \
+       experimental/fibers/GuardPageAllocator.cpp \
        experimental/fibers/TimeoutController.cpp \
        experimental/FunctionScheduler.cpp \
        experimental/io/FsUtil.cpp \
        experimental/JSONSchema.cpp \
        experimental/Select64.cpp \
-       experimental/SharedMutex.cpp \
        experimental/TestUtil.cpp \
        wangle/acceptor/Acceptor.cpp \
        wangle/acceptor/ConnectionManager.cpp \
@@ -426,7 +438,6 @@ libfolly_la_SOURCES += \
 endif
 
 if !HAVE_LINUX
-nobase_follyinclude_HEADERS += detail/Clock.h
 libfollybase_la_SOURCES += detail/Clock.cpp
 endif