move SharedMutex from folly/experimental to folly
[folly.git] / folly / Makefile.am
index 38776bdb2e9c08c3718e1107b1fdeccd8e71fe3b..bdfbe6d541a3c58baab2858f7590fea7d415446b 100644 (file)
@@ -28,6 +28,7 @@ nobase_follyinclude_HEADERS = \
        AtomicHashMap-inl.h \
        AtomicLinkedList.h \
        AtomicStruct.h \
+       AtomicUnorderedMap.h \
        Baton.h \
        Benchmark.h \
        Bits.h \
@@ -39,6 +40,7 @@ nobase_follyinclude_HEADERS = \
        CpuId.h \
        CPortability.h \
        detail/AtomicHashUtils.h \
+       detail/AtomicUnorderedMapUtils.h \
        detail/BitIteratorDetail.h \
        detail/BitsDetail.h \
        detail/CacheLocality.h \
@@ -59,6 +61,7 @@ nobase_follyinclude_HEADERS = \
        detail/SpinLockImpl.h \
        detail/Stats.h \
        detail/ThreadLocalDetail.h \
+       detail/TurnSequencer.h \
        detail/UncaughtExceptionCounter.h \
        Demangle.h \
        DiscriminatedPtr.h \
@@ -90,11 +93,12 @@ nobase_follyinclude_HEADERS = \
        experimental/fibers/ForEach-inl.h \
        experimental/fibers/GenericBaton.h \
        experimental/fibers/GuardPageAllocator.h \
-       experimental/fibers/GuardPageAllocator-inl.h \
        experimental/fibers/LoopController.h \
        experimental/fibers/Promise.h \
        experimental/fibers/Promise-inl.h \
        experimental/fibers/SimpleLoopController.h \
+       experimental/fibers/TimedMutex.h \
+       experimental/fibers/TimedMutex-inl.h \
        experimental/fibers/TimeoutController.h \
        experimental/fibers/traits.h \
        experimental/fibers/WhenN.h \
@@ -103,8 +107,8 @@ nobase_follyinclude_HEADERS = \
        experimental/FutureDAG.h \
        experimental/io/FsUtil.h \
        experimental/JSONSchema.h \
+       experimental/LockFreeRingBuffer.h \
        experimental/Select64.h \
-       experimental/SharedMutex.h \
        experimental/StringKeyedCommon.h \
        experimental/StringKeyedUnorderedMap.h \
        experimental/StringKeyedUnorderedSet.h \
@@ -228,6 +232,7 @@ nobase_follyinclude_HEADERS = \
        Range.h \
        RWSpinLock.h \
        ScopeGuard.h \
+       SharedMutex.h \
        Singleton.h \
        Singleton-inl.h \
        SmallLocks.h \
@@ -280,6 +285,7 @@ nobase_follyinclude_HEADERS = \
        wangle/bootstrap/ClientBootstrap.h \
        wangle/channel/AsyncSocketHandler.h \
        wangle/channel/EventBaseHandler.h \
+       wangle/channel/FileRegion.h \
        wangle/channel/Handler.h \
        wangle/channel/HandlerContext.h \
        wangle/channel/HandlerContext-inl.h \
@@ -293,6 +299,7 @@ nobase_follyinclude_HEADERS = \
        wangle/concurrent/FiberIOExecutor.h \
        wangle/concurrent/FutureExecutor.h \
        wangle/concurrent/IOExecutor.h \
+       wangle/concurrent/IOObjectCache.h \
        wangle/concurrent/IOThreadPoolExecutor.h \
        wangle/concurrent/GlobalExecutor.h \
        wangle/concurrent/LifoSemMPMCQueue.h \
@@ -318,15 +325,15 @@ nobase_follyinclude_HEADERS = \
        wangle/ssl/TLSTicketKeySeeds.h
 
 FormatTables.cpp: build/generate_format_tables.py
-       build/generate_format_tables.py
+       $(PYTHON) build/generate_format_tables.py
 CLEANFILES += FormatTables.cpp
 
 EscapeTables.cpp: build/generate_escape_tables.py
-       build/generate_escape_tables.py
+       $(PYTHON) build/generate_escape_tables.py
 CLEANFILES += EscapeTables.cpp
 
 GroupVarintTables.cpp: build/generate_varint_tables.py
-       build/generate_varint_tables.py
+       $(PYTHON) build/generate_varint_tables.py
 CLEANFILES += GroupVarintTables.cpp
 
 libfollybase_la_SOURCES = \
@@ -383,8 +390,9 @@ libfolly_la_SOURCES = \
        MemoryMapping.cpp \
        Random.cpp \
        SafeAssert.cpp \
-       SocketAddress.cpp \
+       SharedMutex.cpp \
        Singleton.cpp \
+       SocketAddress.cpp \
        SpookyHashV1.cpp \
        SpookyHashV2.cpp \
        stats/Instantiations.cpp \
@@ -397,12 +405,12 @@ libfolly_la_SOURCES = \
        experimental/fibers/Fiber.cpp \
        experimental/fibers/FiberManager.cpp \
        experimental/fibers/FiberManagerMap.cpp \
+       experimental/fibers/GuardPageAllocator.cpp \
        experimental/fibers/TimeoutController.cpp \
        experimental/FunctionScheduler.cpp \
        experimental/io/FsUtil.cpp \
        experimental/JSONSchema.cpp \
        experimental/Select64.cpp \
-       experimental/SharedMutex.cpp \
        experimental/TestUtil.cpp \
        wangle/acceptor/Acceptor.cpp \
        wangle/acceptor/ConnectionManager.cpp \
@@ -430,7 +438,6 @@ libfolly_la_SOURCES += \
 endif
 
 if !HAVE_LINUX
-nobase_follyinclude_HEADERS += detail/Clock.h
 libfollybase_la_SOURCES += detail/Clock.cpp
 endif