Add getCommonName and getSubjectAltName Cert utility helpers
[folly.git] / folly / Makefile.am
index baffeb457cc7f81bf8cbd131ab5d383ec00fd472..ba3a9abf835aba55136a3e6140605232bf3c9479 100644 (file)
@@ -8,11 +8,13 @@ ACLOCAL_AMFLAGS = -I m4
 
 CLEANFILES =
 
+
 noinst_PROGRAMS = generate_fingerprint_tables
 generate_fingerprint_tables_SOURCES = build/GenerateFingerprintTables.cpp
 generate_fingerprint_tables_LDADD = libfollybase.la
 
 noinst_LTLIBRARIES = \
+       libfollybasesse42.la \
        libfollybase.la
 
 lib_LTLIBRARIES = \
@@ -42,6 +44,7 @@ nobase_follyinclude_HEADERS = \
        CachelinePadded.h \
        CallOnce.h \
        Checksum.h \
+       Chrono.h \
        ClockGettimeWrappers.h \
        ConcurrentSkipList.h \
        ConcurrentSkipList-inl.h \
@@ -58,7 +61,6 @@ nobase_follyinclude_HEADERS = \
        detail/CachelinePaddedImpl.h \
        detail/ChecksumDetail.h \
        detail/DiscriminatedPtrDetail.h \
-       detail/ExceptionWrapper.h \
        detail/FileUtilDetail.h \
        detail/FingerprintPolynomial.h \
        detail/Futex.h \
@@ -77,6 +79,7 @@ nobase_follyinclude_HEADERS = \
        detail/StaticSingletonManager.h \
        detail/Stats.h \
        detail/ThreadLocalDetail.h \
+       detail/TryDetail.h \
        detail/TurnSequencer.h \
        detail/UncaughtExceptionCounter.h \
        Demangle.h \
@@ -99,12 +102,14 @@ nobase_follyinclude_HEADERS = \
        experimental/DynamicParser-inl.h \
        experimental/ExecutionObserver.h \
        experimental/EliasFanoCoding.h \
+       experimental/EnvUtil.h \
        experimental/EventCount.h \
        experimental/Instructions.h \
        experimental/bser/Bser.h \
        experimental/FunctionScheduler.h \
        experimental/FutureDAG.h \
        experimental/io/FsUtil.h \
+       experimental/JemallocNodumpAllocator.h \
        experimental/JSONSchema.h \
        experimental/LockFreeRingBuffer.h \
        experimental/NestedCommandLineApp.h \
@@ -121,14 +126,17 @@ nobase_follyinclude_HEADERS = \
        experimental/ProgramOptions.h \
        experimental/ReadMostlySharedPtr.h \
        experimental/symbolizer/Elf.h \
+       experimental/symbolizer/Elf-inl.h \
        experimental/symbolizer/ElfCache.h \
        experimental/symbolizer/Dwarf.h \
        experimental/symbolizer/LineReader.h \
        experimental/symbolizer/SignalHandler.h \
-       experimental/symbolizer/StackTrace.cpp \
+       experimental/symbolizer/StackTrace.h \
        experimental/symbolizer/Symbolizer.h \
        experimental/Select64.h \
        experimental/StringKeyedCommon.h \
+       experimental/StringKeyedMap.h \
+       experimental/StringKeyedSet.h \
        experimental/StringKeyedUnorderedMap.h \
        experimental/StringKeyedUnorderedSet.h \
        experimental/TestUtil.h \
@@ -139,6 +147,7 @@ nobase_follyinclude_HEADERS = \
        File.h \
        FileUtil.h \
        Fingerprint.h \
+       FixedString.h \
        folly-config.h \
        Foreach.h \
        FormatArg.h \
@@ -152,6 +161,7 @@ nobase_follyinclude_HEADERS = \
        futures/Future.h \
        futures/Future-inl.h \
        futures/FutureException.h \
+       futures/FutureSplitter.h \
        futures/InlineExecutor.h \
        futures/ManualExecutor.h \
        futures/OpaqueCallbackShunt.h \
@@ -216,6 +226,7 @@ nobase_follyinclude_HEADERS = \
        io/async/EventBase.h \
        io/async/EventBaseLocal.h \
        io/async/EventBaseManager.h \
+       io/async/EventBaseThread.h \
        io/async/EventFDWrapper.h \
        io/async/EventHandler.h \
        io/async/EventUtil.h \
@@ -229,8 +240,10 @@ nobase_follyinclude_HEADERS = \
        io/async/SSLContext.h \
        io/async/ScopedEventBaseThread.h \
        io/async/TimeoutManager.h \
+       io/async/VirtualEventBase.h \
        io/async/WriteChainAsyncTransportWrapper.h \
        io/async/test/AsyncSSLSocketTest.h \
+       io/async/test/AsyncSocketTest2.h \
        io/async/test/BlockingSocket.h \
        io/async/test/MockAsyncSocket.h \
        io/async/test/MockAsyncServerSocket.h \
@@ -240,6 +253,7 @@ nobase_follyinclude_HEADERS = \
        io/async/test/MockTimeoutManager.h \
        io/async/test/ScopedBoundPort.h \
        io/async/test/SocketPair.h \
+       io/async/test/TestSSLServer.h \
        io/async/test/TimeUtil.h \
        io/async/test/UndelayedDestruction.h \
        io/async/test/Util.h \
@@ -254,6 +268,7 @@ nobase_follyinclude_HEADERS = \
        MallctlHelper.h \
        Malloc.h \
        MapUtil.h \
+       Math.h \
        Memory.h \
        MemoryMapping.h \
        MicroSpinLock.h \
@@ -274,15 +289,17 @@ nobase_follyinclude_HEADERS = \
        portability/Config.h \
        portability/Constexpr.h \
        portability/Dirent.h \
-       portability/Environment.h \
        portability/Event.h \
        portability/Fcntl.h \
        portability/GFlags.h \
+       portability/GMock.h \
+       portability/GTest.h \
        portability/IOVec.h \
        portability/Libgen.h \
        portability/Malloc.h \
        portability/Math.h \
        portability/Memory.h \
+       portability/OpenSSL.h \
        portability/PThread.h \
        portability/Sockets.h \
        portability/Stdio.h \
@@ -303,13 +320,16 @@ nobase_follyinclude_HEADERS = \
        portability/Windows.h \
        portability/Unistd.h \
        Preprocessor.h \
+       PriorityMPMCQueue.h \
        ProducerConsumerQueue.h \
        Random.h \
        Random-inl.h \
        Range.h \
        RWSpinLock.h \
+       SafeAssert.h \
        ScopeGuard.h \
        SharedMutex.h \
+       Shell.h \
        Singleton.h \
        Singleton-inl.h \
        SingletonThreadLocal.h \
@@ -321,7 +341,11 @@ nobase_follyinclude_HEADERS = \
        SpinLock.h \
        SpookyHashV1.h \
        SpookyHashV2.h \
+       ssl/OpenSSLCertUtils.h \
        ssl/OpenSSLHash.h \
+       ssl/OpenSSLVersionFinder.h \
+       ssl/SSLSession.h \
+       ssl/detail/SSLSessionImpl.h \
        stats/BucketedTimeSeries-defs.h \
        stats/BucketedTimeSeries.h \
        stats/Histogram-defs.h \
@@ -344,18 +368,22 @@ nobase_follyinclude_HEADERS = \
        test/TestUtils.h \
        ThreadCachedArena.h \
        ThreadCachedInt.h \
+       ThreadId.h \
        ThreadLocal.h \
        ThreadName.h \
        TimeoutQueue.h \
        TokenBucket.h \
+       tracing/StaticTracepoint.h \
        Traits.h \
        Try-inl.h \
        Try.h \
        Unicode.h \
        Function.h \
+       UncaughtExceptions.h \
        Unit.h \
        Uri.h \
        Uri-inl.h \
+       Utility.h \
        Varint.h \
        VersionCheck.h
 
@@ -371,15 +399,18 @@ GroupVarintTables.cpp: build/generate_varint_tables.py
        $(PYTHON) build/generate_varint_tables.py
 CLEANFILES += GroupVarintTables.cpp
 
+libfollybasesse42_la_SOURCES = \
+       detail/RangeSse42.cpp
+
 libfollybase_la_SOURCES = \
        Conv.cpp \
        Demangle.cpp \
        detail/RangeCommon.cpp \
-       detail/RangeSse42.cpp \
        EscapeTables.cpp \
        Format.cpp \
        FormatTables.cpp \
        MallctlHelper.cpp \
+       portability/BitsFunctexcept.cpp \
        StringBase.cpp \
        String.cpp \
        Unicode.cpp
@@ -392,6 +423,8 @@ libfolly_la_SOURCES = \
        detail/CacheLocality.cpp \
        detail/IPAddress.cpp \
        dynamic.cpp \
+       ExceptionWrapper.cpp \
+       Executor.cpp \
        File.cpp \
        FileUtil.cpp \
        FingerprintTables.cpp \
@@ -410,6 +443,7 @@ libfolly_la_SOURCES = \
        IPAddressV4.cpp \
        IPAddressV6.cpp \
        LifoSem.cpp \
+       init/Init.cpp \
        io/Compression.cpp \
        io/Cursor.cpp \
        io/IOBuf.cpp \
@@ -426,11 +460,14 @@ libfolly_la_SOURCES = \
        io/async/EventBase.cpp \
        io/async/EventBaseLocal.cpp \
        io/async/EventBaseManager.cpp \
+       io/async/EventBaseThread.cpp \
        io/async/EventHandler.cpp \
        io/async/Request.cpp \
        io/async/SSLContext.cpp \
        io/async/ScopedEventBaseThread.cpp \
+       io/async/VirtualEventBase.cpp \
        io/async/HHWheelTimer.cpp \
+       io/async/TimeoutManager.cpp \
        io/async/test/ScopedBoundPort.cpp \
        io/async/test/SocketPair.cpp \
        io/async/test/TimeUtil.cpp \
@@ -441,13 +478,12 @@ libfolly_la_SOURCES = \
        detail/SocketFastOpen.cpp \
        MacAddress.cpp \
        MemoryMapping.cpp \
-       portability/BitsFunctexcept.cpp \
        portability/Dirent.cpp \
-       portability/Environment.cpp \
        portability/Fcntl.cpp \
        portability/Libgen.cpp \
        portability/Malloc.cpp \
        portability/Memory.cpp \
+       portability/OpenSSL.cpp \
        portability/Sockets.cpp \
        portability/Stdio.cpp \
        portability/Stdlib.cpp \
@@ -463,13 +499,17 @@ libfolly_la_SOURCES = \
        portability/Unistd.cpp \
        Random.cpp \
        SafeAssert.cpp \
+       ScopeGuard.cpp \
        SharedMutex.cpp \
+       Shell.cpp \
        MicroLock.cpp \
        Singleton.cpp \
        SocketAddress.cpp \
        SpookyHashV1.cpp \
        SpookyHashV2.cpp \
+       ssl/OpenSSLCertUtils.cpp \
        ssl/OpenSSLHash.cpp \
+       ssl/detail/SSLSessionImpl.cpp \
        stats/Instantiations.cpp \
        Subprocess.cpp \
        ThreadCachedArena.cpp \
@@ -480,8 +520,10 @@ libfolly_la_SOURCES = \
        experimental/bser/Dump.cpp \
        experimental/bser/Load.cpp \
        experimental/DynamicParser.cpp \
+       experimental/EnvUtil.cpp \
        experimental/FunctionScheduler.cpp \
        experimental/io/FsUtil.cpp \
+       experimental/JemallocNodumpAllocator.cpp \
        experimental/JSONSchema.cpp \
        experimental/NestedCommandLineApp.cpp \
        experimental/observer/detail/Core.cpp \
@@ -505,9 +547,13 @@ if HAVE_BOOST_CONTEXT
 nobase_follyinclude_HEADERS += \
        fibers/AddTasks.h \
        fibers/AddTasks-inl.h \
+       fibers/AtomicBatchDispatcher.h \
+       fibers/AtomicBatchDispatcher-inl.h \
        fibers/Baton.h \
        fibers/Baton-inl.h \
+       fibers/BatchDispatcher.h \
        fibers/BoostContextCompatibility.h \
+       fibers/detail/AtomicBatchDispatcher.h \
        fibers/EventBaseLoopController.h \
        fibers/EventBaseLoopController-inl.h \
        fibers/Fiber.h \
@@ -535,6 +581,7 @@ nobase_follyinclude_HEADERS += \
 
 libfolly_la_SOURCES += \
        fibers/Baton.cpp \
+       fibers/detail/AtomicBatchDispatcher.cpp \
        fibers/Fiber.cpp \
        fibers/FiberManager.cpp \
        fibers/FiberManagerMap.cpp \
@@ -543,6 +590,10 @@ libfolly_la_SOURCES += \
        fibers/TimeoutController.cpp
 endif
 
+libfollybasesse42_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LT_VERSION)
+libfollybasesse42_la_CXXFLAGS = -msse4.2
+
+libfollybase_la_LIBADD = libfollybasesse42.la
 libfollybase_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LT_VERSION)
 
 libfolly_la_LIBADD = libfollybase.la