Add getCommonName and getSubjectAltName Cert utility helpers
[folly.git] / folly / Makefile.am
index b353b1bfc79c1d59707ea27b5e1737784af5e3ac..ba3a9abf835aba55136a3e6140605232bf3c9479 100644 (file)
@@ -8,6 +8,7 @@ ACLOCAL_AMFLAGS = -I m4
 
 CLEANFILES =
 
+
 noinst_PROGRAMS = generate_fingerprint_tables
 generate_fingerprint_tables_SOURCES = build/GenerateFingerprintTables.cpp
 generate_fingerprint_tables_LDADD = libfollybase.la
@@ -43,6 +44,7 @@ nobase_follyinclude_HEADERS = \
        CachelinePadded.h \
        CallOnce.h \
        Checksum.h \
+       Chrono.h \
        ClockGettimeWrappers.h \
        ConcurrentSkipList.h \
        ConcurrentSkipList-inl.h \
@@ -59,7 +61,6 @@ nobase_follyinclude_HEADERS = \
        detail/CachelinePaddedImpl.h \
        detail/ChecksumDetail.h \
        detail/DiscriminatedPtrDetail.h \
-       detail/ExceptionWrapper.h \
        detail/FileUtilDetail.h \
        detail/FingerprintPolynomial.h \
        detail/Futex.h \
@@ -78,7 +79,7 @@ nobase_follyinclude_HEADERS = \
        detail/StaticSingletonManager.h \
        detail/Stats.h \
        detail/ThreadLocalDetail.h \
-  detail/TryDetail.h \
+       detail/TryDetail.h \
        detail/TurnSequencer.h \
        detail/UncaughtExceptionCounter.h \
        Demangle.h \
@@ -101,12 +102,14 @@ nobase_follyinclude_HEADERS = \
        experimental/DynamicParser-inl.h \
        experimental/ExecutionObserver.h \
        experimental/EliasFanoCoding.h \
+       experimental/EnvUtil.h \
        experimental/EventCount.h \
        experimental/Instructions.h \
        experimental/bser/Bser.h \
        experimental/FunctionScheduler.h \
        experimental/FutureDAG.h \
        experimental/io/FsUtil.h \
+       experimental/JemallocNodumpAllocator.h \
        experimental/JSONSchema.h \
        experimental/LockFreeRingBuffer.h \
        experimental/NestedCommandLineApp.h \
@@ -144,6 +147,7 @@ nobase_follyinclude_HEADERS = \
        File.h \
        FileUtil.h \
        Fingerprint.h \
+       FixedString.h \
        folly-config.h \
        Foreach.h \
        FormatArg.h \
@@ -157,6 +161,7 @@ nobase_follyinclude_HEADERS = \
        futures/Future.h \
        futures/Future-inl.h \
        futures/FutureException.h \
+       futures/FutureSplitter.h \
        futures/InlineExecutor.h \
        futures/ManualExecutor.h \
        futures/OpaqueCallbackShunt.h \
@@ -221,6 +226,7 @@ nobase_follyinclude_HEADERS = \
        io/async/EventBase.h \
        io/async/EventBaseLocal.h \
        io/async/EventBaseManager.h \
+       io/async/EventBaseThread.h \
        io/async/EventFDWrapper.h \
        io/async/EventHandler.h \
        io/async/EventUtil.h \
@@ -237,6 +243,7 @@ nobase_follyinclude_HEADERS = \
        io/async/VirtualEventBase.h \
        io/async/WriteChainAsyncTransportWrapper.h \
        io/async/test/AsyncSSLSocketTest.h \
+       io/async/test/AsyncSocketTest2.h \
        io/async/test/BlockingSocket.h \
        io/async/test/MockAsyncSocket.h \
        io/async/test/MockAsyncServerSocket.h \
@@ -246,6 +253,7 @@ nobase_follyinclude_HEADERS = \
        io/async/test/MockTimeoutManager.h \
        io/async/test/ScopedBoundPort.h \
        io/async/test/SocketPair.h \
+       io/async/test/TestSSLServer.h \
        io/async/test/TimeUtil.h \
        io/async/test/UndelayedDestruction.h \
        io/async/test/Util.h \
@@ -281,7 +289,6 @@ nobase_follyinclude_HEADERS = \
        portability/Config.h \
        portability/Constexpr.h \
        portability/Dirent.h \
-       portability/Environment.h \
        portability/Event.h \
        portability/Fcntl.h \
        portability/GFlags.h \
@@ -292,6 +299,7 @@ nobase_follyinclude_HEADERS = \
        portability/Malloc.h \
        portability/Math.h \
        portability/Memory.h \
+       portability/OpenSSL.h \
        portability/PThread.h \
        portability/Sockets.h \
        portability/Stdio.h \
@@ -312,6 +320,7 @@ nobase_follyinclude_HEADERS = \
        portability/Windows.h \
        portability/Unistd.h \
        Preprocessor.h \
+       PriorityMPMCQueue.h \
        ProducerConsumerQueue.h \
        Random.h \
        Random-inl.h \
@@ -332,9 +341,10 @@ nobase_follyinclude_HEADERS = \
        SpinLock.h \
        SpookyHashV1.h \
        SpookyHashV2.h \
+       ssl/OpenSSLCertUtils.h \
        ssl/OpenSSLHash.h \
+       ssl/OpenSSLVersionFinder.h \
        ssl/SSLSession.h \
-       ssl/detail/OpenSSLVersionFinder.h \
        ssl/detail/SSLSessionImpl.h \
        stats/BucketedTimeSeries-defs.h \
        stats/BucketedTimeSeries.h \
@@ -363,14 +373,17 @@ nobase_follyinclude_HEADERS = \
        ThreadName.h \
        TimeoutQueue.h \
        TokenBucket.h \
+       tracing/StaticTracepoint.h \
        Traits.h \
        Try-inl.h \
        Try.h \
        Unicode.h \
        Function.h \
+       UncaughtExceptions.h \
        Unit.h \
        Uri.h \
        Uri-inl.h \
+       Utility.h \
        Varint.h \
        VersionCheck.h
 
@@ -411,6 +424,7 @@ libfolly_la_SOURCES = \
        detail/IPAddress.cpp \
        dynamic.cpp \
        ExceptionWrapper.cpp \
+       Executor.cpp \
        File.cpp \
        FileUtil.cpp \
        FingerprintTables.cpp \
@@ -429,6 +443,7 @@ libfolly_la_SOURCES = \
        IPAddressV4.cpp \
        IPAddressV6.cpp \
        LifoSem.cpp \
+       init/Init.cpp \
        io/Compression.cpp \
        io/Cursor.cpp \
        io/IOBuf.cpp \
@@ -445,6 +460,7 @@ libfolly_la_SOURCES = \
        io/async/EventBase.cpp \
        io/async/EventBaseLocal.cpp \
        io/async/EventBaseManager.cpp \
+       io/async/EventBaseThread.cpp \
        io/async/EventHandler.cpp \
        io/async/Request.cpp \
        io/async/SSLContext.cpp \
@@ -463,11 +479,11 @@ libfolly_la_SOURCES = \
        MacAddress.cpp \
        MemoryMapping.cpp \
        portability/Dirent.cpp \
-       portability/Environment.cpp \
        portability/Fcntl.cpp \
        portability/Libgen.cpp \
        portability/Malloc.cpp \
        portability/Memory.cpp \
+       portability/OpenSSL.cpp \
        portability/Sockets.cpp \
        portability/Stdio.cpp \
        portability/Stdlib.cpp \
@@ -483,6 +499,7 @@ libfolly_la_SOURCES = \
        portability/Unistd.cpp \
        Random.cpp \
        SafeAssert.cpp \
+       ScopeGuard.cpp \
        SharedMutex.cpp \
        Shell.cpp \
        MicroLock.cpp \
@@ -490,6 +507,7 @@ libfolly_la_SOURCES = \
        SocketAddress.cpp \
        SpookyHashV1.cpp \
        SpookyHashV2.cpp \
+       ssl/OpenSSLCertUtils.cpp \
        ssl/OpenSSLHash.cpp \
        ssl/detail/SSLSessionImpl.cpp \
        stats/Instantiations.cpp \
@@ -502,8 +520,10 @@ libfolly_la_SOURCES = \
        experimental/bser/Dump.cpp \
        experimental/bser/Load.cpp \
        experimental/DynamicParser.cpp \
+       experimental/EnvUtil.cpp \
        experimental/FunctionScheduler.cpp \
        experimental/io/FsUtil.cpp \
+       experimental/JemallocNodumpAllocator.cpp \
        experimental/JSONSchema.cpp \
        experimental/NestedCommandLineApp.cpp \
        experimental/observer/detail/Core.cpp \
@@ -533,6 +553,7 @@ nobase_follyinclude_HEADERS += \
        fibers/Baton-inl.h \
        fibers/BatchDispatcher.h \
        fibers/BoostContextCompatibility.h \
+       fibers/detail/AtomicBatchDispatcher.h \
        fibers/EventBaseLoopController.h \
        fibers/EventBaseLoopController-inl.h \
        fibers/Fiber.h \
@@ -560,6 +581,7 @@ nobase_follyinclude_HEADERS += \
 
 libfolly_la_SOURCES += \
        fibers/Baton.cpp \
+       fibers/detail/AtomicBatchDispatcher.cpp \
        fibers/Fiber.cpp \
        fibers/FiberManager.cpp \
        fibers/FiberManagerMap.cpp \