Add getCommonName and getSubjectAltName Cert utility helpers
[folly.git] / folly / Makefile.am
index 6c6d4baf2540134e85b00f348961ff616359b656..ba3a9abf835aba55136a3e6140605232bf3c9479 100644 (file)
@@ -44,6 +44,7 @@ nobase_follyinclude_HEADERS = \
        CachelinePadded.h \
        CallOnce.h \
        Checksum.h \
+       Chrono.h \
        ClockGettimeWrappers.h \
        ConcurrentSkipList.h \
        ConcurrentSkipList-inl.h \
@@ -78,7 +79,7 @@ nobase_follyinclude_HEADERS = \
        detail/StaticSingletonManager.h \
        detail/Stats.h \
        detail/ThreadLocalDetail.h \
-  detail/TryDetail.h \
+       detail/TryDetail.h \
        detail/TurnSequencer.h \
        detail/UncaughtExceptionCounter.h \
        Demangle.h \
@@ -101,6 +102,7 @@ nobase_follyinclude_HEADERS = \
        experimental/DynamicParser-inl.h \
        experimental/ExecutionObserver.h \
        experimental/EliasFanoCoding.h \
+       experimental/EnvUtil.h \
        experimental/EventCount.h \
        experimental/Instructions.h \
        experimental/bser/Bser.h \
@@ -159,6 +161,7 @@ nobase_follyinclude_HEADERS = \
        futures/Future.h \
        futures/Future-inl.h \
        futures/FutureException.h \
+       futures/FutureSplitter.h \
        futures/InlineExecutor.h \
        futures/ManualExecutor.h \
        futures/OpaqueCallbackShunt.h \
@@ -240,6 +243,7 @@ nobase_follyinclude_HEADERS = \
        io/async/VirtualEventBase.h \
        io/async/WriteChainAsyncTransportWrapper.h \
        io/async/test/AsyncSSLSocketTest.h \
+       io/async/test/AsyncSocketTest2.h \
        io/async/test/BlockingSocket.h \
        io/async/test/MockAsyncSocket.h \
        io/async/test/MockAsyncServerSocket.h \
@@ -249,6 +253,7 @@ nobase_follyinclude_HEADERS = \
        io/async/test/MockTimeoutManager.h \
        io/async/test/ScopedBoundPort.h \
        io/async/test/SocketPair.h \
+       io/async/test/TestSSLServer.h \
        io/async/test/TimeUtil.h \
        io/async/test/UndelayedDestruction.h \
        io/async/test/Util.h \
@@ -284,7 +289,6 @@ nobase_follyinclude_HEADERS = \
        portability/Config.h \
        portability/Constexpr.h \
        portability/Dirent.h \
-       portability/Environment.h \
        portability/Event.h \
        portability/Fcntl.h \
        portability/GFlags.h \
@@ -295,6 +299,7 @@ nobase_follyinclude_HEADERS = \
        portability/Malloc.h \
        portability/Math.h \
        portability/Memory.h \
+       portability/OpenSSL.h \
        portability/PThread.h \
        portability/Sockets.h \
        portability/Stdio.h \
@@ -315,6 +320,7 @@ nobase_follyinclude_HEADERS = \
        portability/Windows.h \
        portability/Unistd.h \
        Preprocessor.h \
+       PriorityMPMCQueue.h \
        ProducerConsumerQueue.h \
        Random.h \
        Random-inl.h \
@@ -335,9 +341,10 @@ nobase_follyinclude_HEADERS = \
        SpinLock.h \
        SpookyHashV1.h \
        SpookyHashV2.h \
+       ssl/OpenSSLCertUtils.h \
        ssl/OpenSSLHash.h \
+       ssl/OpenSSLVersionFinder.h \
        ssl/SSLSession.h \
-       ssl/detail/OpenSSLVersionFinder.h \
        ssl/detail/SSLSessionImpl.h \
        stats/BucketedTimeSeries-defs.h \
        stats/BucketedTimeSeries.h \
@@ -472,11 +479,11 @@ libfolly_la_SOURCES = \
        MacAddress.cpp \
        MemoryMapping.cpp \
        portability/Dirent.cpp \
-       portability/Environment.cpp \
        portability/Fcntl.cpp \
        portability/Libgen.cpp \
        portability/Malloc.cpp \
        portability/Memory.cpp \
+       portability/OpenSSL.cpp \
        portability/Sockets.cpp \
        portability/Stdio.cpp \
        portability/Stdlib.cpp \
@@ -500,6 +507,7 @@ libfolly_la_SOURCES = \
        SocketAddress.cpp \
        SpookyHashV1.cpp \
        SpookyHashV2.cpp \
+       ssl/OpenSSLCertUtils.cpp \
        ssl/OpenSSLHash.cpp \
        ssl/detail/SSLSessionImpl.cpp \
        stats/Instantiations.cpp \
@@ -512,6 +520,7 @@ libfolly_la_SOURCES = \
        experimental/bser/Dump.cpp \
        experimental/bser/Load.cpp \
        experimental/DynamicParser.cpp \
+       experimental/EnvUtil.cpp \
        experimental/FunctionScheduler.cpp \
        experimental/io/FsUtil.cpp \
        experimental/JemallocNodumpAllocator.cpp \
@@ -544,6 +553,7 @@ nobase_follyinclude_HEADERS += \
        fibers/Baton-inl.h \
        fibers/BatchDispatcher.h \
        fibers/BoostContextCompatibility.h \
+       fibers/detail/AtomicBatchDispatcher.h \
        fibers/EventBaseLoopController.h \
        fibers/EventBaseLoopController-inl.h \
        fibers/Fiber.h \
@@ -571,6 +581,7 @@ nobase_follyinclude_HEADERS += \
 
 libfolly_la_SOURCES += \
        fibers/Baton.cpp \
+       fibers/detail/AtomicBatchDispatcher.cpp \
        fibers/Fiber.cpp \
        fibers/FiberManager.cpp \
        fibers/FiberManagerMap.cpp \