Shrink integral hasher specialization implementations
[folly.git] / folly / Makefile.am
index f1872fea5b62d859218a451a4b0c0e4df5f96286..ad956fb4177b6d2cf4522425dbd2f5dabc3e62fc 100644 (file)
@@ -46,7 +46,6 @@ nobase_follyinclude_HEADERS = \
        Bits.h \
        CachelinePadded.h \
        CallOnce.h \
-       Checksum.h \
        Chrono.h \
        ClockGettimeWrappers.h \
        ConcurrentSkipList.h \
@@ -59,12 +58,13 @@ nobase_follyinclude_HEADERS = \
        concurrency/CacheLocality.h \
        concurrency/ConcurrentHashMap.h \
        concurrency/CoreCachedSharedPtr.h \
+       concurrency/GlobalThreadPoolList.h \
        concurrency/detail/ConcurrentHashMap-detail.h \
+       ConstexprMath.h \
        detail/AtomicHashUtils.h \
        detail/AtomicUnorderedMapUtils.h \
        detail/AtomicUtils.h \
        detail/BitIteratorDetail.h \
-       detail/ChecksumDetail.h \
        detail/DiscriminatedPtrDetail.h \
        detail/FileUtilDetail.h \
        detail/FingerprintPolynomial.h \
@@ -82,9 +82,27 @@ nobase_follyinclude_HEADERS = \
        detail/SocketFastOpen.h \
        detail/StaticSingletonManager.h \
        detail/ThreadLocalDetail.h \
-       detail/TryDetail.h \
        detail/TurnSequencer.h \
        detail/UncaughtExceptionCounter.h \
+       executors/Async.h \
+       executors/BlockingQueue.h \
+       executors/CPUThreadPoolExecutor.h \
+       executors/Codel.h \
+       executors/FiberIOExecutor.h \
+       executors/FutureExecutor.h \
+       executors/GlobalExecutor.h \
+       executors/IOExecutor.h \
+       executors/IOObjectCache.h \
+       executors/IOThreadPoolExecutor.h \
+       executors/LifoSemMPMCQueue.h \
+       executors/NamedThreadFactory.h \
+       executors/PriorityLifoSemMPMCQueue.h \
+       executors/PriorityThreadFactory.h \
+       executors/SerialExecutor.h \
+       executors/ThreadFactory.h \
+       executors/ThreadPoolExecutor.h \
+       executors/ThreadedExecutor.h \
+       executors/UnboundedBlockingQueue.h \
        Demangle.h \
        DiscriminatedPtr.h \
        DynamicConverter.h \
@@ -161,14 +179,6 @@ nobase_follyinclude_HEADERS = \
        experimental/observer/SimpleObservable-inl.h \
        experimental/ProgramOptions.h \
        experimental/ReadMostlySharedPtr.h \
-       experimental/symbolizer/Elf.h \
-       experimental/symbolizer/Elf-inl.h \
-       experimental/symbolizer/ElfCache.h \
-       experimental/symbolizer/Dwarf.h \
-       experimental/symbolizer/LineReader.h \
-       experimental/symbolizer/SignalHandler.h \
-       experimental/symbolizer/StackTrace.h \
-       experimental/symbolizer/Symbolizer.h \
        experimental/Select64.h \
        experimental/StampedPtr.h \
        experimental/StringKeyedCommon.h \
@@ -187,6 +197,7 @@ nobase_follyinclude_HEADERS = \
        FixedString.h \
        folly-config.h \
        Foreach.h \
+       Foreach-inl.h \
        FormatArg.h \
        FormatTraits.h \
        Format.h \
@@ -204,6 +215,7 @@ nobase_follyinclude_HEADERS = \
        futures/Promise-inl.h \
        futures/Promise.h \
        futures/QueuedImmediateExecutor.h \
+       futures/Retrying.h \
        futures/ScheduledExecutor.h \
        futures/SharedPromise.h \
        futures/SharedPromise-inl.h \
@@ -213,6 +225,8 @@ nobase_follyinclude_HEADERS = \
        futures/detail/FSM.h \
        futures/detail/Types.h \
        futures/test/TestExecutor.h \
+       hash/Checksum.h \
+       hash/detail/ChecksumDetail.h \
        hash/SpookyHashV1.h \
        hash/SpookyHashV2.h \
        gen/Base.h \
@@ -229,7 +243,6 @@ nobase_follyinclude_HEADERS = \
        gen/ParallelMap-inl.h \
        gen/String.h \
        gen/String-inl.h \
-       GlobalThreadPoolList.h \
        GroupVarint.h \
        Hash.h \
        IPAddress.h \
@@ -298,6 +311,8 @@ nobase_follyinclude_HEADERS = \
        io/async/test/TimeUtil.h \
        io/async/test/UndelayedDestruction.h \
        io/async/test/Util.h \
+       io/compression/Utils.h \
+       io/compression/Zlib.h \
        Iterator.h \
        json.h \
        Launder.h \
@@ -425,6 +440,7 @@ nobase_follyinclude_HEADERS = \
        TimeoutQueue.h \
        TokenBucket.h \
        tracing/StaticTracepoint.h \
+       tracing/ScopedTraceSection.h \
        Traits.h \
        Try-inl.h \
        Try.h \
@@ -452,9 +468,9 @@ GroupVarintTables.cpp: build/generate_varint_tables.py
 CLEANFILES += GroupVarintTables.cpp
 
 libfollybasesse42_la_SOURCES = \
-       detail/Crc32cDetail.cpp \
-       detail/ChecksumDetail.cpp \
-       detail/RangeSse42.cpp
+       detail/RangeSse42.cpp \
+       hash/detail/ChecksumDetail.cpp \
+       hash/detail/Crc32cDetail.cpp
 
 libfollybase_la_SOURCES = \
        Conv.cpp \
@@ -471,9 +487,9 @@ libfollybase_la_SOURCES = \
 
 libfolly_la_SOURCES = \
        Assume.cpp \
-       Checksum.cpp \
        ClockGettimeWrappers.cpp \
        concurrency/CacheLocality.cpp \
+       concurrency/GlobalThreadPoolList.cpp \
        detail/Futex.cpp \
        detail/IPAddress.cpp \
        detail/StaticSingletonManager.cpp \
@@ -491,11 +507,18 @@ libfolly_la_SOURCES = \
        futures/QueuedImmediateExecutor.cpp \
        futures/ThreadWheelTimekeeper.cpp \
        futures/test/TestExecutor.cpp \
+       executors/CPUThreadPoolExecutor.cpp \
+       executors/Codel.cpp \
+       executors/GlobalExecutor.cpp \
+       executors/IOThreadPoolExecutor.cpp \
+       executors/SerialExecutor.cpp \
+       executors/ThreadPoolExecutor.cpp \
+       executors/ThreadedExecutor.cpp \
        experimental/hazptr/hazptr.cpp \
        experimental/hazptr/memory_resource.cpp \
-       GlobalThreadPoolList.cpp \
        GroupVarint.cpp \
        GroupVarintTables.cpp \
+       hash/Checksum.cpp \
        hash/SpookyHashV1.cpp \
        hash/SpookyHashV2.cpp \
        IPAddress.cpp \
@@ -515,6 +538,7 @@ libfolly_la_SOURCES = \
        io/async/AsyncServerSocket.cpp \
        io/async/AsyncSignalHandler.cpp \
        io/async/AsyncSocket.cpp \
+       io/async/AsyncSocketException.cpp \
        io/async/AsyncSSLSocket.cpp \
        io/async/EventBase.cpp \
        io/async/EventBaseLocal.cpp \
@@ -533,6 +557,7 @@ libfolly_la_SOURCES = \
        io/async/test/TimeUtil.cpp \
        io/async/ssl/OpenSSLUtils.cpp \
        io/async/ssl/SSLErrors.cpp \
+       io/compression/Zlib.cpp \
        json.cpp \
        detail/MemoryIdler.cpp \
        detail/SocketFastOpen.cpp \
@@ -658,6 +683,27 @@ libfolly_la_SOURCES += \
        fibers/TimeoutController.cpp
 endif
 
+if USE_SYMBOLIZER
+nobase_follyinclude_HEADERS += \
+       experimental/symbolizer/Elf.h \
+       experimental/symbolizer/Elf-inl.h \
+       experimental/symbolizer/ElfCache.h \
+       experimental/symbolizer/Dwarf.h \
+       experimental/symbolizer/LineReader.h \
+       experimental/symbolizer/SignalHandler.h \
+       experimental/symbolizer/StackTrace.h \
+       experimental/symbolizer/Symbolizer.h
+
+libfolly_la_SOURCES += \
+       experimental/symbolizer/Elf.cpp \
+       experimental/symbolizer/ElfCache.cpp \
+       experimental/symbolizer/Dwarf.cpp \
+       experimental/symbolizer/LineReader.cpp \
+       experimental/symbolizer/SignalHandler.cpp \
+       experimental/symbolizer/StackTrace.cpp \
+       experimental/symbolizer/Symbolizer.cpp
+endif
+
 libfollybasesse42_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LT_VERSION)
 libfollybasesse42_la_CXXFLAGS = -msse4.2 -mpclmul