Revert D4832473: [Folly] Disable EnvUtil::setAsCurrentEnvironment() on platforms...
[folly.git] / folly / Makefile.am
index 7e5a02842f18bd881ebe745e7eae1b88a0d16aa4..94c8fe4d5ec80b1294532e39d7eeeda496f09597 100644 (file)
@@ -1,7 +1,7 @@
 if FOLLY_TESTMAIN
-SUBDIRS = . experimental init test
+SUBDIRS = . experimental init test io/test experimental/io/test
 else
-SUBDIRS = . test
+SUBDIRS = . experimental test io/test experimental/io/test
 endif
 
 ACLOCAL_AMFLAGS = -I m4
@@ -55,6 +55,7 @@ nobase_follyinclude_HEADERS = \
        CPortability.h \
        detail/AtomicHashUtils.h \
        detail/AtomicUnorderedMapUtils.h \
+       detail/AtomicUtils.h \
        detail/BitIteratorDetail.h \
        detail/BitsDetail.h \
        detail/CacheLocality.h \
@@ -95,6 +96,8 @@ nobase_follyinclude_HEADERS = \
        Executor.h \
        Expected.h \
        experimental/AsymmetricMemoryBarrier.h \
+       experimental/AtomicSharedPtr.h \
+       experimental/detail/AtomicSharedPtr-detail.h \
        experimental/AutoTimer.h \
        experimental/Bits.h \
        experimental/BitVectorCoding.h \
@@ -161,6 +164,7 @@ nobase_follyinclude_HEADERS = \
        futures/Future.h \
        futures/Future-inl.h \
        futures/FutureException.h \
+       futures/FutureSplitter.h \
        futures/InlineExecutor.h \
        futures/ManualExecutor.h \
        futures/OpaqueCallbackShunt.h \
@@ -175,6 +179,7 @@ nobase_follyinclude_HEADERS = \
        futures/detail/Core.h \
        futures/detail/FSM.h \
        futures/detail/Types.h \
+       futures/test/TestExecutor.h \
        gen/Base.h \
        gen/Base-inl.h \
        gen/Combine.h \
@@ -340,6 +345,7 @@ nobase_follyinclude_HEADERS = \
        SpinLock.h \
        SpookyHashV1.h \
        SpookyHashV2.h \
+       ssl/OpenSSLCertUtils.h \
        ssl/OpenSSLHash.h \
        ssl/OpenSSLVersionFinder.h \
        ssl/SSLSession.h \
@@ -432,6 +438,7 @@ libfolly_la_SOURCES = \
        futures/ManualExecutor.cpp \
        futures/QueuedImmediateExecutor.cpp \
        futures/ThreadWheelTimekeeper.cpp \
+       futures/test/TestExecutor.cpp \
        detail/Futex.cpp \
        detail/StaticSingletonManager.cpp \
        detail/ThreadLocalDetail.cpp \
@@ -505,6 +512,7 @@ libfolly_la_SOURCES = \
        SocketAddress.cpp \
        SpookyHashV1.cpp \
        SpookyHashV2.cpp \
+       ssl/OpenSSLCertUtils.cpp \
        ssl/OpenSSLHash.cpp \
        ssl/detail/SSLSessionImpl.cpp \
        stats/Instantiations.cpp \