Lift the invoke helper in Function.h
[folly.git] / folly / Makefile.am
index cb6c1074e30a8289f9dda588e5b3cda43a6f1973..94b417c27dbd2a6a23d02beab6bca159921ed83e 100644 (file)
@@ -46,7 +46,6 @@ nobase_follyinclude_HEADERS = \
        Bits.h \
        CachelinePadded.h \
        CallOnce.h \
-       Checksum.h \
        Chrono.h \
        ClockGettimeWrappers.h \
        ConcurrentSkipList.h \
@@ -59,13 +58,13 @@ nobase_follyinclude_HEADERS = \
        concurrency/CacheLocality.h \
        concurrency/ConcurrentHashMap.h \
        concurrency/CoreCachedSharedPtr.h \
+       concurrency/GlobalThreadPoolList.h \
        concurrency/detail/ConcurrentHashMap-detail.h \
        ConstexprMath.h \
        detail/AtomicHashUtils.h \
        detail/AtomicUnorderedMapUtils.h \
        detail/AtomicUtils.h \
        detail/BitIteratorDetail.h \
-       detail/ChecksumDetail.h \
        detail/DiscriminatedPtrDetail.h \
        detail/FileUtilDetail.h \
        detail/FingerprintPolynomial.h \
@@ -97,6 +96,7 @@ nobase_follyinclude_HEADERS = \
        executors/IOThreadPoolExecutor.h \
        executors/LifoSemMPMCQueue.h \
        executors/NamedThreadFactory.h \
+       executors/NotificationQueueExecutor.h \
        executors/PriorityLifoSemMPMCQueue.h \
        executors/PriorityThreadFactory.h \
        executors/SerialExecutor.h \
@@ -203,6 +203,7 @@ nobase_follyinclude_HEADERS = \
        FormatTraits.h \
        Format.h \
        Format-inl.h \
+       functional/Invoke.h \
        futures/Barrier.h \
        futures/DrivableExecutor.h \
        futures/Future-pre.h \
@@ -216,6 +217,7 @@ nobase_follyinclude_HEADERS = \
        futures/Promise-inl.h \
        futures/Promise.h \
        futures/QueuedImmediateExecutor.h \
+       futures/Retrying.h \
        futures/ScheduledExecutor.h \
        futures/SharedPromise.h \
        futures/SharedPromise-inl.h \
@@ -225,6 +227,8 @@ nobase_follyinclude_HEADERS = \
        futures/detail/FSM.h \
        futures/detail/Types.h \
        futures/test/TestExecutor.h \
+       hash/Checksum.h \
+       hash/detail/ChecksumDetail.h \
        hash/SpookyHashV1.h \
        hash/SpookyHashV2.h \
        gen/Base.h \
@@ -241,7 +245,6 @@ nobase_follyinclude_HEADERS = \
        gen/ParallelMap-inl.h \
        gen/String.h \
        gen/String-inl.h \
-       GlobalThreadPoolList.h \
        GroupVarint.h \
        Hash.h \
        IPAddress.h \
@@ -467,9 +470,9 @@ GroupVarintTables.cpp: build/generate_varint_tables.py
 CLEANFILES += GroupVarintTables.cpp
 
 libfollybasesse42_la_SOURCES = \
-       detail/Crc32cDetail.cpp \
-       detail/ChecksumDetail.cpp \
-       detail/RangeSse42.cpp
+       detail/RangeSse42.cpp \
+       hash/detail/ChecksumDetail.cpp \
+       hash/detail/Crc32cDetail.cpp
 
 libfollybase_la_SOURCES = \
        Conv.cpp \
@@ -486,9 +489,9 @@ libfollybase_la_SOURCES = \
 
 libfolly_la_SOURCES = \
        Assume.cpp \
-       Checksum.cpp \
        ClockGettimeWrappers.cpp \
        concurrency/CacheLocality.cpp \
+       concurrency/GlobalThreadPoolList.cpp \
        detail/Futex.cpp \
        detail/IPAddress.cpp \
        detail/StaticSingletonManager.cpp \
@@ -515,9 +518,9 @@ libfolly_la_SOURCES = \
        executors/ThreadedExecutor.cpp \
        experimental/hazptr/hazptr.cpp \
        experimental/hazptr/memory_resource.cpp \
-       GlobalThreadPoolList.cpp \
        GroupVarint.cpp \
        GroupVarintTables.cpp \
+       hash/Checksum.cpp \
        hash/SpookyHashV1.cpp \
        hash/SpookyHashV2.cpp \
        IPAddress.cpp \
@@ -537,6 +540,7 @@ libfolly_la_SOURCES = \
        io/async/AsyncServerSocket.cpp \
        io/async/AsyncSignalHandler.cpp \
        io/async/AsyncSocket.cpp \
+       io/async/AsyncSocketException.cpp \
        io/async/AsyncSSLSocket.cpp \
        io/async/EventBase.cpp \
        io/async/EventBaseLocal.cpp \