Small readability improvements
[folly.git] / folly / Makefile.am
index f0a3493570b1029150f4185eeb99ee92d0f6f0c7..706f659c8425842e780a8fc5596f87780aaeb7ab 100644 (file)
@@ -26,8 +26,10 @@ nobase_follyinclude_HEADERS = \
        AtomicHashMap.h \
        AtomicHashMap-inl.h \
        AtomicStruct.h \
+       Baton.h \
        Benchmark.h \
        Bits.h \
+       Checksum.h \
        Chrono.h \
        ConcurrentSkipList.h \
        ConcurrentSkipList-inl.h \
@@ -38,33 +40,47 @@ nobase_follyinclude_HEADERS = \
        detail/BitIteratorDetail.h \
        detail/BitsDetail.h \
        detail/CacheLocality.h \
+       detail/ChecksumDetail.h \
+       detail/Clock.h \
        detail/DiscriminatedPtrDetail.h \
+       detail/ExceptionWrapper.h \
        detail/FileUtilDetail.h \
        detail/FingerprintPolynomial.h \
        detail/FunctionalExcept.h \
        detail/Futex.h \
        detail/GroupVarintDetail.h \
        detail/Malloc.h \
+       detail/MemoryIdler.h \
        detail/MPMCPipelineDetail.h \
        detail/SlowFingerprint.h \
        detail/Stats.h \
        detail/ThreadLocalDetail.h \
+       detail/UncaughtExceptionCounter.h \
+       Demangle.h \
        DiscriminatedPtr.h \
        DynamicConverter.h \
        dynamic.h \
        dynamic-inl.h \
+       Exception.h \
        FBString.h \
        FBVector.h \
        File.h \
        FileUtil.h \
        Fingerprint.h \
        folly-config.h \
+       Exception.h \
+       ExceptionWrapper.h \
        Foreach.h \
        FormatArg.h \
        Format.h \
        Format-inl.h \
        GroupVarint.h \
        Hash.h \
+       IPAddress.h \
+       IPAddressV4.h \
+       IPAddressV6.h \
+       IPAddressException.h \
+       IndexedMemPool.h \
        IntrusiveList.h \
        io/Cursor.h \
        io/IOBuf.h \
@@ -72,10 +88,20 @@ nobase_follyinclude_HEADERS = \
        io/RecordIO.h \
        io/RecordIO-inl.h \
        io/TypedIOBuf.h \
+       io/async/AsyncTimeout.h \
+       io/async/EventBase.h \
+       io/async/EventFDWrapper.h \
+       io/async/EventHandler.h \
+       io/async/EventUtil.h \
+       io/async/NotificationQueue.h \
+       io/async/Request.h \
+       io/async/TimeoutManager.h \
        json.h \
        Lazy.h \
+       LifoSem.h \
        Likely.h \
        Logging.h \
+       MacAddress.h \
        Malloc.h \
        MapUtil.h \
        Memory.h \
@@ -122,7 +148,22 @@ nobase_follyinclude_HEADERS = \
        Unicode.h \
        Uri.h \
        Uri-inl.h \
-       Varint.h
+       Varint.h \
+       wangle/Executor.h \
+       wangle/Future-inl.h \
+       wangle/Future.h \
+       wangle/GenericThreadGate.h \
+       wangle/InlineExecutor.h \
+       wangle/Later-inl.h \
+       wangle/Later.h \
+       wangle/ManualExecutor.h \
+       wangle/Promise-inl.h \
+       wangle/Promise.h \
+       wangle/ThreadGate.h \
+       wangle/Try-inl.h \
+       wangle/Try.h \
+       wangle/WangleException.h \
+       wangle/detail.h
 
 FormatTables.cpp: build/generate_format_tables.py
        build/generate_format_tables.py
@@ -137,9 +178,9 @@ GroupVarintTables.cpp: build/generate_varint_tables.py
 CLEANFILES += GroupVarintTables.cpp
 
 libfolly_la_SOURCES = \
-       Benchmark.cpp \
        Bits.cpp \
        Conv.cpp \
+       Demangle.cpp \
        detail/CacheLocality.cpp \
        dynamic.cpp \
        EscapeTables.cpp \
@@ -147,15 +188,29 @@ libfolly_la_SOURCES = \
        FileUtil.cpp \
        Format.cpp \
        FormatTables.cpp \
+       detail/Futex.cpp \
        GroupVarint.cpp \
        GroupVarintTables.cpp \
+       IPAddress.cpp \
+       IPAddressV4.cpp \
+       IPAddressV6.cpp \
+       LifoSem.cpp \
        io/IOBuf.cpp \
        io/IOBufQueue.cpp \
        io/RecordIO.cpp \
+       io/async/AsyncTimeout.cpp \
+       io/async/EventBase.cpp \
+       io/async/EventHandler.cpp \
+       io/async/Request.cpp \
        json.cpp \
+       detail/MallocImpl.cpp \
+       detail/MemoryIdler.cpp \
+       MacAddress.cpp \
+       Malloc.cpp \
        MemoryMapping.cpp \
        Random.cpp \
        Range.cpp \
+       SafeAssert.cpp \
        SpookyHashV1.cpp \
        SpookyHashV2.cpp \
        stats/Instantiations.cpp \
@@ -164,7 +219,10 @@ libfolly_la_SOURCES = \
        ThreadCachedArena.cpp \
        TimeoutQueue.cpp \
        Unicode.cpp \
-       Uri.cpp
+       Uri.cpp \
+       wangle/InlineExecutor.cpp \
+       wangle/ManualExecutor.cpp \
+       wangle/ThreadGate.cpp
 
 if !HAVE_LINUX
 nobase_follyinclude_HEADERS += detail/Clock.h
@@ -172,7 +230,7 @@ libfolly_la_SOURCES += detail/Clock.cpp
 endif
 
 if !HAVE_WEAK_SYMBOLS
-libfolly_la_SOURCES += detail/Malloc.cpp
+libfolly_la_SOURCES += detail/MallocImpl.cpp
 endif
 
 if !HAVE_BITS_FUNCTEXCEPT
@@ -192,4 +250,3 @@ libfollybenchmark_la_LIBADD = libfolly.la
 
 libfollytimeout_queue_la_SOURCES = TimeoutQueue.cpp
 libfollytimeout_queue_la_LIBADD = libfolly.la
-