Small readability improvements
[folly.git] / folly / Makefile.am
index b420da275fdf919e8b33b6ebe2ef62bb98760834..706f659c8425842e780a8fc5596f87780aaeb7ab 100644 (file)
@@ -29,6 +29,7 @@ nobase_follyinclude_HEADERS = \
        Baton.h \
        Benchmark.h \
        Bits.h \
+       Checksum.h \
        Chrono.h \
        ConcurrentSkipList.h \
        ConcurrentSkipList-inl.h \
@@ -42,6 +43,7 @@ nobase_follyinclude_HEADERS = \
        detail/ChecksumDetail.h \
        detail/Clock.h \
        detail/DiscriminatedPtrDetail.h \
+       detail/ExceptionWrapper.h \
        detail/FileUtilDetail.h \
        detail/FingerprintPolynomial.h \
        detail/FunctionalExcept.h \
@@ -54,10 +56,12 @@ nobase_follyinclude_HEADERS = \
        detail/Stats.h \
        detail/ThreadLocalDetail.h \
        detail/UncaughtExceptionCounter.h \
+       Demangle.h \
        DiscriminatedPtr.h \
        DynamicConverter.h \
        dynamic.h \
        dynamic-inl.h \
+       Exception.h \
        FBString.h \
        FBVector.h \
        File.h \
@@ -65,12 +69,17 @@ nobase_follyinclude_HEADERS = \
        Fingerprint.h \
        folly-config.h \
        Exception.h \
+       ExceptionWrapper.h \
        Foreach.h \
        FormatArg.h \
        Format.h \
        Format-inl.h \
        GroupVarint.h \
        Hash.h \
+       IPAddress.h \
+       IPAddressV4.h \
+       IPAddressV6.h \
+       IPAddressException.h \
        IndexedMemPool.h \
        IntrusiveList.h \
        io/Cursor.h \
@@ -89,8 +98,10 @@ nobase_follyinclude_HEADERS = \
        io/async/TimeoutManager.h \
        json.h \
        Lazy.h \
+       LifoSem.h \
        Likely.h \
        Logging.h \
+       MacAddress.h \
        Malloc.h \
        MapUtil.h \
        Memory.h \
@@ -167,7 +178,6 @@ GroupVarintTables.cpp: build/generate_varint_tables.py
 CLEANFILES += GroupVarintTables.cpp
 
 libfolly_la_SOURCES = \
-       Benchmark.cpp \
        Bits.cpp \
        Conv.cpp \
        Demangle.cpp \
@@ -178,8 +188,13 @@ libfolly_la_SOURCES = \
        FileUtil.cpp \
        Format.cpp \
        FormatTables.cpp \
+       detail/Futex.cpp \
        GroupVarint.cpp \
        GroupVarintTables.cpp \
+       IPAddress.cpp \
+       IPAddressV4.cpp \
+       IPAddressV6.cpp \
+       LifoSem.cpp \
        io/IOBuf.cpp \
        io/IOBufQueue.cpp \
        io/RecordIO.cpp \
@@ -188,10 +203,14 @@ libfolly_la_SOURCES = \
        io/async/EventHandler.cpp \
        io/async/Request.cpp \
        json.cpp \
+       detail/MallocImpl.cpp \
        detail/MemoryIdler.cpp \
+       MacAddress.cpp \
+       Malloc.cpp \
        MemoryMapping.cpp \
        Random.cpp \
        Range.cpp \
+       SafeAssert.cpp \
        SpookyHashV1.cpp \
        SpookyHashV2.cpp \
        stats/Instantiations.cpp \
@@ -211,7 +230,7 @@ libfolly_la_SOURCES += detail/Clock.cpp
 endif
 
 if !HAVE_WEAK_SYMBOLS
-libfolly_la_SOURCES += detail/Malloc.cpp
+libfolly_la_SOURCES += detail/MallocImpl.cpp
 endif
 
 if !HAVE_BITS_FUNCTEXCEPT