Small readability improvements
[folly.git] / folly / Makefile.am
index 49573d0d909c01939a99d59838447005e32c9a00..706f659c8425842e780a8fc5596f87780aaeb7ab 100644 (file)
@@ -2,6 +2,8 @@ SUBDIRS = . test
 
 ACLOCAL_AMFLAGS = -I m4
 
+CLEANFILES =
+
 noinst_PROGRAMS = generate_fingerprint_tables
 generate_fingerprint_tables_SOURCES = build/GenerateFingerprintTables.cpp
 generate_fingerprint_tables_LDADD = libfolly.la
@@ -15,47 +17,101 @@ lib_LTLIBRARIES = \
 follyincludedir = $(includedir)/folly
 
 nobase_follyinclude_HEADERS = \
+       ApplyTuple.h \
        Arena.h \
        Arena-inl.h \
+       AtomicBitSet.h \
        AtomicHashArray.h \
        AtomicHashArray-inl.h \
        AtomicHashMap.h \
        AtomicHashMap-inl.h \
+       AtomicStruct.h \
+       Baton.h \
        Benchmark.h \
        Bits.h \
+       Checksum.h \
+       Chrono.h \
        ConcurrentSkipList.h \
        ConcurrentSkipList-inl.h \
        Conv.h \
+       CpuId.h \
+       CPortability.h \
        detail/AtomicHashUtils.h \
        detail/BitIteratorDetail.h \
+       detail/BitsDetail.h \
+       detail/CacheLocality.h \
+       detail/ChecksumDetail.h \
+       detail/Clock.h \
        detail/DiscriminatedPtrDetail.h \
+       detail/ExceptionWrapper.h \
+       detail/FileUtilDetail.h \
        detail/FingerprintPolynomial.h \
+       detail/FunctionalExcept.h \
+       detail/Futex.h \
        detail/GroupVarintDetail.h \
+       detail/Malloc.h \
+       detail/MemoryIdler.h \
+       detail/MPMCPipelineDetail.h \
        detail/SlowFingerprint.h \
+       detail/Stats.h \
        detail/ThreadLocalDetail.h \
+       detail/UncaughtExceptionCounter.h \
+       Demangle.h \
        DiscriminatedPtr.h \
+       DynamicConverter.h \
        dynamic.h \
        dynamic-inl.h \
-       eventfd.h \
+       Exception.h \
        FBString.h \
        FBVector.h \
+       File.h \
+       FileUtil.h \
        Fingerprint.h \
        folly-config.h \
+       Exception.h \
+       ExceptionWrapper.h \
        Foreach.h \
        FormatArg.h \
        Format.h \
        Format-inl.h \
        GroupVarint.h \
        Hash.h \
-       Histogram.h \
-       Histogram-inl.h \
+       IPAddress.h \
+       IPAddressV4.h \
+       IPAddressV6.h \
+       IPAddressException.h \
+       IndexedMemPool.h \
        IntrusiveList.h \
+       io/Cursor.h \
+       io/IOBuf.h \
+       io/IOBufQueue.h \
+       io/RecordIO.h \
+       io/RecordIO-inl.h \
+       io/TypedIOBuf.h \
+       io/async/AsyncTimeout.h \
+       io/async/EventBase.h \
+       io/async/EventFDWrapper.h \
+       io/async/EventHandler.h \
+       io/async/EventUtil.h \
+       io/async/NotificationQueue.h \
+       io/async/Request.h \
+       io/async/TimeoutManager.h \
        json.h \
+       Lazy.h \
+       LifoSem.h \
        Likely.h \
        Logging.h \
+       MacAddress.h \
        Malloc.h \
        MapUtil.h \
+       Memory.h \
+       MemoryMapping.h \
+       MoveWrapper.h \
+       MPMCPipeline.h \
+       MPMCQueue.h \
+       Optional.h \
        PackedSyncPtr.h \
+       Padded.h \
        Portability.h \
        Preprocessor.h \
        ProducerConsumerQueue.h \
@@ -66,9 +122,17 @@ nobase_follyinclude_HEADERS = \
        SmallLocks.h \
        small_vector.h \
        sorted_vector_types.h \
-       StlAllocator.h \
+       SpookyHashV1.h \
+       SpookyHashV2.h \
+       stats/BucketedTimeSeries-defs.h \
+       stats/BucketedTimeSeries.h \
+       stats/Histogram-defs.h \
+       stats/Histogram.h \
+       stats/MultiLevelTimeSeries-defs.h \
+       stats/MultiLevelTimeSeries.h \
        String.h \
        String-inl.h \
+       Subprocess.h \
        Synchronized.h \
        test/FBStringTestBenchmarks.cpp.h \
        test/FBVectorTestBenchmarks.cpp.h \
@@ -81,41 +145,108 @@ nobase_follyinclude_HEADERS = \
        ThreadLocal.h \
        TimeoutQueue.h \
        Traits.h \
-       Unicode.h
+       Unicode.h \
+       Uri.h \
+       Uri-inl.h \
+       Varint.h \
+       wangle/Executor.h \
+       wangle/Future-inl.h \
+       wangle/Future.h \
+       wangle/GenericThreadGate.h \
+       wangle/InlineExecutor.h \
+       wangle/Later-inl.h \
+       wangle/Later.h \
+       wangle/ManualExecutor.h \
+       wangle/Promise-inl.h \
+       wangle/Promise.h \
+       wangle/ThreadGate.h \
+       wangle/Try-inl.h \
+       wangle/Try.h \
+       wangle/WangleException.h \
+       wangle/detail.h
 
 FormatTables.cpp: build/generate_format_tables.py
        build/generate_format_tables.py
+CLEANFILES += FormatTables.cpp
 
 EscapeTables.cpp: build/generate_escape_tables.py
        build/generate_escape_tables.py
+CLEANFILES += EscapeTables.cpp
 
 GroupVarintTables.cpp: build/generate_varint_tables.py
        build/generate_varint_tables.py
+CLEANFILES += GroupVarintTables.cpp
 
 libfolly_la_SOURCES = \
-       Random.cpp \
-       Range.cpp \
-       Unicode.cpp \
+       Bits.cpp \
        Conv.cpp \
-       json.cpp \
+       Demangle.cpp \
+       detail/CacheLocality.cpp \
        dynamic.cpp \
-       GroupVarint.cpp \
-       GroupVarintTables.cpp \
        EscapeTables.cpp \
-       ThreadCachedArena.cpp \
+       File.cpp \
+       FileUtil.cpp \
        Format.cpp \
        FormatTables.cpp \
-       String.cpp
+       detail/Futex.cpp \
+       GroupVarint.cpp \
+       GroupVarintTables.cpp \
+       IPAddress.cpp \
+       IPAddressV4.cpp \
+       IPAddressV6.cpp \
+       LifoSem.cpp \
+       io/IOBuf.cpp \
+       io/IOBufQueue.cpp \
+       io/RecordIO.cpp \
+       io/async/AsyncTimeout.cpp \
+       io/async/EventBase.cpp \
+       io/async/EventHandler.cpp \
+       io/async/Request.cpp \
+       json.cpp \
+       detail/MallocImpl.cpp \
+       detail/MemoryIdler.cpp \
+       MacAddress.cpp \
+       Malloc.cpp \
+       MemoryMapping.cpp \
+       Random.cpp \
+       Range.cpp \
+       SafeAssert.cpp \
+       SpookyHashV1.cpp \
+       SpookyHashV2.cpp \
+       stats/Instantiations.cpp \
+       String.cpp \
+       Subprocess.cpp \
+       ThreadCachedArena.cpp \
+       TimeoutQueue.cpp \
+       Unicode.cpp \
+       Uri.cpp \
+       wangle/InlineExecutor.cpp \
+       wangle/ManualExecutor.cpp \
+       wangle/ThreadGate.cpp
+
+if !HAVE_LINUX
+nobase_follyinclude_HEADERS += detail/Clock.h
+libfolly_la_SOURCES += detail/Clock.cpp
+endif
+
+if !HAVE_WEAK_SYMBOLS
+libfolly_la_SOURCES += detail/MallocImpl.cpp
+endif
 
-libfolly_la_LIBADD = $(BOOST_THREAD_LIBS) -lpthread
+if !HAVE_BITS_FUNCTEXCEPT
+libfolly_la_SOURCES += detail/FunctionalExcept.cpp
+endif
 
 FingerprintTables.cpp: generate_fingerprint_tables
        ./generate_fingerprint_tables
+CLEANFILES += FingerprintTables.cpp
 
 libfollyfingerprint_la_SOURCES = \
        FingerprintTables.cpp
+libfollyfingerprint_la_LIBADD = libfolly.la
 
 libfollybenchmark_la_SOURCES = Benchmark.cpp
-libfollybenchmark_la_LIBADD = -lboost_regex -lpthread -lrt
+libfollybenchmark_la_LIBADD = libfolly.la
 
 libfollytimeout_queue_la_SOURCES = TimeoutQueue.cpp
+libfollytimeout_queue_la_LIBADD = libfolly.la