Fix mcrouter opensource build
[folly.git] / folly / Makefile.am
index 91a993bf53f0cf3c850ab8714cf8f930182dcea8..701f3df9331200fa179e1b475f917417f93d9c09 100644 (file)
@@ -6,13 +6,14 @@ CLEANFILES =
 
 noinst_PROGRAMS = generate_fingerprint_tables
 generate_fingerprint_tables_SOURCES = build/GenerateFingerprintTables.cpp
-generate_fingerprint_tables_LDADD = libfolly.la
+generate_fingerprint_tables_LDADD = libfollybase.la
+
+noinst_LTLIBRARIES = \
+       libfollybase.la
 
 lib_LTLIBRARIES = \
        libfolly.la \
-       libfollybenchmark.la \
-       libfollytimeout_queue.la \
-       libfollyfingerprint.la
+       libfollybenchmark.la
 
 follyincludedir = $(includedir)/folly
 
@@ -25,8 +26,11 @@ nobase_follyinclude_HEADERS = \
        AtomicHashArray-inl.h \
        AtomicHashMap.h \
        AtomicHashMap-inl.h \
+       AtomicStruct.h \
+       Baton.h \
        Benchmark.h \
        Bits.h \
+       Checksum.h \
        Chrono.h \
        ConcurrentSkipList.h \
        ConcurrentSkipList-inl.h \
@@ -36,20 +40,41 @@ nobase_follyinclude_HEADERS = \
        detail/AtomicHashUtils.h \
        detail/BitIteratorDetail.h \
        detail/BitsDetail.h \
+       detail/CacheLocality.h \
+       detail/ChecksumDetail.h \
+       detail/Clock.h \
        detail/DiscriminatedPtrDetail.h \
+       detail/ExceptionWrapper.h \
        detail/FileUtilDetail.h \
        detail/FingerprintPolynomial.h \
+       detail/FunctionalExcept.h \
        detail/Futex.h \
        detail/GroupVarintDetail.h \
+       detail/IPAddress.h \
        detail/Malloc.h \
+       detail/MemoryIdler.h \
        detail/MPMCPipelineDetail.h \
        detail/SlowFingerprint.h \
        detail/Stats.h \
        detail/ThreadLocalDetail.h \
+       detail/UncaughtExceptionCounter.h \
+       Demangle.h \
        DiscriminatedPtr.h \
        DynamicConverter.h \
        dynamic.h \
        dynamic-inl.h \
+       Exception.h \
+       ExceptionWrapper.h \
+       EvictingCacheMap.h \
+       experimental/Bits.h \
+       experimental/EliasFanoCoding.h \
+       experimental/EventCount.h \
+       experimental/io/FsUtil.h \
+       experimental/Singleton.h \
+       experimental/TestUtil.h \
+       experimental/wangle/concurrent/Codel.h \
+       experimental/wangle/ConnectionManager.h \
+       experimental/wangle/ManagedConnection.h \
        FBString.h \
        FBVector.h \
        File.h \
@@ -60,19 +85,53 @@ nobase_follyinclude_HEADERS = \
        FormatArg.h \
        Format.h \
        Format-inl.h \
+       gen/Base.h \
+       gen/Base-inl.h \
+       gen/Combine.h \
+       gen/Combine-inl.h \
+       gen/Core.h \
+       gen/Core-inl.h \
+       gen/File.h \
+       gen/File-inl.h \
+       gen/Parallel.h \
+       gen/Parallel-inl.h \
+       gen/ParallelMap.h \
+       gen/ParallelMap-inl.h \
+       gen/String.h \
+       gen/String-inl.h \
        GroupVarint.h \
        Hash.h \
+       IPAddress.h \
+       IPAddressV4.h \
+       IPAddressV6.h \
+       IPAddressException.h \
+       IndexedMemPool.h \
        IntrusiveList.h \
+       io/Compression.h \
        io/Cursor.h \
        io/IOBuf.h \
        io/IOBufQueue.h \
        io/RecordIO.h \
        io/RecordIO-inl.h \
        io/TypedIOBuf.h \
+       io/ShutdownSocketSet.h \
+       io/async/AsyncTimeout.h \
+       io/async/DelayedDestruction.h \
+       io/async/EventBase.h \
+       io/async/EventBaseManager.h \
+       io/async/EventFDWrapper.h \
+       io/async/EventHandler.h \
+       io/async/EventUtil.h \
+       io/async/NotificationQueue.h \
+       io/async/HHWheelTimer.h \
+       io/async/Request.h \
+       io/async/TimeoutManager.h \
        json.h \
        Lazy.h \
+       LifoSem.h \
        Likely.h \
        Logging.h \
+       MacAddress.h \
        Malloc.h \
        MapUtil.h \
        Memory.h \
@@ -87,11 +146,13 @@ nobase_follyinclude_HEADERS = \
        Preprocessor.h \
        ProducerConsumerQueue.h \
        Random.h \
+       Random-inl.h \
        Range.h \
        RWSpinLock.h \
        ScopeGuard.h \
        SmallLocks.h \
        small_vector.h \
+       SocketAddress.h \
        sorted_vector_types.h \
        SpookyHashV1.h \
        SpookyHashV2.h \
@@ -114,12 +175,29 @@ nobase_follyinclude_HEADERS = \
        ThreadCachedArena.h \
        ThreadCachedInt.h \
        ThreadLocal.h \
+       ThreadName.h \
        TimeoutQueue.h \
        Traits.h \
        Unicode.h \
        Uri.h \
        Uri-inl.h \
-       Varint.h
+       Varint.h \
+       VersionCheck.h \
+       wangle/Executor.h \
+       wangle/Future-inl.h \
+       wangle/Future.h \
+       wangle/GenericThreadGate.h \
+       wangle/InlineExecutor.h \
+       wangle/Later-inl.h \
+       wangle/Later.h \
+       wangle/ManualExecutor.h \
+       wangle/Promise-inl.h \
+       wangle/Promise.h \
+       wangle/ThreadGate.h \
+       wangle/Try-inl.h \
+       wangle/Try.h \
+       wangle/WangleException.h \
+       wangle/detail/Core.h
 
 FormatTables.cpp: build/generate_format_tables.py
        build/generate_format_tables.py
@@ -133,55 +211,96 @@ GroupVarintTables.cpp: build/generate_varint_tables.py
        build/generate_varint_tables.py
 CLEANFILES += GroupVarintTables.cpp
 
+libfollybase_la_SOURCES = \
+       Conv.cpp \
+       Demangle.cpp \
+       EscapeTables.cpp \
+       Format.cpp \
+       FormatTables.cpp \
+       Malloc.cpp \
+       Range.cpp \
+       String.cpp \
+       Unicode.cpp
+
 libfolly_la_SOURCES = \
-       Benchmark.cpp \
        Bits.cpp \
-       Conv.cpp \
+       detail/CacheLocality.cpp \
        dynamic.cpp \
-       EscapeTables.cpp \
        File.cpp \
        FileUtil.cpp \
-       Format.cpp \
-       FormatTables.cpp \
+       FingerprintTables.cpp \
+       detail/Futex.cpp \
        GroupVarint.cpp \
        GroupVarintTables.cpp \
+       IPAddress.cpp \
+       IPAddressV4.cpp \
+       IPAddressV6.cpp \
+       LifoSem.cpp \
+       io/Compression.cpp \
        io/IOBuf.cpp \
        io/IOBufQueue.cpp \
        io/RecordIO.cpp \
+       io/ShutdownSocketSet.cpp \
+       io/async/AsyncTimeout.cpp \
+       io/async/EventBase.cpp \
+       io/async/EventBaseManager.cpp \
+       io/async/EventHandler.cpp \
+       io/async/Request.cpp \
+       io/async/HHWheelTimer.cpp \
        json.cpp \
+       detail/MemoryIdler.cpp \
+       MacAddress.cpp \
        MemoryMapping.cpp \
        Random.cpp \
-       Range.cpp \
+       SafeAssert.cpp \
+       SocketAddress.cpp \
        SpookyHashV1.cpp \
        SpookyHashV2.cpp \
        stats/Instantiations.cpp \
-       String.cpp \
        Subprocess.cpp \
        ThreadCachedArena.cpp \
        TimeoutQueue.cpp \
-       Unicode.cpp \
-       Uri.cpp
+       Uri.cpp \
+       Version.cpp \
+       wangle/InlineExecutor.cpp \
+       wangle/ManualExecutor.cpp \
+       wangle/ThreadGate.cpp \
+       experimental/io/FsUtil.cpp \
+       experimental/Singleton.cpp \
+       experimental/TestUtil.cpp \
+       experimental/wangle/concurrent/Codel.cpp \
+       experimental/wangle/ConnectionManager.cpp \
+       experimental/wangle/ManagedConnection.cpp
+
+if HAVE_LINUX
+nobase_follyinclude_HEADERS += \
+       experimental/io/HugePages.h
+libfolly_la_SOURCES += \
+       experimental/io/HugePages.cpp
+endif
 
 if !HAVE_LINUX
 nobase_follyinclude_HEADERS += detail/Clock.h
-libfolly_la_SOURCES += detail/Clock.cpp
+libfollybase_la_SOURCES += detail/Clock.cpp
 endif
 
 if !HAVE_WEAK_SYMBOLS
-libfolly_la_SOURCES += detail/Malloc.cpp
+libfollybase_la_SOURCES += detail/MallocImpl.cpp
+endif
+
+if !HAVE_BITS_FUNCTEXCEPT
+libfollybase_la_SOURCES += detail/FunctionalExcept.cpp
 endif
 
+libfollybase_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LT_VERSION)
+
+libfolly_la_LIBADD = libfollybase.la
+libfolly_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LT_VERSION)
+
 FingerprintTables.cpp: generate_fingerprint_tables
        ./generate_fingerprint_tables
 CLEANFILES += FingerprintTables.cpp
 
-libfollyfingerprint_la_SOURCES = \
-       FingerprintTables.cpp
-libfollyfingerprint_la_LIBADD = libfolly.la
-
 libfollybenchmark_la_SOURCES = Benchmark.cpp
 libfollybenchmark_la_LIBADD = libfolly.la
-
-libfollytimeout_queue_la_SOURCES = TimeoutQueue.cpp
-libfollytimeout_queue_la_LIBADD = libfolly.la
-
+libfollybenchmark_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LT_VERSION)