Remove the folly/Assume.h shim
[folly.git] / folly / Makefile.am
index a351f990d26c38aae8387266eef2c97c94fe9470..6df61c3c6a3c2ed362394de1b8182b1123f7f7e3 100644 (file)
@@ -5,7 +5,7 @@ endif
 # Note that the order of SUBDIRS matters.
 # Many subdirectories depend on libfollytest from the test directory,
 # so it must appear before other directories
-SUBDIRS = . test experimental $(MAYBE_INIT) io/test stats/test
+SUBDIRS = . test experimental $(MAYBE_INIT) chrono/test io/test stats/test
 
 ACLOCAL_AMFLAGS = -I m4
 
@@ -27,7 +27,6 @@ lib_LTLIBRARIES = \
 follyincludedir = $(includedir)/folly
 
 nobase_follyinclude_HEADERS = \
-       Assume.h \
        AtomicBitSet.h \
        AtomicHashArray.h \
        AtomicHashArray-inl.h \
@@ -37,15 +36,14 @@ nobase_follyinclude_HEADERS = \
        AtomicLinkedList.h \
        AtomicStruct.h \
        AtomicUnorderedMap.h \
-       Baton.h \
        Benchmark.h \
        Bits.h \
        CachelinePadded.h \
        Chrono.h \
+       chrono/Conv.h \
        ClockGettimeWrappers.h \
        ConcurrentSkipList.h \
        ConcurrentSkipList-inl.h \
-       ContainerTraits.h \
        Conv.h \
        CppAttributes.h \
        CpuId.h \
@@ -57,6 +55,8 @@ nobase_follyinclude_HEADERS = \
        concurrency/ConcurrentHashMap.h \
        concurrency/CoreCachedSharedPtr.h \
        concurrency/detail/ConcurrentHashMap-detail.h \
+       concurrency/UnboundedQueue.h \
+       container/Access.h \
        container/Array.h \
        container/Iterator.h \
        container/Enumerate.h \
@@ -65,6 +65,7 @@ nobase_follyinclude_HEADERS = \
        container/Foreach-inl.h \
        container/SparseByteSet.h \
        ConstexprMath.h \
+       detail/AtFork.h \
        detail/AtomicHashUtils.h \
        detail/AtomicUnorderedMapUtils.h \
        detail/BitIteratorDetail.h \
@@ -155,14 +156,21 @@ nobase_follyinclude_HEADERS = \
        experimental/JSONSchema.h \
        experimental/LockFreeRingBuffer.h \
        experimental/logging/AsyncFileWriter.h \
+       experimental/logging/FileHandlerFactory.h \
+       experimental/logging/FileWriterFactory.h \
        experimental/logging/GlogStyleFormatter.h \
        experimental/logging/ImmediateFileWriter.h \
        experimental/logging/Init.h \
        experimental/logging/LogCategory.h \
+       experimental/logging/LogCategoryConfig.h \
+       experimental/logging/LogConfig.h \
+       experimental/logging/LogConfigParser.h \
        experimental/logging/LogFormatter.h \
        experimental/logging/Logger.h \
        experimental/logging/LoggerDB.h \
        experimental/logging/LogHandler.h \
+       experimental/logging/LogHandlerFactory.h \
+       experimental/logging/LogHandlerConfig.h \
        experimental/logging/LogLevel.h \
        experimental/logging/LogMessage.h \
        experimental/logging/LogName.h \
@@ -172,6 +180,8 @@ nobase_follyinclude_HEADERS = \
        experimental/logging/printf.h \
        experimental/logging/RateLimiter.h \
        experimental/logging/StandardLogHandler.h \
+       experimental/logging/StandardLogHandlerFactory.h \
+       experimental/logging/StreamHandlerFactory.h \
        experimental/logging/xlog.h \
        experimental/NestedCommandLineApp.h \
        experimental/observer/detail/Core.h \
@@ -313,10 +323,14 @@ nobase_follyinclude_HEADERS = \
        io/async/test/UndelayedDestruction.h \
        io/async/test/Util.h \
        json.h \
+       lang/Align.h \
        lang/Assume.h \
+       lang/Bits.h \
+       lang/ColdClass.h \
        lang/Launder.h \
+       lang/RValueReferenceWrapper.h \
+       lang/SafeAssert.h \
        Lazy.h \
-       LifoSem.h \
        Likely.h \
        LockTraits.h \
        LockTraitsBoost.h \
@@ -393,7 +407,6 @@ nobase_follyinclude_HEADERS = \
        Range.h \
        Replaceable.h \
        RWSpinLock.h \
-       SafeAssert.h \
        ScopeGuard.h \
        SharedMutex.h \
        Singleton.h \
@@ -423,7 +436,9 @@ nobase_follyinclude_HEADERS = \
        stats/TimeseriesHistogram-defs.h \
        stats/TimeseriesHistogram.h \
        synchronization/AsymmetricMemoryBarrier.h \
+       synchronization/Baton.h \
        synchronization/CallOnce.h \
+       synchronization/LifoSem.h \
        synchronization/detail/AtomicUtils.h \
        system/MemoryMapping.h \
        system/Shell.h \
@@ -454,7 +469,6 @@ nobase_follyinclude_HEADERS = \
        Try.h \
        Unicode.h \
        Function.h \
-       Functional.h \
        UncaughtExceptions.h \
        Unit.h \
        Uri.h \
@@ -497,6 +511,7 @@ libfolly_la_SOURCES = \
        compression/Compression.cpp \
        compression/Zlib.cpp \
        concurrency/CacheLocality.cpp \
+       detail/AtFork.cpp \
        detail/Futex.cpp \
        detail/IPAddress.cpp \
        detail/StaticSingletonManager.cpp \
@@ -504,6 +519,7 @@ libfolly_la_SOURCES = \
        dynamic.cpp \
        ExceptionWrapper.cpp \
        Executor.cpp \
+       Expected.cpp \
        File.cpp \
        FileUtil.cpp \
        FingerprintTables.cpp \
@@ -533,7 +549,6 @@ libfolly_la_SOURCES = \
        IPAddress.cpp \
        IPAddressV4.cpp \
        IPAddressV6.cpp \
-       LifoSem.cpp \
        init/Init.cpp \
        io/Cursor.cpp \
        io/IOBuf.cpp \
@@ -567,11 +582,12 @@ libfolly_la_SOURCES = \
        io/async/ssl/SSLErrors.cpp \
        json.cpp \
        lang/Assume.cpp \
+       lang/ColdClass.cpp \
+       lang/SafeAssert.cpp \
        detail/MemoryIdler.cpp \
        detail/SocketFastOpen.cpp \
        MacAddress.cpp \
        memory/ThreadCachedArena.cpp \
-       Poly.cpp \
        portability/Dirent.cpp \
        portability/Fcntl.cpp \
        portability/Libgen.cpp \
@@ -593,7 +609,6 @@ libfolly_la_SOURCES = \
        portability/Time.cpp \
        portability/Unistd.cpp \
        Random.cpp \
-       SafeAssert.cpp \
        ScopeGuard.cpp \
        SharedMutex.cpp \
        MicroLock.cpp \
@@ -610,6 +625,7 @@ libfolly_la_SOURCES = \
        stats/MultiLevelTimeSeries.cpp \
        stats/TimeseriesHistogram.cpp \
        synchronization/AsymmetricMemoryBarrier.cpp \
+       synchronization/LifoSem.cpp \
        system/MemoryMapping.cpp \
        system/Shell.cpp \
        system/ThreadName.cpp \
@@ -713,6 +729,11 @@ libfolly_la_SOURCES += \
        experimental/symbolizer/Symbolizer.cpp
 endif
 
+if HAVE_VARIABLE_TEMPLATES
+libfolly_la_SOURCES += \
+       Poly.cpp
+endif
+
 libfollybasesse42_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LT_VERSION)
 libfollybasesse42_la_CXXFLAGS = -msse4.2 -mpclmul
 
@@ -722,6 +743,10 @@ libfollybase_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LT_VERSION)
 libfolly_la_LIBADD = libfollybase.la
 libfolly_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LT_VERSION) -lssl
 
+if USE_SYMBOLIZER
+libfolly_la_LDFLAGS += -lunwind
+endif
+
 FingerprintTables.cpp: generate_fingerprint_tables
        ./generate_fingerprint_tables
 CLEANFILES += FingerprintTables.cpp