Fix a race in Observable context destruction
[folly.git] / folly / Makefile.am
index b2dbcfaf45f029db312b834a643bbcc1f58d49b2..6d93decd75ed2dc212a8cbae2902faf7f9d3fd89 100644 (file)
@@ -1,9 +1,14 @@
 if FOLLY_TESTMAIN
-SUBDIRS = . experimental init test io/test experimental/io/test
-else
-SUBDIRS = . experimental test io/test experimental/io/test
+MAYBE_INIT = init
 endif
 
+if EXCEPTION_TRACER
+MAYBE_EXCEPTION_TRACER = experimental/exception_tracer
+endif
+
+SUBDIRS = . experimental $(MAYBE_INIT) test io/test experimental/io/test \
+         $(MAYBE_EXCEPTION_TRACER)
+
 ACLOCAL_AMFLAGS = -I m4
 
 CLEANFILES =
@@ -99,6 +104,7 @@ nobase_follyinclude_HEADERS = \
        experimental/AtomicSharedPtr.h \
        experimental/detail/AtomicSharedPtr-detail.h \
        experimental/AutoTimer.h \
+       experimental/ThreadedRepeatingFunctionRunner.h \
        experimental/Bits.h \
        experimental/BitVectorCoding.h \
        experimental/DynamicParser.h \
@@ -109,6 +115,11 @@ nobase_follyinclude_HEADERS = \
        experimental/EventCount.h \
        experimental/Instructions.h \
        experimental/bser/Bser.h \
+       experimental/exception_tracer/ExceptionAbi.h \
+       experimental/exception_tracer/ExceptionCounterLib.h \
+       experimental/exception_tracer/ExceptionTracer.h \
+       experimental/exception_tracer/ExceptionTracerLib.h \
+       experimental/exception_tracer/StackTrace.h \
        experimental/FunctionScheduler.h \
        experimental/FutureDAG.h \
        experimental/io/FsUtil.h \
@@ -281,6 +292,7 @@ nobase_follyinclude_HEADERS = \
        MPMCPipeline.h \
        MPMCQueue.h \
        Optional.h \
+       Overload.h \
        PackedSyncPtr.h \
        Padded.h \
        Partial.h \
@@ -383,6 +395,7 @@ nobase_follyinclude_HEADERS = \
        Try.h \
        Unicode.h \
        Function.h \
+       Functional.h \
        UncaughtExceptions.h \
        Unit.h \
        Uri.h \
@@ -489,6 +502,7 @@ libfolly_la_SOURCES = \
        portability/Malloc.cpp \
        portability/Memory.cpp \
        portability/OpenSSL.cpp \
+       portability/PThread.cpp \
        portability/Sockets.cpp \
        portability/Stdio.cpp \
        portability/Stdlib.cpp \
@@ -518,10 +532,12 @@ libfolly_la_SOURCES = \
        stats/Instantiations.cpp \
        Subprocess.cpp \
        ThreadCachedArena.cpp \
+       ThreadName.cpp \
        TimeoutQueue.cpp \
        Uri.cpp \
        Version.cpp \
        experimental/AsymmetricMemoryBarrier.cpp \
+       experimental/ThreadedRepeatingFunctionRunner.cpp \
        experimental/bser/Dump.cpp \
        experimental/bser/Load.cpp \
        experimental/DynamicParser.cpp \