Add TimedDrivableExecutor to folly.
[folly.git] / folly / Makefile.am
index c5b9d9ca1985ec532f1b070bfe29dc720653fe5a..66bb93e76b9657f08f324ea88a54b4cd31d4afc7 100644 (file)
@@ -57,6 +57,7 @@ nobase_follyinclude_HEADERS = \
        concurrency/UnboundedQueue.h \
        container/Access.h \
        container/Array.h \
+       container/detail/BitIteratorDetail.h \
        container/Iterator.h \
        container/Enumerate.h \
        container/EvictingCacheMap.h \
@@ -67,7 +68,6 @@ nobase_follyinclude_HEADERS = \
        detail/AtFork.h \
        detail/AtomicHashUtils.h \
        detail/AtomicUnorderedMapUtils.h \
-       detail/BitIteratorDetail.h \
        detail/DiscriminatedPtrDetail.h \
        detail/FileUtilDetail.h \
        detail/FingerprintPolynomial.h \
@@ -103,6 +103,7 @@ nobase_follyinclude_HEADERS = \
        executors/SerialExecutor.h \
        executors/ThreadPoolExecutor.h \
        executors/ThreadedExecutor.h \
+       executors/TimedDrivableExecutor.h \
        executors/task_queue/BlockingQueue.h \
        executors/task_queue/LifoSemMPMCQueue.h \
        executors/task_queue/PriorityLifoSemMPMCQueue.h \
@@ -403,7 +404,6 @@ nobase_follyinclude_HEADERS = \
        Random-inl.h \
        Range.h \
        Replaceable.h \
-       RWSpinLock.h \
        ScopeGuard.h \
        SharedMutex.h \
        Singleton.h \
@@ -438,7 +438,10 @@ nobase_follyinclude_HEADERS = \
        synchronization/CallOnce.h \
        synchronization/LifoSem.h \
        synchronization/ParkingLot.h \
+       synchronization/RWSpinLock.h \
        synchronization/SaturatingSemaphore.h \
+       synchronization/Tearable.h \
+       synchronization/WaitOptions.h \
        synchronization/detail/AtomicUtils.h \
        synchronization/detail/Sleeper.h \
        system/MemoryMapping.h \
@@ -539,6 +542,7 @@ libfolly_la_SOURCES = \
        executors/SerialExecutor.cpp \
        executors/ThreadPoolExecutor.cpp \
        executors/ThreadedExecutor.cpp \
+       executors/TimedDrivableExecutor.cpp \
        executors/QueuedImmediateExecutor.cpp \
        experimental/hazptr/hazptr.cpp \
        experimental/hazptr/memory_resource.cpp \
@@ -593,7 +597,6 @@ libfolly_la_SOURCES = \
        portability/Fcntl.cpp \
        portability/Libgen.cpp \
        portability/Malloc.cpp \
-       portability/Memory.cpp \
        portability/OpenSSL.cpp \
        portability/PThread.cpp \
        portability/Sockets.cpp \
@@ -628,6 +631,7 @@ libfolly_la_SOURCES = \
        synchronization/AsymmetricMemoryBarrier.cpp \
        synchronization/LifoSem.cpp \
        synchronization/ParkingLot.cpp \
+       synchronization/WaitOptions.cpp \
        system/MemoryMapping.cpp \
        system/Shell.cpp \
        system/ThreadName.cpp \