Add TimedDrivableExecutor to folly.
[folly.git] / folly / Makefile.am
index 60a66c8e5e5489e034c86c0fc26b1301db411181..66bb93e76b9657f08f324ea88a54b4cd31d4afc7 100644 (file)
@@ -103,6 +103,7 @@ nobase_follyinclude_HEADERS = \
        executors/SerialExecutor.h \
        executors/ThreadPoolExecutor.h \
        executors/ThreadedExecutor.h \
+       executors/TimedDrivableExecutor.h \
        executors/task_queue/BlockingQueue.h \
        executors/task_queue/LifoSemMPMCQueue.h \
        executors/task_queue/PriorityLifoSemMPMCQueue.h \
@@ -439,6 +440,7 @@ nobase_follyinclude_HEADERS = \
        synchronization/ParkingLot.h \
        synchronization/RWSpinLock.h \
        synchronization/SaturatingSemaphore.h \
+       synchronization/Tearable.h \
        synchronization/WaitOptions.h \
        synchronization/detail/AtomicUtils.h \
        synchronization/detail/Sleeper.h \
@@ -540,6 +542,7 @@ libfolly_la_SOURCES = \
        executors/SerialExecutor.cpp \
        executors/ThreadPoolExecutor.cpp \
        executors/ThreadedExecutor.cpp \
+       executors/TimedDrivableExecutor.cpp \
        executors/QueuedImmediateExecutor.cpp \
        experimental/hazptr/hazptr.cpp \
        experimental/hazptr/memory_resource.cpp \
@@ -594,7 +597,6 @@ libfolly_la_SOURCES = \
        portability/Fcntl.cpp \
        portability/Libgen.cpp \
        portability/Malloc.cpp \
-       portability/Memory.cpp \
        portability/OpenSSL.cpp \
        portability/PThread.cpp \
        portability/Sockets.cpp \
@@ -629,6 +631,7 @@ libfolly_la_SOURCES = \
        synchronization/AsymmetricMemoryBarrier.cpp \
        synchronization/LifoSem.cpp \
        synchronization/ParkingLot.cpp \
+       synchronization/WaitOptions.cpp \
        system/MemoryMapping.cpp \
        system/Shell.cpp \
        system/ThreadName.cpp \