Add TimedDrivableExecutor to folly.
[folly.git] / folly / Makefile.am
index 121c1eeb9ff89d1862f97ac4ee584de833704601..66bb93e76b9657f08f324ea88a54b4cd31d4afc7 100644 (file)
@@ -27,7 +27,6 @@ lib_LTLIBRARIES = \
 follyincludedir = $(includedir)/folly
 
 nobase_follyinclude_HEADERS = \
-       Assume.h \
        AtomicBitSet.h \
        AtomicHashArray.h \
        AtomicHashArray-inl.h \
@@ -35,7 +34,6 @@ nobase_follyinclude_HEADERS = \
        AtomicHashMap-inl.h \
        AtomicIntrusiveLinkedList.h \
        AtomicLinkedList.h \
-       AtomicStruct.h \
        AtomicUnorderedMap.h \
        Benchmark.h \
        Bits.h \
@@ -59,6 +57,7 @@ nobase_follyinclude_HEADERS = \
        concurrency/UnboundedQueue.h \
        container/Access.h \
        container/Array.h \
+       container/detail/BitIteratorDetail.h \
        container/Iterator.h \
        container/Enumerate.h \
        container/EvictingCacheMap.h \
@@ -69,7 +68,6 @@ nobase_follyinclude_HEADERS = \
        detail/AtFork.h \
        detail/AtomicHashUtils.h \
        detail/AtomicUnorderedMapUtils.h \
-       detail/BitIteratorDetail.h \
        detail/DiscriminatedPtrDetail.h \
        detail/FileUtilDetail.h \
        detail/FingerprintPolynomial.h \
@@ -82,14 +80,12 @@ nobase_follyinclude_HEADERS = \
        detail/PolyDetail.h \
        detail/RangeCommon.h \
        detail/RangeSse42.h \
-       detail/Sleeper.h \
        detail/SlowFingerprint.h \
        detail/SocketFastOpen.h \
        detail/StaticSingletonManager.h \
        detail/ThreadLocalDetail.h \
        detail/TypeList.h \
        detail/TurnSequencer.h \
-       detail/UncaughtExceptionCounter.h \
        executors/Async.h \
        executors/CPUThreadPoolExecutor.h \
        executors/Codel.h \
@@ -107,6 +103,7 @@ nobase_follyinclude_HEADERS = \
        executors/SerialExecutor.h \
        executors/ThreadPoolExecutor.h \
        executors/ThreadedExecutor.h \
+       executors/TimedDrivableExecutor.h \
        executors/task_queue/BlockingQueue.h \
        executors/task_queue/LifoSemMPMCQueue.h \
        executors/task_queue/PriorityLifoSemMPMCQueue.h \
@@ -324,7 +321,9 @@ nobase_follyinclude_HEADERS = \
        io/async/test/UndelayedDestruction.h \
        io/async/test/Util.h \
        json.h \
+       lang/Align.h \
        lang/Assume.h \
+       lang/Bits.h \
        lang/ColdClass.h \
        lang/Launder.h \
        lang/RValueReferenceWrapper.h \
@@ -405,7 +404,6 @@ nobase_follyinclude_HEADERS = \
        Random-inl.h \
        Range.h \
        Replaceable.h \
-       RWSpinLock.h \
        ScopeGuard.h \
        SharedMutex.h \
        Singleton.h \
@@ -435,10 +433,17 @@ nobase_follyinclude_HEADERS = \
        stats/TimeseriesHistogram-defs.h \
        stats/TimeseriesHistogram.h \
        synchronization/AsymmetricMemoryBarrier.h \
+       synchronization/AtomicStruct.h \
        synchronization/Baton.h \
        synchronization/CallOnce.h \
        synchronization/LifoSem.h \
+       synchronization/ParkingLot.h \
+       synchronization/RWSpinLock.h \
+       synchronization/SaturatingSemaphore.h \
+       synchronization/Tearable.h \
+       synchronization/WaitOptions.h \
        synchronization/detail/AtomicUtils.h \
+       synchronization/detail/Sleeper.h \
        system/MemoryMapping.h \
        system/Shell.h \
        system/ThreadId.h \
@@ -537,6 +542,7 @@ libfolly_la_SOURCES = \
        executors/SerialExecutor.cpp \
        executors/ThreadPoolExecutor.cpp \
        executors/ThreadedExecutor.cpp \
+       executors/TimedDrivableExecutor.cpp \
        executors/QueuedImmediateExecutor.cpp \
        experimental/hazptr/hazptr.cpp \
        experimental/hazptr/memory_resource.cpp \
@@ -591,7 +597,6 @@ libfolly_la_SOURCES = \
        portability/Fcntl.cpp \
        portability/Libgen.cpp \
        portability/Malloc.cpp \
-       portability/Memory.cpp \
        portability/OpenSSL.cpp \
        portability/PThread.cpp \
        portability/Sockets.cpp \
@@ -625,6 +630,8 @@ libfolly_la_SOURCES = \
        stats/TimeseriesHistogram.cpp \
        synchronization/AsymmetricMemoryBarrier.cpp \
        synchronization/LifoSem.cpp \
+       synchronization/ParkingLot.cpp \
+       synchronization/WaitOptions.cpp \
        system/MemoryMapping.cpp \
        system/Shell.cpp \
        system/ThreadName.cpp \