add Cursor::readWhile() and skipWhile()
[folly.git] / folly / Makefile.am
index 3b248629b3f00c01699f63674a56fe28c4e445fc..60bd725d8c05737cb040b39134fe7cf9f981eef8 100644 (file)
@@ -70,6 +70,7 @@ nobase_follyinclude_HEADERS = \
        detail/RangeSse42.h \
        detail/Sleeper.h \
        detail/SlowFingerprint.h \
+       detail/SocketFastOpen.h \
        detail/SpinLockImpl.h \
        detail/StaticSingletonManager.h \
        detail/Stats.h \
@@ -95,32 +96,32 @@ nobase_follyinclude_HEADERS = \
        experimental/EventCount.h \
        experimental/Instructions.h \
        experimental/bser/Bser.h \
-       experimental/fibers/AddTasks.h \
-       experimental/fibers/AddTasks-inl.h \
-       experimental/fibers/Baton.h \
-       experimental/fibers/Baton-inl.h \
-       experimental/fibers/BoostContextCompatibility.h \
-       experimental/fibers/EventBaseLoopController.h \
-       experimental/fibers/EventBaseLoopController-inl.h \
-       experimental/fibers/Fiber.h \
-       experimental/fibers/Fiber-inl.h \
-       experimental/fibers/FiberManager.h \
-       experimental/fibers/FiberManager-inl.h \
-       experimental/fibers/FiberManagerMap.h \
-       experimental/fibers/ForEach.h \
-       experimental/fibers/ForEach-inl.h \
-       experimental/fibers/GenericBaton.h \
-       experimental/fibers/GuardPageAllocator.h \
-       experimental/fibers/LoopController.h \
-       experimental/fibers/Promise.h \
-       experimental/fibers/Promise-inl.h \
-       experimental/fibers/SimpleLoopController.h \
-       experimental/fibers/TimedMutex.h \
-       experimental/fibers/TimedMutex-inl.h \
-       experimental/fibers/TimeoutController.h \
-       experimental/fibers/traits.h \
-       experimental/fibers/WhenN.h \
-       experimental/fibers/WhenN-inl.h \
+       fibers/AddTasks.h \
+       fibers/AddTasks-inl.h \
+       fibers/Baton.h \
+       fibers/Baton-inl.h \
+       fibers/BoostContextCompatibility.h \
+       fibers/EventBaseLoopController.h \
+       fibers/EventBaseLoopController-inl.h \
+       fibers/Fiber.h \
+       fibers/Fiber-inl.h \
+       fibers/FiberManager.h \
+       fibers/FiberManager-inl.h \
+       fibers/FiberManagerMap.h \
+       fibers/ForEach.h \
+       fibers/ForEach-inl.h \
+       fibers/GenericBaton.h \
+       fibers/GuardPageAllocator.h \
+       fibers/LoopController.h \
+       fibers/Promise.h \
+       fibers/Promise-inl.h \
+       fibers/SimpleLoopController.h \
+       fibers/TimedMutex.h \
+       fibers/TimedMutex-inl.h \
+       fibers/TimeoutController.h \
+       fibers/traits.h \
+       fibers/WhenN.h \
+       fibers/WhenN-inl.h \
        experimental/FunctionScheduler.h \
        experimental/FutureDAG.h \
        experimental/io/FsUtil.h \
@@ -155,7 +156,6 @@ nobase_follyinclude_HEADERS = \
        Format.h \
        Format-inl.h \
        futures/Barrier.h \
-       futures/ThreadedExecutor.h \
        futures/DrivableExecutor.h \
        futures/Future-pre.h \
        futures/helpers.h \
@@ -173,9 +173,6 @@ nobase_follyinclude_HEADERS = \
        futures/SharedPromise-inl.h \
        futures/ThreadWheelTimekeeper.h \
        futures/Timekeeper.h \
-       futures/Try-inl.h \
-       futures/Try.h \
-       futures/Unit.h \
        futures/detail/Core.h \
        futures/detail/FSM.h \
        futures/detail/Types.h \
@@ -205,6 +202,7 @@ nobase_follyinclude_HEADERS = \
        IntrusiveList.h \
        io/Compression.h \
        io/Cursor.h \
+       io/Cursor-inl.h \
        io/IOBuf.h \
        io/IOBufQueue.h \
        io/RecordIO.h \
@@ -346,8 +344,11 @@ nobase_follyinclude_HEADERS = \
        ThreadName.h \
        TimeoutQueue.h \
        Traits.h \
+       Try-inl.h \
+       Try.h \
        Unicode.h \
        Function.h \
+       Unit.h \
        Uri.h \
        Uri-inl.h \
        Varint.h \
@@ -386,7 +387,6 @@ libfolly_la_SOURCES = \
        FileUtil.cpp \
        FingerprintTables.cpp \
        futures/Barrier.cpp \
-       futures/ThreadedExecutor.cpp \
        futures/Future.cpp \
        futures/InlineExecutor.cpp \
        futures/ManualExecutor.cpp \
@@ -402,6 +402,7 @@ libfolly_la_SOURCES = \
        IPAddressV6.cpp \
        LifoSem.cpp \
        io/Compression.cpp \
+       io/Cursor.cpp \
        io/IOBuf.cpp \
        io/IOBufQueue.cpp \
        io/RecordIO.cpp \
@@ -427,6 +428,7 @@ libfolly_la_SOURCES = \
        io/async/ssl/SSLErrors.cpp \
        json.cpp \
        detail/MemoryIdler.cpp \
+       detail/SocketFastOpen.cpp \
        MacAddress.cpp \
        MemoryMapping.cpp \
        portability/Dirent.cpp \
@@ -444,6 +446,7 @@ libfolly_la_SOURCES = \
        portability/SysResource.cpp \
        portability/SysStat.cpp \
        portability/SysTime.cpp \
+       portability/SysUio.cpp \
        portability/Time.cpp \
        portability/Unistd.cpp \
        Random.cpp \
@@ -463,12 +466,12 @@ libfolly_la_SOURCES = \
        experimental/bser/Dump.cpp \
        experimental/bser/Load.cpp \
        experimental/DynamicParser.cpp \
-       experimental/fibers/Baton.cpp \
-       experimental/fibers/Fiber.cpp \
-       experimental/fibers/FiberManager.cpp \
-       experimental/fibers/FiberManagerMap.cpp \
-       experimental/fibers/GuardPageAllocator.cpp \
-       experimental/fibers/TimeoutController.cpp \
+       fibers/Baton.cpp \
+       fibers/Fiber.cpp \
+       fibers/FiberManager.cpp \
+       fibers/FiberManagerMap.cpp \
+       fibers/GuardPageAllocator.cpp \
+       fibers/TimeoutController.cpp \
        experimental/FunctionScheduler.cpp \
        experimental/io/FsUtil.cpp \
        experimental/JSONSchema.cpp \