add Cursor::readWhile() and skipWhile()
[folly.git] / folly / Makefile.am
index 37bfde336088916547f458cd61b9f7f7895fb2d3..60bd725d8c05737cb040b39134fe7cf9f981eef8 100644 (file)
@@ -1,4 +1,8 @@
+if FOLLY_TESTMAIN
+SUBDIRS = . experimental init test
+else
 SUBDIRS = . test
+endif
 
 ACLOCAL_AMFLAGS = -I m4
 
@@ -21,23 +25,28 @@ nobase_follyinclude_HEADERS = \
        ApplyTuple.h \
        Arena.h \
        Arena-inl.h \
+       Array.h \
        Assume.h \
        AtomicBitSet.h \
        AtomicHashArray.h \
        AtomicHashArray-inl.h \
        AtomicHashMap.h \
        AtomicHashMap-inl.h \
+       AtomicIntrusiveLinkedList.h \
        AtomicLinkedList.h \
        AtomicStruct.h \
        AtomicUnorderedMap.h \
        Baton.h \
        Benchmark.h \
        Bits.h \
+       CallOnce.h \
        Checksum.h \
        ConcurrentSkipList.h \
        ConcurrentSkipList-inl.h \
+       ConditionallyExistent.h \
        ContainerTraits.h \
        Conv.h \
+       CppAttributes.h \
        CpuId.h \
        CPortability.h \
        detail/AtomicHashUtils.h \
@@ -46,7 +55,6 @@ nobase_follyinclude_HEADERS = \
        detail/BitsDetail.h \
        detail/CacheLocality.h \
        detail/ChecksumDetail.h \
-       detail/Clock.h \
        detail/DiscriminatedPtrDetail.h \
        detail/ExceptionWrapper.h \
        detail/FileUtilDetail.h \
@@ -58,9 +66,13 @@ nobase_follyinclude_HEADERS = \
        detail/Malloc.h \
        detail/MemoryIdler.h \
        detail/MPMCPipelineDetail.h \
+       detail/RangeCommon.h \
+       detail/RangeSse42.h \
        detail/Sleeper.h \
        detail/SlowFingerprint.h \
+       detail/SocketFastOpen.h \
        detail/SpinLockImpl.h \
+       detail/StaticSingletonManager.h \
        detail/Stats.h \
        detail/ThreadLocalDetail.h \
        detail/TurnSequencer.h \
@@ -77,36 +89,39 @@ nobase_follyinclude_HEADERS = \
        experimental/AutoTimer.h \
        experimental/Bits.h \
        experimental/BitVectorCoding.h \
+       experimental/DynamicParser.h \
+       experimental/DynamicParser-inl.h \
        experimental/ExecutionObserver.h \
        experimental/EliasFanoCoding.h \
        experimental/EventCount.h \
        experimental/Instructions.h \
-       experimental/fibers/AddTasks.h \
-       experimental/fibers/AddTasks-inl.h \
-       experimental/fibers/Baton.h \
-       experimental/fibers/Baton-inl.h \
-       experimental/fibers/BoostContextCompatibility.h \
-       experimental/fibers/EventBaseLoopController.h \
-       experimental/fibers/EventBaseLoopController-inl.h \
-       experimental/fibers/Fiber.h \
-       experimental/fibers/Fiber-inl.h \
-       experimental/fibers/FiberManager.h \
-       experimental/fibers/FiberManager-inl.h \
-       experimental/fibers/FiberManagerMap.h \
-       experimental/fibers/ForEach.h \
-       experimental/fibers/ForEach-inl.h \
-       experimental/fibers/GenericBaton.h \
-       experimental/fibers/GuardPageAllocator.h \
-       experimental/fibers/LoopController.h \
-       experimental/fibers/Promise.h \
-       experimental/fibers/Promise-inl.h \
-       experimental/fibers/SimpleLoopController.h \
-       experimental/fibers/TimedMutex.h \
-       experimental/fibers/TimedMutex-inl.h \
-       experimental/fibers/TimeoutController.h \
-       experimental/fibers/traits.h \
-       experimental/fibers/WhenN.h \
-       experimental/fibers/WhenN-inl.h \
+       experimental/bser/Bser.h \
+       fibers/AddTasks.h \
+       fibers/AddTasks-inl.h \
+       fibers/Baton.h \
+       fibers/Baton-inl.h \
+       fibers/BoostContextCompatibility.h \
+       fibers/EventBaseLoopController.h \
+       fibers/EventBaseLoopController-inl.h \
+       fibers/Fiber.h \
+       fibers/Fiber-inl.h \
+       fibers/FiberManager.h \
+       fibers/FiberManager-inl.h \
+       fibers/FiberManagerMap.h \
+       fibers/ForEach.h \
+       fibers/ForEach-inl.h \
+       fibers/GenericBaton.h \
+       fibers/GuardPageAllocator.h \
+       fibers/LoopController.h \
+       fibers/Promise.h \
+       fibers/Promise-inl.h \
+       fibers/SimpleLoopController.h \
+       fibers/TimedMutex.h \
+       fibers/TimedMutex-inl.h \
+       fibers/TimeoutController.h \
+       fibers/traits.h \
+       fibers/WhenN.h \
+       fibers/WhenN-inl.h \
        experimental/FunctionScheduler.h \
        experimental/FutureDAG.h \
        experimental/io/FsUtil.h \
@@ -114,13 +129,21 @@ nobase_follyinclude_HEADERS = \
        experimental/LockFreeRingBuffer.h \
        experimental/NestedCommandLineApp.h \
        experimental/ProgramOptions.h \
+       experimental/ReadMostlySharedPtr.h \
+       experimental/symbolizer/Elf.h \
+       experimental/symbolizer/ElfCache.h \
+       experimental/symbolizer/Dwarf.h \
+       experimental/symbolizer/LineReader.h \
+       experimental/symbolizer/SignalHandler.h \
+       experimental/symbolizer/StackTrace.cpp \
+       experimental/symbolizer/Symbolizer.h \
        experimental/Select64.h \
        experimental/StringKeyedCommon.h \
        experimental/StringKeyedUnorderedMap.h \
        experimental/StringKeyedUnorderedSet.h \
        experimental/TestUtil.h \
+       experimental/TLRefCount.h \
        experimental/TupleOps.h \
-       SparseByteSet.h \
        FBString.h \
        FBVector.h \
        File.h \
@@ -133,7 +156,6 @@ nobase_follyinclude_HEADERS = \
        Format.h \
        Format-inl.h \
        futures/Barrier.h \
-       futures/ThreadedExecutor.h \
        futures/DrivableExecutor.h \
        futures/Future-pre.h \
        futures/helpers.h \
@@ -151,9 +173,6 @@ nobase_follyinclude_HEADERS = \
        futures/SharedPromise-inl.h \
        futures/ThreadWheelTimekeeper.h \
        futures/Timekeeper.h \
-       futures/Try-inl.h \
-       futures/Try.h \
-       futures/Unit.h \
        futures/detail/Core.h \
        futures/detail/FSM.h \
        futures/detail/Types.h \
@@ -177,10 +196,13 @@ nobase_follyinclude_HEADERS = \
        IPAddressV4.h \
        IPAddressV6.h \
        IPAddressException.h \
+       Indestructible.h \
        IndexedMemPool.h \
+       init/Init.h \
        IntrusiveList.h \
        io/Compression.h \
        io/Cursor.h \
+       io/Cursor-inl.h \
        io/IOBuf.h \
        io/IOBufQueue.h \
        io/RecordIO.h \
@@ -208,6 +230,10 @@ nobase_follyinclude_HEADERS = \
        io/async/EventUtil.h \
        io/async/NotificationQueue.h \
        io/async/HHWheelTimer.h \
+       io/async/ssl/OpenSSLPtrTypes.h \
+       io/async/ssl/OpenSSLUtils.h \
+       io/async/ssl/SSLErrors.h \
+       io/async/ssl/TLSDefinitions.h \
        io/async/Request.h \
        io/async/SSLContext.h \
        io/async/ScopedEventBaseThread.h \
@@ -219,6 +245,7 @@ nobase_follyinclude_HEADERS = \
        io/async/test/MockAsyncSSLSocket.h \
        io/async/test/MockAsyncTransport.h \
        io/async/test/MockAsyncUDPSocket.h \
+       io/async/test/MockTimeoutManager.h \
        io/async/test/SocketPair.h \
        io/async/test/TimeUtil.h \
        io/async/test/UndelayedDestruction.h \
@@ -234,6 +261,7 @@ nobase_follyinclude_HEADERS = \
        Memory.h \
        MemoryMapping.h \
        MicroSpinLock.h \
+       MicroLock.h \
        MoveWrapper.h \
        MPMCPipeline.h \
        MPMCQueue.h \
@@ -242,6 +270,36 @@ nobase_follyinclude_HEADERS = \
        Padded.h \
        PicoSpinLock.h \
        Portability.h \
+       portability/Asm.h \
+       portability/Builtins.h \
+       portability/Config.h \
+       portability/Constexpr.h \
+       portability/Dirent.h \
+       portability/Environment.h \
+       portability/Event.h \
+       portability/Fcntl.h \
+       portability/GFlags.h \
+       portability/IOVec.h \
+       portability/Libgen.h \
+       portability/Malloc.h \
+       portability/Memory.h \
+       portability/PThread.h \
+       portability/Sockets.h \
+       portability/Stdio.h \
+       portability/Stdlib.h \
+       portability/String.h \
+       portability/Syslog.h \
+       portability/SysFile.h \
+       portability/SysMman.h \
+       portability/SysResource.h \
+       portability/SysStat.h \
+       portability/SysSyscall.h \
+       portability/SysTime.h \
+       portability/SysTypes.h \
+       portability/SysUio.h \
+       portability/Time.h \
+       portability/Windows.h \
+       portability/Unistd.h \
        Preprocessor.h \
        ProducerConsumerQueue.h \
        Random.h \
@@ -252,10 +310,12 @@ nobase_follyinclude_HEADERS = \
        SharedMutex.h \
        Singleton.h \
        Singleton-inl.h \
+       SingletonThreadLocal.h \
        SmallLocks.h \
        small_vector.h \
        SocketAddress.h \
        sorted_vector_types.h \
+       SparseByteSet.h \
        SpinLock.h \
        SpookyHashV1.h \
        SpookyHashV2.h \
@@ -265,6 +325,8 @@ nobase_follyinclude_HEADERS = \
        stats/Histogram.h \
        stats/MultiLevelTimeSeries-defs.h \
        stats/MultiLevelTimeSeries.h \
+       stats/TimeseriesHistogram-defs.h \
+       stats/TimeseriesHistogram.h \
        String.h \
        String-inl.h \
        Subprocess.h \
@@ -275,13 +337,18 @@ nobase_follyinclude_HEADERS = \
        test/function_benchmark/test_functions.h \
        test/SynchronizedTestLib.h \
        test/SynchronizedTestLib-inl.h \
+       test/TestUtils.h \
        ThreadCachedArena.h \
        ThreadCachedInt.h \
        ThreadLocal.h \
        ThreadName.h \
        TimeoutQueue.h \
        Traits.h \
+       Try-inl.h \
+       Try.h \
        Unicode.h \
+       Function.h \
+       Unit.h \
        Uri.h \
        Uri-inl.h \
        Varint.h \
@@ -302,11 +369,11 @@ CLEANFILES += GroupVarintTables.cpp
 libfollybase_la_SOURCES = \
        Conv.cpp \
        Demangle.cpp \
+       detail/RangeCommon.cpp \
+       detail/RangeSse42.cpp \
        EscapeTables.cpp \
        Format.cpp \
        FormatTables.cpp \
-       Malloc.cpp \
-       Range.cpp \
        StringBase.cpp \
        String.cpp \
        Unicode.cpp
@@ -320,13 +387,14 @@ libfolly_la_SOURCES = \
        FileUtil.cpp \
        FingerprintTables.cpp \
        futures/Barrier.cpp \
-       futures/ThreadedExecutor.cpp \
        futures/Future.cpp \
        futures/InlineExecutor.cpp \
        futures/ManualExecutor.cpp \
        futures/QueuedImmediateExecutor.cpp \
        futures/ThreadWheelTimekeeper.cpp \
        detail/Futex.cpp \
+       detail/StaticSingletonManager.cpp \
+       detail/ThreadLocalDetail.cpp \
        GroupVarint.cpp \
        GroupVarintTables.cpp \
        IPAddress.cpp \
@@ -334,6 +402,7 @@ libfolly_la_SOURCES = \
        IPAddressV6.cpp \
        LifoSem.cpp \
        io/Compression.cpp \
+       io/Cursor.cpp \
        io/IOBuf.cpp \
        io/IOBufQueue.cpp \
        io/RecordIO.cpp \
@@ -349,18 +418,41 @@ libfolly_la_SOURCES = \
        io/async/EventBaseLocal.cpp \
        io/async/EventBaseManager.cpp \
        io/async/EventHandler.cpp \
+       io/async/Request.cpp \
        io/async/SSLContext.cpp \
        io/async/ScopedEventBaseThread.cpp \
        io/async/HHWheelTimer.cpp \
        io/async/test/SocketPair.cpp \
        io/async/test/TimeUtil.cpp \
+       io/async/ssl/OpenSSLUtils.cpp \
+       io/async/ssl/SSLErrors.cpp \
        json.cpp \
        detail/MemoryIdler.cpp \
+       detail/SocketFastOpen.cpp \
        MacAddress.cpp \
        MemoryMapping.cpp \
+       portability/Dirent.cpp \
+       portability/Environment.cpp \
+       portability/Fcntl.cpp \
+       portability/Libgen.cpp \
+       portability/Malloc.cpp \
+       portability/Memory.cpp \
+       portability/Sockets.cpp \
+       portability/Stdio.cpp \
+       portability/Stdlib.cpp \
+       portability/String.cpp \
+       portability/SysFile.cpp \
+       portability/SysMman.cpp \
+       portability/SysResource.cpp \
+       portability/SysStat.cpp \
+       portability/SysTime.cpp \
+       portability/SysUio.cpp \
+       portability/Time.cpp \
+       portability/Unistd.cpp \
        Random.cpp \
        SafeAssert.cpp \
        SharedMutex.cpp \
+       MicroLock.cpp \
        Singleton.cpp \
        SocketAddress.cpp \
        SpookyHashV1.cpp \
@@ -371,12 +463,15 @@ libfolly_la_SOURCES = \
        TimeoutQueue.cpp \
        Uri.cpp \
        Version.cpp \
-       experimental/fibers/Baton.cpp \
-       experimental/fibers/Fiber.cpp \
-       experimental/fibers/FiberManager.cpp \
-       experimental/fibers/FiberManagerMap.cpp \
-       experimental/fibers/GuardPageAllocator.cpp \
-       experimental/fibers/TimeoutController.cpp \
+       experimental/bser/Dump.cpp \
+       experimental/bser/Load.cpp \
+       experimental/DynamicParser.cpp \
+       fibers/Baton.cpp \
+       fibers/Fiber.cpp \
+       fibers/FiberManager.cpp \
+       fibers/FiberManagerMap.cpp \
+       fibers/GuardPageAllocator.cpp \
+       fibers/TimeoutController.cpp \
        experimental/FunctionScheduler.cpp \
        experimental/io/FsUtil.cpp \
        experimental/JSONSchema.cpp \
@@ -392,15 +487,11 @@ libfolly_la_SOURCES += \
        experimental/io/HugePages.cpp
 endif
 
-if !HAVE_LINUX
-libfollybase_la_SOURCES += detail/Clock.cpp
-endif
-
 if !HAVE_WEAK_SYMBOLS
 libfollybase_la_SOURCES += detail/MallocImpl.cpp
 endif
 
-if !HAVE_BITS_FUNCTEXCEPT
+if !HAVE_BITS_FUNCTEXCEPT_H
 libfollybase_la_SOURCES += detail/FunctionalExcept.cpp
 endif