add Cursor::readWhile() and skipWhile()
[folly.git] / folly / Makefile.am
index 1cc7a2ee193d099097fa89ff35b41a0d93977e95..60bd725d8c05737cb040b39134fe7cf9f981eef8 100644 (file)
@@ -173,8 +173,6 @@ nobase_follyinclude_HEADERS = \
        futures/SharedPromise-inl.h \
        futures/ThreadWheelTimekeeper.h \
        futures/Timekeeper.h \
-       futures/Try-inl.h \
-       futures/Try.h \
        futures/detail/Core.h \
        futures/detail/FSM.h \
        futures/detail/Types.h \
@@ -204,6 +202,7 @@ nobase_follyinclude_HEADERS = \
        IntrusiveList.h \
        io/Compression.h \
        io/Cursor.h \
+       io/Cursor-inl.h \
        io/IOBuf.h \
        io/IOBufQueue.h \
        io/RecordIO.h \
@@ -345,6 +344,8 @@ nobase_follyinclude_HEADERS = \
        ThreadName.h \
        TimeoutQueue.h \
        Traits.h \
+       Try-inl.h \
+       Try.h \
        Unicode.h \
        Function.h \
        Unit.h \
@@ -401,6 +402,7 @@ libfolly_la_SOURCES = \
        IPAddressV6.cpp \
        LifoSem.cpp \
        io/Compression.cpp \
+       io/Cursor.cpp \
        io/IOBuf.cpp \
        io/IOBufQueue.cpp \
        io/RecordIO.cpp \