Register singleton's destruction using std::atexit
[folly.git] / folly / Makefile.am
index 8144f8060144cb06520e9e8717de7cc99e039aec..60a66c8e5e5489e034c86c0fc26b1301db411181 100644 (file)
@@ -403,7 +403,6 @@ nobase_follyinclude_HEADERS = \
        Random-inl.h \
        Range.h \
        Replaceable.h \
-       RWSpinLock.h \
        ScopeGuard.h \
        SharedMutex.h \
        Singleton.h \
@@ -438,7 +437,9 @@ nobase_follyinclude_HEADERS = \
        synchronization/CallOnce.h \
        synchronization/LifoSem.h \
        synchronization/ParkingLot.h \
+       synchronization/RWSpinLock.h \
        synchronization/SaturatingSemaphore.h \
+       synchronization/WaitOptions.h \
        synchronization/detail/AtomicUtils.h \
        synchronization/detail/Sleeper.h \
        system/MemoryMapping.h \