Register singleton's destruction using std::atexit
[folly.git] / folly / Makefile.am
index 468320904fdeafa457da974bdbc1494e11071178..60a66c8e5e5489e034c86c0fc26b1301db411181 100644 (file)
@@ -27,7 +27,6 @@ lib_LTLIBRARIES = \
 follyincludedir = $(includedir)/folly
 
 nobase_follyinclude_HEADERS = \
-       Assume.h \
        AtomicBitSet.h \
        AtomicHashArray.h \
        AtomicHashArray-inl.h \
@@ -35,7 +34,6 @@ nobase_follyinclude_HEADERS = \
        AtomicHashMap-inl.h \
        AtomicIntrusiveLinkedList.h \
        AtomicLinkedList.h \
-       AtomicStruct.h \
        AtomicUnorderedMap.h \
        Benchmark.h \
        Bits.h \
@@ -59,6 +57,7 @@ nobase_follyinclude_HEADERS = \
        concurrency/UnboundedQueue.h \
        container/Access.h \
        container/Array.h \
+       container/detail/BitIteratorDetail.h \
        container/Iterator.h \
        container/Enumerate.h \
        container/EvictingCacheMap.h \
@@ -69,7 +68,6 @@ nobase_follyinclude_HEADERS = \
        detail/AtFork.h \
        detail/AtomicHashUtils.h \
        detail/AtomicUnorderedMapUtils.h \
-       detail/BitIteratorDetail.h \
        detail/DiscriminatedPtrDetail.h \
        detail/FileUtilDetail.h \
        detail/FingerprintPolynomial.h \
@@ -82,14 +80,12 @@ nobase_follyinclude_HEADERS = \
        detail/PolyDetail.h \
        detail/RangeCommon.h \
        detail/RangeSse42.h \
-       detail/Sleeper.h \
        detail/SlowFingerprint.h \
        detail/SocketFastOpen.h \
        detail/StaticSingletonManager.h \
        detail/ThreadLocalDetail.h \
        detail/TypeList.h \
        detail/TurnSequencer.h \
-       detail/UncaughtExceptionCounter.h \
        executors/Async.h \
        executors/CPUThreadPoolExecutor.h \
        executors/Codel.h \
@@ -407,7 +403,6 @@ nobase_follyinclude_HEADERS = \
        Random-inl.h \
        Range.h \
        Replaceable.h \
-       RWSpinLock.h \
        ScopeGuard.h \
        SharedMutex.h \
        Singleton.h \
@@ -437,10 +432,16 @@ nobase_follyinclude_HEADERS = \
        stats/TimeseriesHistogram-defs.h \
        stats/TimeseriesHistogram.h \
        synchronization/AsymmetricMemoryBarrier.h \
+       synchronization/AtomicStruct.h \
        synchronization/Baton.h \
        synchronization/CallOnce.h \
        synchronization/LifoSem.h \
+       synchronization/ParkingLot.h \
+       synchronization/RWSpinLock.h \
+       synchronization/SaturatingSemaphore.h \
+       synchronization/WaitOptions.h \
        synchronization/detail/AtomicUtils.h \
+       synchronization/detail/Sleeper.h \
        system/MemoryMapping.h \
        system/Shell.h \
        system/ThreadId.h \
@@ -627,6 +628,7 @@ libfolly_la_SOURCES = \
        stats/TimeseriesHistogram.cpp \
        synchronization/AsymmetricMemoryBarrier.cpp \
        synchronization/LifoSem.cpp \
+       synchronization/ParkingLot.cpp \
        system/MemoryMapping.cpp \
        system/Shell.cpp \
        system/ThreadName.cpp \