Register singleton's destruction using std::atexit
[folly.git] / folly / Makefile.am
index 2bf6bae77d18166229d4bff3dfc00288778458d9..60a66c8e5e5489e034c86c0fc26b1301db411181 100644 (file)
@@ -27,7 +27,6 @@ lib_LTLIBRARIES = \
 follyincludedir = $(includedir)/folly
 
 nobase_follyinclude_HEADERS = \
-       Assume.h \
        AtomicBitSet.h \
        AtomicHashArray.h \
        AtomicHashArray-inl.h \
@@ -35,9 +34,7 @@ nobase_follyinclude_HEADERS = \
        AtomicHashMap-inl.h \
        AtomicIntrusiveLinkedList.h \
        AtomicLinkedList.h \
-       AtomicStruct.h \
        AtomicUnorderedMap.h \
-       Baton.h \
        Benchmark.h \
        Bits.h \
        CachelinePadded.h \
@@ -57,8 +54,10 @@ nobase_follyinclude_HEADERS = \
        concurrency/ConcurrentHashMap.h \
        concurrency/CoreCachedSharedPtr.h \
        concurrency/detail/ConcurrentHashMap-detail.h \
+       concurrency/UnboundedQueue.h \
        container/Access.h \
        container/Array.h \
+       container/detail/BitIteratorDetail.h \
        container/Iterator.h \
        container/Enumerate.h \
        container/EvictingCacheMap.h \
@@ -66,9 +65,9 @@ nobase_follyinclude_HEADERS = \
        container/Foreach-inl.h \
        container/SparseByteSet.h \
        ConstexprMath.h \
+       detail/AtFork.h \
        detail/AtomicHashUtils.h \
        detail/AtomicUnorderedMapUtils.h \
-       detail/BitIteratorDetail.h \
        detail/DiscriminatedPtrDetail.h \
        detail/FileUtilDetail.h \
        detail/FingerprintPolynomial.h \
@@ -81,14 +80,12 @@ nobase_follyinclude_HEADERS = \
        detail/PolyDetail.h \
        detail/RangeCommon.h \
        detail/RangeSse42.h \
-       detail/Sleeper.h \
        detail/SlowFingerprint.h \
        detail/SocketFastOpen.h \
        detail/StaticSingletonManager.h \
        detail/ThreadLocalDetail.h \
        detail/TypeList.h \
        detail/TurnSequencer.h \
-       detail/UncaughtExceptionCounter.h \
        executors/Async.h \
        executors/CPUThreadPoolExecutor.h \
        executors/Codel.h \
@@ -156,14 +153,21 @@ nobase_follyinclude_HEADERS = \
        experimental/JSONSchema.h \
        experimental/LockFreeRingBuffer.h \
        experimental/logging/AsyncFileWriter.h \
+       experimental/logging/FileHandlerFactory.h \
+       experimental/logging/FileWriterFactory.h \
        experimental/logging/GlogStyleFormatter.h \
        experimental/logging/ImmediateFileWriter.h \
        experimental/logging/Init.h \
        experimental/logging/LogCategory.h \
+       experimental/logging/LogCategoryConfig.h \
+       experimental/logging/LogConfig.h \
+       experimental/logging/LogConfigParser.h \
        experimental/logging/LogFormatter.h \
        experimental/logging/Logger.h \
        experimental/logging/LoggerDB.h \
        experimental/logging/LogHandler.h \
+       experimental/logging/LogHandlerFactory.h \
+       experimental/logging/LogHandlerConfig.h \
        experimental/logging/LogLevel.h \
        experimental/logging/LogMessage.h \
        experimental/logging/LogName.h \
@@ -173,6 +177,8 @@ nobase_follyinclude_HEADERS = \
        experimental/logging/printf.h \
        experimental/logging/RateLimiter.h \
        experimental/logging/StandardLogHandler.h \
+       experimental/logging/StandardLogHandlerFactory.h \
+       experimental/logging/StreamHandlerFactory.h \
        experimental/logging/xlog.h \
        experimental/NestedCommandLineApp.h \
        experimental/observer/detail/Core.h \
@@ -314,7 +320,9 @@ nobase_follyinclude_HEADERS = \
        io/async/test/UndelayedDestruction.h \
        io/async/test/Util.h \
        json.h \
+       lang/Align.h \
        lang/Assume.h \
+       lang/Bits.h \
        lang/ColdClass.h \
        lang/Launder.h \
        lang/RValueReferenceWrapper.h \
@@ -395,7 +403,6 @@ nobase_follyinclude_HEADERS = \
        Random-inl.h \
        Range.h \
        Replaceable.h \
-       RWSpinLock.h \
        ScopeGuard.h \
        SharedMutex.h \
        Singleton.h \
@@ -425,9 +432,16 @@ nobase_follyinclude_HEADERS = \
        stats/TimeseriesHistogram-defs.h \
        stats/TimeseriesHistogram.h \
        synchronization/AsymmetricMemoryBarrier.h \
+       synchronization/AtomicStruct.h \
+       synchronization/Baton.h \
        synchronization/CallOnce.h \
        synchronization/LifoSem.h \
+       synchronization/ParkingLot.h \
+       synchronization/RWSpinLock.h \
+       synchronization/SaturatingSemaphore.h \
+       synchronization/WaitOptions.h \
        synchronization/detail/AtomicUtils.h \
+       synchronization/detail/Sleeper.h \
        system/MemoryMapping.h \
        system/Shell.h \
        system/ThreadId.h \
@@ -499,6 +513,7 @@ libfolly_la_SOURCES = \
        compression/Compression.cpp \
        compression/Zlib.cpp \
        concurrency/CacheLocality.cpp \
+       detail/AtFork.cpp \
        detail/Futex.cpp \
        detail/IPAddress.cpp \
        detail/StaticSingletonManager.cpp \
@@ -613,6 +628,7 @@ libfolly_la_SOURCES = \
        stats/TimeseriesHistogram.cpp \
        synchronization/AsymmetricMemoryBarrier.cpp \
        synchronization/LifoSem.cpp \
+       synchronization/ParkingLot.cpp \
        system/MemoryMapping.cpp \
        system/Shell.cpp \
        system/ThreadName.cpp \
@@ -730,6 +746,10 @@ libfollybase_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LT_VERSION)
 libfolly_la_LIBADD = libfollybase.la
 libfolly_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LT_VERSION) -lssl
 
+if USE_SYMBOLIZER
+libfolly_la_LDFLAGS += -lunwind
+endif
+
 FingerprintTables.cpp: generate_fingerprint_tables
        ./generate_fingerprint_tables
 CLEANFILES += FingerprintTables.cpp