Register singleton's destruction using std::atexit
[folly.git] / folly / Makefile.am
index 19f31af42482c40620d847672732ae00a0a8d9cf..60a66c8e5e5489e034c86c0fc26b1301db411181 100644 (file)
@@ -57,6 +57,7 @@ nobase_follyinclude_HEADERS = \
        concurrency/UnboundedQueue.h \
        container/Access.h \
        container/Array.h \
+       container/detail/BitIteratorDetail.h \
        container/Iterator.h \
        container/Enumerate.h \
        container/EvictingCacheMap.h \
@@ -67,7 +68,6 @@ nobase_follyinclude_HEADERS = \
        detail/AtFork.h \
        detail/AtomicHashUtils.h \
        detail/AtomicUnorderedMapUtils.h \
-       detail/BitIteratorDetail.h \
        detail/DiscriminatedPtrDetail.h \
        detail/FileUtilDetail.h \
        detail/FingerprintPolynomial.h \
@@ -86,7 +86,6 @@ nobase_follyinclude_HEADERS = \
        detail/ThreadLocalDetail.h \
        detail/TypeList.h \
        detail/TurnSequencer.h \
-       detail/UncaughtExceptionCounter.h \
        executors/Async.h \
        executors/CPUThreadPoolExecutor.h \
        executors/Codel.h \
@@ -404,7 +403,6 @@ nobase_follyinclude_HEADERS = \
        Random-inl.h \
        Range.h \
        Replaceable.h \
-       RWSpinLock.h \
        ScopeGuard.h \
        SharedMutex.h \
        Singleton.h \
@@ -438,6 +436,10 @@ nobase_follyinclude_HEADERS = \
        synchronization/Baton.h \
        synchronization/CallOnce.h \
        synchronization/LifoSem.h \
+       synchronization/ParkingLot.h \
+       synchronization/RWSpinLock.h \
+       synchronization/SaturatingSemaphore.h \
+       synchronization/WaitOptions.h \
        synchronization/detail/AtomicUtils.h \
        synchronization/detail/Sleeper.h \
        system/MemoryMapping.h \
@@ -626,6 +628,7 @@ libfolly_la_SOURCES = \
        stats/TimeseriesHistogram.cpp \
        synchronization/AsymmetricMemoryBarrier.cpp \
        synchronization/LifoSem.cpp \
+       synchronization/ParkingLot.cpp \
        system/MemoryMapping.cpp \
        system/Shell.cpp \
        system/ThreadName.cpp \