Split tests into test and benchmarks.
[folly.git] / folly / Makefile.am
index 929676401b6126032407ec985fe567ce3a157e2f..569879db823d16b66c565ba341f3bd38fa9c6198 100644 (file)
@@ -1,4 +1,8 @@
+if FOLLY_TESTMAIN
+SUBDIRS = . experimental init test
+else
 SUBDIRS = . test
+endif
 
 ACLOCAL_AMFLAGS = -I m4
 
@@ -30,15 +34,17 @@ nobase_follyinclude_HEADERS = \
        AtomicLinkedList.h \
        AtomicStruct.h \
        AtomicUnorderedMap.h \
-       CppAttributes.h \
        Baton.h \
        Benchmark.h \
        Bits.h \
+       CallOnce.h \
        Checksum.h \
        ConcurrentSkipList.h \
        ConcurrentSkipList-inl.h \
+       ConditionallyExistent.h \
        ContainerTraits.h \
        Conv.h \
+       CppAttributes.h \
        CpuId.h \
        CPortability.h \
        detail/AtomicHashUtils.h \
@@ -84,6 +90,7 @@ nobase_follyinclude_HEADERS = \
        experimental/EliasFanoCoding.h \
        experimental/EventCount.h \
        experimental/Instructions.h \
+       experimental/bser/Bser.h \
        experimental/fibers/AddTasks.h \
        experimental/fibers/AddTasks-inl.h \
        experimental/fibers/Baton.h \
@@ -118,6 +125,13 @@ nobase_follyinclude_HEADERS = \
        experimental/NestedCommandLineApp.h \
        experimental/ProgramOptions.h \
        experimental/ReadMostlySharedPtr.h \
+       experimental/symbolizer/Elf.h \
+       experimental/symbolizer/ElfCache.h \
+       experimental/symbolizer/Dwarf.h \
+       experimental/symbolizer/LineReader.h \
+       experimental/symbolizer/SignalHandler.h \
+       experimental/symbolizer/StackTrace.cpp \
+       experimental/symbolizer/Symbolizer.h \
        experimental/Select64.h \
        experimental/StringKeyedCommon.h \
        experimental/StringKeyedUnorderedMap.h \
@@ -125,7 +139,6 @@ nobase_follyinclude_HEADERS = \
        experimental/TestUtil.h \
        experimental/TLRefCount.h \
        experimental/TupleOps.h \
-       SparseByteSet.h \
        FBString.h \
        FBVector.h \
        File.h \
@@ -182,7 +195,9 @@ nobase_follyinclude_HEADERS = \
        IPAddressV4.h \
        IPAddressV6.h \
        IPAddressException.h \
+       Indestructible.h \
        IndexedMemPool.h \
+       init/Init.h \
        IntrusiveList.h \
        io/Compression.h \
        io/Cursor.h \
@@ -213,6 +228,7 @@ nobase_follyinclude_HEADERS = \
        io/async/EventUtil.h \
        io/async/NotificationQueue.h \
        io/async/HHWheelTimer.h \
+       io/async/OpenSSLPtrTypes.h \
        io/async/Request.h \
        io/async/SSLContext.h \
        io/async/ScopedEventBaseThread.h \
@@ -224,6 +240,7 @@ nobase_follyinclude_HEADERS = \
        io/async/test/MockAsyncSSLSocket.h \
        io/async/test/MockAsyncTransport.h \
        io/async/test/MockAsyncUDPSocket.h \
+       io/async/test/MockTimeoutManager.h \
        io/async/test/SocketPair.h \
        io/async/test/TimeUtil.h \
        io/async/test/UndelayedDestruction.h \
@@ -247,6 +264,11 @@ nobase_follyinclude_HEADERS = \
        Padded.h \
        PicoSpinLock.h \
        Portability.h \
+       portability/Constexpr.h \
+       portability/Environment.h \
+       portability/GFlags.h \
+       portability/Syscall.h \
+       portability/SysUio.h \
        Preprocessor.h \
        ProducerConsumerQueue.h \
        Random.h \
@@ -257,10 +279,12 @@ nobase_follyinclude_HEADERS = \
        SharedMutex.h \
        Singleton.h \
        Singleton-inl.h \
+       SingletonThreadLocal.h \
        SmallLocks.h \
        small_vector.h \
        SocketAddress.h \
        sorted_vector_types.h \
+       SparseByteSet.h \
        SpinLock.h \
        SpookyHashV1.h \
        SpookyHashV2.h \
@@ -358,6 +382,7 @@ libfolly_la_SOURCES = \
        io/async/EventBaseLocal.cpp \
        io/async/EventBaseManager.cpp \
        io/async/EventHandler.cpp \
+       io/async/Request.cpp \
        io/async/SSLContext.cpp \
        io/async/ScopedEventBaseThread.cpp \
        io/async/HHWheelTimer.cpp \
@@ -367,6 +392,7 @@ libfolly_la_SOURCES = \
        detail/MemoryIdler.cpp \
        MacAddress.cpp \
        MemoryMapping.cpp \
+       portability/Environment.cpp \
        Random.cpp \
        SafeAssert.cpp \
        SharedMutex.cpp \
@@ -380,6 +406,8 @@ libfolly_la_SOURCES = \
        TimeoutQueue.cpp \
        Uri.cpp \
        Version.cpp \
+       experimental/bser/Dump.cpp \
+       experimental/bser/Load.cpp \
        experimental/fibers/Baton.cpp \
        experimental/fibers/Fiber.cpp \
        experimental/fibers/FiberManager.cpp \