Added a for_each function to iterate through ranges
[folly.git] / folly / Makefile.am
index f1872fea5b62d859218a451a4b0c0e4df5f96286..40f9d7fdff8116a93ed4134e32e6889c88a6abbb 100644 (file)
@@ -187,6 +187,7 @@ nobase_follyinclude_HEADERS = \
        FixedString.h \
        folly-config.h \
        Foreach.h \
+       Foreach-inl.h \
        FormatArg.h \
        FormatTraits.h \
        Format.h \
@@ -298,6 +299,8 @@ nobase_follyinclude_HEADERS = \
        io/async/test/TimeUtil.h \
        io/async/test/UndelayedDestruction.h \
        io/async/test/Util.h \
+       io/compression/Utils.h \
+       io/compression/Zlib.h \
        Iterator.h \
        json.h \
        Launder.h \
@@ -533,6 +536,7 @@ libfolly_la_SOURCES = \
        io/async/test/TimeUtil.cpp \
        io/async/ssl/OpenSSLUtils.cpp \
        io/async/ssl/SSLErrors.cpp \
+       io/compression/Zlib.cpp \
        json.cpp \
        detail/MemoryIdler.cpp \
        detail/SocketFastOpen.cpp \