Added a for_each function to iterate through ranges
[folly.git] / folly / Makefile.am
index 54788e69e5d4287ea1d899851392b88e72c958bf..40f9d7fdff8116a93ed4134e32e6889c88a6abbb 100644 (file)
@@ -57,7 +57,9 @@ nobase_follyinclude_HEADERS = \
        CpuId.h \
        CPortability.h \
        concurrency/CacheLocality.h \
+       concurrency/ConcurrentHashMap.h \
        concurrency/CoreCachedSharedPtr.h \
+       concurrency/detail/ConcurrentHashMap-detail.h \
        detail/AtomicHashUtils.h \
        detail/AtomicUnorderedMapUtils.h \
        detail/AtomicUtils.h \
@@ -119,6 +121,10 @@ nobase_follyinclude_HEADERS = \
        experimental/exception_tracer/StackTrace.h \
        experimental/FunctionScheduler.h \
        experimental/FutureDAG.h \
+       experimental/hazptr/debug.h \
+       experimental/hazptr/hazptr.h \
+       experimental/hazptr/hazptr-impl.h \
+       experimental/hazptr/memory_resource.h \
        experimental/io/FsUtil.h \
        experimental/JemallocNodumpAllocator.h \
        experimental/JSONSchema.h \
@@ -181,6 +187,7 @@ nobase_follyinclude_HEADERS = \
        FixedString.h \
        folly-config.h \
        Foreach.h \
+       Foreach-inl.h \
        FormatArg.h \
        FormatTraits.h \
        Format.h \
@@ -223,6 +230,7 @@ nobase_follyinclude_HEADERS = \
        gen/ParallelMap-inl.h \
        gen/String.h \
        gen/String-inl.h \
+       GlobalThreadPoolList.h \
        GroupVarint.h \
        Hash.h \
        IPAddress.h \
@@ -291,6 +299,8 @@ nobase_follyinclude_HEADERS = \
        io/async/test/TimeUtil.h \
        io/async/test/UndelayedDestruction.h \
        io/async/test/Util.h \
+       io/compression/Utils.h \
+       io/compression/Zlib.h \
        Iterator.h \
        json.h \
        Launder.h \
@@ -402,6 +412,7 @@ nobase_follyinclude_HEADERS = \
        String-inl.h \
        Subprocess.h \
        Synchronized.h \
+       SynchronizedPtr.h \
        test/FBStringTestBenchmarks.cpp.h \
        test/FBVectorTestBenchmarks.cpp.h \
        test/function_benchmark/benchmark_impl.h \
@@ -454,6 +465,7 @@ libfollybase_la_SOURCES = \
        detail/RangeCommon.cpp \
        EscapeTables.cpp \
        Format.cpp \
+       FormatArg.cpp \
        FormatTables.cpp \
        MallctlHelper.cpp \
        portability/BitsFunctexcept.cpp \
@@ -465,7 +477,10 @@ libfolly_la_SOURCES = \
        Checksum.cpp \
        ClockGettimeWrappers.cpp \
        concurrency/CacheLocality.cpp \
+       detail/Futex.cpp \
        detail/IPAddress.cpp \
+       detail/StaticSingletonManager.cpp \
+       detail/ThreadLocalDetail.cpp \
        dynamic.cpp \
        ExceptionWrapper.cpp \
        Executor.cpp \
@@ -479,13 +494,13 @@ libfolly_la_SOURCES = \
        futures/QueuedImmediateExecutor.cpp \
        futures/ThreadWheelTimekeeper.cpp \
        futures/test/TestExecutor.cpp \
-       detail/Futex.cpp \
-       detail/StaticSingletonManager.cpp \
-       detail/ThreadLocalDetail.cpp \
-       hash/SpookyHashV1.cpp \
-       hash/SpookyHashV2.cpp \
+       experimental/hazptr/hazptr.cpp \
+       experimental/hazptr/memory_resource.cpp \
+       GlobalThreadPoolList.cpp \
        GroupVarint.cpp \
        GroupVarintTables.cpp \
+       hash/SpookyHashV1.cpp \
+       hash/SpookyHashV2.cpp \
        IPAddress.cpp \
        IPAddressV4.cpp \
        IPAddressV6.cpp \
@@ -521,6 +536,7 @@ libfolly_la_SOURCES = \
        io/async/test/TimeUtil.cpp \
        io/async/ssl/OpenSSLUtils.cpp \
        io/async/ssl/SSLErrors.cpp \
+       io/compression/Zlib.cpp \
        json.cpp \
        detail/MemoryIdler.cpp \
        detail/SocketFastOpen.cpp \