Added a for_each function to iterate through ranges
[folly.git] / folly / Makefile.am
index 00796bb46390c88016efe9b2d38c65d16576f105..40f9d7fdff8116a93ed4134e32e6889c88a6abbb 100644 (file)
@@ -2,12 +2,10 @@ if FOLLY_TESTMAIN
 MAYBE_INIT = init
 endif
 
-if EXCEPTION_TRACER
-MAYBE_EXCEPTION_TRACER = experimental/exception_tracer
-endif
-
-SUBDIRS = . experimental $(MAYBE_INIT) test io/test experimental/io/test \
-         $(MAYBE_EXCEPTION_TRACER)
+# Note that the order of SUBDIRS matters.
+# Many subdirectories depend on libfollytest from the test directory,
+# so it must appear before other directories
+SUBDIRS = . test experimental $(MAYBE_INIT) io/test stats/test
 
 ACLOCAL_AMFLAGS = -I m4
 
@@ -58,14 +56,14 @@ nobase_follyinclude_HEADERS = \
        CppAttributes.h \
        CpuId.h \
        CPortability.h \
+       concurrency/CacheLocality.h \
+       concurrency/ConcurrentHashMap.h \
        concurrency/CoreCachedSharedPtr.h \
+       concurrency/detail/ConcurrentHashMap-detail.h \
        detail/AtomicHashUtils.h \
        detail/AtomicUnorderedMapUtils.h \
        detail/AtomicUtils.h \
        detail/BitIteratorDetail.h \
-       detail/BitsDetail.h \
-       detail/CacheLocality.h \
-       detail/CachelinePaddedImpl.h \
        detail/ChecksumDetail.h \
        detail/DiscriminatedPtrDetail.h \
        detail/FileUtilDetail.h \
@@ -74,7 +72,7 @@ nobase_follyinclude_HEADERS = \
        detail/GroupVarintDetail.h \
        detail/IPAddress.h \
        detail/IPAddressSource.h \
-       detail/Malloc.h \
+       detail/MallocImpl.h \
        detail/MemoryIdler.h \
        detail/MPMCPipelineDetail.h \
        detail/RangeCommon.h \
@@ -83,7 +81,6 @@ nobase_follyinclude_HEADERS = \
        detail/SlowFingerprint.h \
        detail/SocketFastOpen.h \
        detail/StaticSingletonManager.h \
-       detail/Stats.h \
        detail/ThreadLocalDetail.h \
        detail/TryDetail.h \
        detail/TurnSequencer.h \
@@ -101,9 +98,9 @@ nobase_follyinclude_HEADERS = \
        ExceptionWrapper-inl.h \
        Executor.h \
        Expected.h \
+       concurrency/AtomicSharedPtr.h \
+       concurrency/detail/AtomicSharedPtr-detail.h \
        experimental/AsymmetricMemoryBarrier.h \
-       experimental/AtomicSharedPtr.h \
-       experimental/detail/AtomicSharedPtr-detail.h \
        experimental/AutoTimer.h \
        experimental/ThreadedRepeatingFunctionRunner.h \
        experimental/Bits.h \
@@ -124,10 +121,33 @@ nobase_follyinclude_HEADERS = \
        experimental/exception_tracer/StackTrace.h \
        experimental/FunctionScheduler.h \
        experimental/FutureDAG.h \
+       experimental/hazptr/debug.h \
+       experimental/hazptr/hazptr.h \
+       experimental/hazptr/hazptr-impl.h \
+       experimental/hazptr/memory_resource.h \
        experimental/io/FsUtil.h \
        experimental/JemallocNodumpAllocator.h \
        experimental/JSONSchema.h \
        experimental/LockFreeRingBuffer.h \
+       experimental/logging/AsyncFileWriter.h \
+       experimental/logging/GlogStyleFormatter.h \
+       experimental/logging/ImmediateFileWriter.h \
+       experimental/logging/Init.h \
+       experimental/logging/LogCategory.h \
+       experimental/logging/LogFormatter.h \
+       experimental/logging/Logger.h \
+       experimental/logging/LoggerDB.h \
+       experimental/logging/LogHandler.h \
+       experimental/logging/LogLevel.h \
+       experimental/logging/LogMessage.h \
+       experimental/logging/LogName.h \
+       experimental/logging/LogStream.h \
+       experimental/logging/LogStreamProcessor.h \
+       experimental/logging/LogWriter.h \
+       experimental/logging/printf.h \
+       experimental/logging/RateLimiter.h \
+       experimental/logging/StandardLogHandler.h \
+       experimental/logging/xlog.h \
        experimental/NestedCommandLineApp.h \
        experimental/observer/detail/Core.h \
        experimental/observer/detail/GraphCycleDetector.h \
@@ -167,6 +187,7 @@ nobase_follyinclude_HEADERS = \
        FixedString.h \
        folly-config.h \
        Foreach.h \
+       Foreach-inl.h \
        FormatArg.h \
        FormatTraits.h \
        Format.h \
@@ -181,7 +202,6 @@ nobase_follyinclude_HEADERS = \
        futures/FutureSplitter.h \
        futures/InlineExecutor.h \
        futures/ManualExecutor.h \
-       futures/OpaqueCallbackShunt.h \
        futures/Promise-inl.h \
        futures/Promise.h \
        futures/QueuedImmediateExecutor.h \
@@ -194,6 +214,8 @@ nobase_follyinclude_HEADERS = \
        futures/detail/FSM.h \
        futures/detail/Types.h \
        futures/test/TestExecutor.h \
+       hash/SpookyHashV1.h \
+       hash/SpookyHashV2.h \
        gen/Base.h \
        gen/Base-inl.h \
        gen/Combine.h \
@@ -208,6 +230,7 @@ nobase_follyinclude_HEADERS = \
        gen/ParallelMap-inl.h \
        gen/String.h \
        gen/String-inl.h \
+       GlobalThreadPoolList.h \
        GroupVarint.h \
        Hash.h \
        IPAddress.h \
@@ -256,6 +279,7 @@ nobase_follyinclude_HEADERS = \
        io/async/ssl/TLSDefinitions.h \
        io/async/Request.h \
        io/async/SSLContext.h \
+       io/async/SSLOptions.h \
        io/async/ScopedEventBaseThread.h \
        io/async/TimeoutManager.h \
        io/async/VirtualEventBase.h \
@@ -275,8 +299,11 @@ nobase_follyinclude_HEADERS = \
        io/async/test/TimeUtil.h \
        io/async/test/UndelayedDestruction.h \
        io/async/test/Util.h \
+       io/compression/Utils.h \
+       io/compression/Zlib.h \
        Iterator.h \
        json.h \
+       Launder.h \
        Lazy.h \
        LifoSem.h \
        Likely.h \
@@ -290,6 +317,7 @@ nobase_follyinclude_HEADERS = \
        Math.h \
        Memory.h \
        MemoryMapping.h \
+       memory/UninitializedMemoryHacks.h \
        MicroSpinLock.h \
        MicroLock.h \
        MoveWrapper.h \
@@ -321,6 +349,7 @@ nobase_follyinclude_HEADERS = \
        portability/Memory.h \
        portability/OpenSSL.h \
        portability/PThread.h \
+       portability/Semaphore.h \
        portability/Sockets.h \
        portability/Stdio.h \
        portability/Stdlib.h \
@@ -337,14 +366,15 @@ nobase_follyinclude_HEADERS = \
        portability/SysUio.h \
        portability/Time.h \
        portability/TypeTraits.h \
-       portability/Windows.h \
        portability/Unistd.h \
+       portability/Windows.h \
        Preprocessor.h \
        PriorityMPMCQueue.h \
        ProducerConsumerQueue.h \
        Random.h \
        Random-inl.h \
        Range.h \
+       Replaceable.h \
        RWSpinLock.h \
        SafeAssert.h \
        ScopeGuard.h \
@@ -359,14 +389,16 @@ nobase_follyinclude_HEADERS = \
        sorted_vector_types.h \
        SparseByteSet.h \
        SpinLock.h \
-       SpookyHashV1.h \
-       SpookyHashV2.h \
+       ssl/Init.h \
        ssl/OpenSSLCertUtils.h \
        ssl/OpenSSLHash.h \
        ssl/OpenSSLPtrTypes.h \
        ssl/OpenSSLVersionFinder.h \
        ssl/SSLSession.h \
+       ssl/OpenSSLLockTypes.h \
+       ssl/detail/OpenSSLThreading.h \
        ssl/detail/SSLSessionImpl.h \
+       stats/detail/Bucket.h \
        stats/BucketedTimeSeries-defs.h \
        stats/BucketedTimeSeries.h \
        stats/Histogram-defs.h \
@@ -380,6 +412,7 @@ nobase_follyinclude_HEADERS = \
        String-inl.h \
        Subprocess.h \
        Synchronized.h \
+       SynchronizedPtr.h \
        test/FBStringTestBenchmarks.cpp.h \
        test/FBVectorTestBenchmarks.cpp.h \
        test/function_benchmark/benchmark_impl.h \
@@ -422,6 +455,7 @@ GroupVarintTables.cpp: build/generate_varint_tables.py
 CLEANFILES += GroupVarintTables.cpp
 
 libfollybasesse42_la_SOURCES = \
+       detail/Crc32cDetail.cpp \
        detail/ChecksumDetail.cpp \
        detail/RangeSse42.cpp
 
@@ -431,20 +465,22 @@ libfollybase_la_SOURCES = \
        detail/RangeCommon.cpp \
        EscapeTables.cpp \
        Format.cpp \
+       FormatArg.cpp \
        FormatTables.cpp \
        MallctlHelper.cpp \
        portability/BitsFunctexcept.cpp \
-       StringBase.cpp \
        String.cpp \
        Unicode.cpp
 
 libfolly_la_SOURCES = \
        Assume.cpp \
-       Bits.cpp \
        Checksum.cpp \
        ClockGettimeWrappers.cpp \
-       detail/CacheLocality.cpp \
+       concurrency/CacheLocality.cpp \
+       detail/Futex.cpp \
        detail/IPAddress.cpp \
+       detail/StaticSingletonManager.cpp \
+       detail/ThreadLocalDetail.cpp \
        dynamic.cpp \
        ExceptionWrapper.cpp \
        Executor.cpp \
@@ -453,16 +489,18 @@ libfolly_la_SOURCES = \
        FingerprintTables.cpp \
        futures/Barrier.cpp \
        futures/Future.cpp \
-       futures/InlineExecutor.cpp \
+       futures/FutureException.cpp \
        futures/ManualExecutor.cpp \
        futures/QueuedImmediateExecutor.cpp \
        futures/ThreadWheelTimekeeper.cpp \
        futures/test/TestExecutor.cpp \
-       detail/Futex.cpp \
-       detail/StaticSingletonManager.cpp \
-       detail/ThreadLocalDetail.cpp \
+       experimental/hazptr/hazptr.cpp \
+       experimental/hazptr/memory_resource.cpp \
+       GlobalThreadPoolList.cpp \
        GroupVarint.cpp \
        GroupVarintTables.cpp \
+       hash/SpookyHashV1.cpp \
+       hash/SpookyHashV2.cpp \
        IPAddress.cpp \
        IPAddressV4.cpp \
        IPAddressV6.cpp \
@@ -488,6 +526,7 @@ libfolly_la_SOURCES = \
        io/async/EventHandler.cpp \
        io/async/Request.cpp \
        io/async/SSLContext.cpp \
+       io/async/SSLOptions.cpp \
        io/async/ScopedEventBaseThread.cpp \
        io/async/VirtualEventBase.cpp \
        io/async/HHWheelTimer.cpp \
@@ -497,6 +536,7 @@ libfolly_la_SOURCES = \
        io/async/test/TimeUtil.cpp \
        io/async/ssl/OpenSSLUtils.cpp \
        io/async/ssl/SSLErrors.cpp \
+       io/compression/Zlib.cpp \
        json.cpp \
        detail/MemoryIdler.cpp \
        detail/SocketFastOpen.cpp \
@@ -531,16 +571,20 @@ libfolly_la_SOURCES = \
        Optional.cpp \
        Singleton.cpp \
        SocketAddress.cpp \
-       SpookyHashV1.cpp \
-       SpookyHashV2.cpp \
+       ssl/Init.cpp \
        ssl/OpenSSLCertUtils.cpp \
        ssl/OpenSSLHash.cpp \
+       ssl/detail/OpenSSLThreading.cpp \
        ssl/detail/SSLSessionImpl.cpp \
-       stats/Instantiations.cpp \
+       stats/BucketedTimeSeries.cpp \
+       stats/Histogram.cpp \
+       stats/MultiLevelTimeSeries.cpp \
+       stats/TimeseriesHistogram.cpp \
        Subprocess.cpp \
        ThreadCachedArena.cpp \
        ThreadName.cpp \
        TimeoutQueue.cpp \
+       Try.cpp \
        Uri.cpp \
        Version.cpp \
        experimental/AsymmetricMemoryBarrier.cpp \