Add exception_tracer to OSS build
[folly.git] / folly / Makefile.am
index 4bde2ae3ee190ef3bc6e023f105bde10f13c29c2..3d5fd9ba5816c27af5a3a18f6445d07fe098fc52 100644 (file)
@@ -1,9 +1,14 @@
 if FOLLY_TESTMAIN
 if FOLLY_TESTMAIN
-SUBDIRS = . experimental init test io/test experimental/io/test
-else
-SUBDIRS = . experimental test io/test experimental/io/test
+MAYBE_INIT = init
 endif
 
 endif
 
+if EXCEPTION_TRACER
+MAYBE_EXCEPTION_TRACER = experimental/exception_tracer
+endif
+
+SUBDIRS = . experimental $(MAYBE_INIT) test io/test experimental/io/test \
+         $(MAYBE_EXCEPTION_TRACER)
+
 ACLOCAL_AMFLAGS = -I m4
 
 CLEANFILES =
 ACLOCAL_AMFLAGS = -I m4
 
 CLEANFILES =
@@ -109,6 +114,11 @@ nobase_follyinclude_HEADERS = \
        experimental/EventCount.h \
        experimental/Instructions.h \
        experimental/bser/Bser.h \
        experimental/EventCount.h \
        experimental/Instructions.h \
        experimental/bser/Bser.h \
+       experimental/exception_tracer/ExceptionAbi.h \
+       experimental/exception_tracer/ExceptionCounterLib.h \
+       experimental/exception_tracer/ExceptionTracer.h \
+       experimental/exception_tracer/ExceptionTracerLib.h \
+       experimental/exception_tracer/StackTrace.h \
        experimental/FunctionScheduler.h \
        experimental/FutureDAG.h \
        experimental/io/FsUtil.h \
        experimental/FunctionScheduler.h \
        experimental/FutureDAG.h \
        experimental/io/FsUtil.h \