Add Tearable, for concurrently-modified non-atomic objects.
[folly.git] / folly / Makefile.am
index c1327fc4d4082fba16e733e0051445ebcc504b49..3ba08f4c5df7f4c6996bf3fe31963cc0c9ac0cbe 100644 (file)
@@ -439,6 +439,8 @@ nobase_follyinclude_HEADERS = \
        synchronization/ParkingLot.h \
        synchronization/RWSpinLock.h \
        synchronization/SaturatingSemaphore.h \
+       synchronization/Tearable.h \
+       synchronization/WaitOptions.h \
        synchronization/detail/AtomicUtils.h \
        synchronization/detail/Sleeper.h \
        system/MemoryMapping.h \
@@ -593,7 +595,6 @@ libfolly_la_SOURCES = \
        portability/Fcntl.cpp \
        portability/Libgen.cpp \
        portability/Malloc.cpp \
-       portability/Memory.cpp \
        portability/OpenSSL.cpp \
        portability/PThread.cpp \
        portability/Sockets.cpp \