Add Tearable, for concurrently-modified non-atomic objects.
[folly.git] / folly / Makefile.am
index 9bc83a13cb0caa5e4979b568da0a0c1a07e53a5d..3ba08f4c5df7f4c6996bf3fe31963cc0c9ac0cbe 100644 (file)
@@ -57,6 +57,7 @@ nobase_follyinclude_HEADERS = \
        concurrency/UnboundedQueue.h \
        container/Access.h \
        container/Array.h \
+       container/detail/BitIteratorDetail.h \
        container/Iterator.h \
        container/Enumerate.h \
        container/EvictingCacheMap.h \
@@ -67,7 +68,6 @@ nobase_follyinclude_HEADERS = \
        detail/AtFork.h \
        detail/AtomicHashUtils.h \
        detail/AtomicUnorderedMapUtils.h \
-       detail/BitIteratorDetail.h \
        detail/DiscriminatedPtrDetail.h \
        detail/FileUtilDetail.h \
        detail/FingerprintPolynomial.h \
@@ -403,7 +403,6 @@ nobase_follyinclude_HEADERS = \
        Random-inl.h \
        Range.h \
        Replaceable.h \
-       RWSpinLock.h \
        ScopeGuard.h \
        SharedMutex.h \
        Singleton.h \
@@ -437,6 +436,11 @@ nobase_follyinclude_HEADERS = \
        synchronization/Baton.h \
        synchronization/CallOnce.h \
        synchronization/LifoSem.h \
+       synchronization/ParkingLot.h \
+       synchronization/RWSpinLock.h \
+       synchronization/SaturatingSemaphore.h \
+       synchronization/Tearable.h \
+       synchronization/WaitOptions.h \
        synchronization/detail/AtomicUtils.h \
        synchronization/detail/Sleeper.h \
        system/MemoryMapping.h \
@@ -591,7 +595,6 @@ libfolly_la_SOURCES = \
        portability/Fcntl.cpp \
        portability/Libgen.cpp \
        portability/Malloc.cpp \
-       portability/Memory.cpp \
        portability/OpenSSL.cpp \
        portability/PThread.cpp \
        portability/Sockets.cpp \
@@ -625,6 +628,7 @@ libfolly_la_SOURCES = \
        stats/TimeseriesHistogram.cpp \
        synchronization/AsymmetricMemoryBarrier.cpp \
        synchronization/LifoSem.cpp \
+       synchronization/ParkingLot.cpp \
        system/MemoryMapping.cpp \
        system/Shell.cpp \
        system/ThreadName.cpp \