Improve launder
[folly.git] / folly / Makefile.am
index 52ae0d490994bb8269ceff0496e7f6b2d8baff74..36b703feaba46f9cf1311b5f86b12dd1c119037b 100644 (file)
@@ -2,12 +2,10 @@ if FOLLY_TESTMAIN
 MAYBE_INIT = init
 endif
 
-if EXCEPTION_TRACER
-MAYBE_EXCEPTION_TRACER = experimental/exception_tracer
-endif
-
-SUBDIRS = . experimental $(MAYBE_INIT) test io/test experimental/io/test \
-         $(MAYBE_EXCEPTION_TRACER)
+# Note that the order of SUBDIRS matters.
+# Many subdirectories depend on libfollytest from the test directory,
+# so it must appear before other directories
+SUBDIRS = . test experimental $(MAYBE_INIT) io/test stats/test
 
 ACLOCAL_AMFLAGS = -I m4
 
@@ -58,12 +56,12 @@ nobase_follyinclude_HEADERS = \
        CppAttributes.h \
        CpuId.h \
        CPortability.h \
+       concurrency/CacheLocality.h \
+       concurrency/CoreCachedSharedPtr.h \
        detail/AtomicHashUtils.h \
        detail/AtomicUnorderedMapUtils.h \
        detail/AtomicUtils.h \
        detail/BitIteratorDetail.h \
-       detail/BitsDetail.h \
-       detail/CacheLocality.h \
        detail/CachelinePaddedImpl.h \
        detail/ChecksumDetail.h \
        detail/DiscriminatedPtrDetail.h \
@@ -73,7 +71,7 @@ nobase_follyinclude_HEADERS = \
        detail/GroupVarintDetail.h \
        detail/IPAddress.h \
        detail/IPAddressSource.h \
-       detail/Malloc.h \
+       detail/MallocImpl.h \
        detail/MemoryIdler.h \
        detail/MPMCPipelineDetail.h \
        detail/RangeCommon.h \
@@ -82,7 +80,6 @@ nobase_follyinclude_HEADERS = \
        detail/SlowFingerprint.h \
        detail/SocketFastOpen.h \
        detail/StaticSingletonManager.h \
-       detail/Stats.h \
        detail/ThreadLocalDetail.h \
        detail/TryDetail.h \
        detail/TurnSequencer.h \
@@ -100,9 +97,9 @@ nobase_follyinclude_HEADERS = \
        ExceptionWrapper-inl.h \
        Executor.h \
        Expected.h \
+       concurrency/AtomicSharedPtr.h \
+       concurrency/detail/AtomicSharedPtr-detail.h \
        experimental/AsymmetricMemoryBarrier.h \
-       experimental/AtomicSharedPtr.h \
-       experimental/detail/AtomicSharedPtr-detail.h \
        experimental/AutoTimer.h \
        experimental/ThreadedRepeatingFunctionRunner.h \
        experimental/Bits.h \
@@ -127,6 +124,25 @@ nobase_follyinclude_HEADERS = \
        experimental/JemallocNodumpAllocator.h \
        experimental/JSONSchema.h \
        experimental/LockFreeRingBuffer.h \
+       experimental/logging/AsyncFileWriter.h \
+       experimental/logging/GlogStyleFormatter.h \
+       experimental/logging/ImmediateFileWriter.h \
+       experimental/logging/Init.h \
+       experimental/logging/LogCategory.h \
+       experimental/logging/LogFormatter.h \
+       experimental/logging/Logger.h \
+       experimental/logging/LoggerDB.h \
+       experimental/logging/LogHandler.h \
+       experimental/logging/LogLevel.h \
+       experimental/logging/LogMessage.h \
+       experimental/logging/LogName.h \
+       experimental/logging/LogStream.h \
+       experimental/logging/LogStreamProcessor.h \
+       experimental/logging/LogWriter.h \
+       experimental/logging/printf.h \
+       experimental/logging/RateLimiter.h \
+       experimental/logging/StandardLogHandler.h \
+       experimental/logging/xlog.h \
        experimental/NestedCommandLineApp.h \
        experimental/observer/detail/Core.h \
        experimental/observer/detail/GraphCycleDetector.h \
@@ -149,6 +165,7 @@ nobase_follyinclude_HEADERS = \
        experimental/symbolizer/StackTrace.h \
        experimental/symbolizer/Symbolizer.h \
        experimental/Select64.h \
+       experimental/StampedPtr.h \
        experimental/StringKeyedCommon.h \
        experimental/StringKeyedMap.h \
        experimental/StringKeyedSet.h \
@@ -179,7 +196,6 @@ nobase_follyinclude_HEADERS = \
        futures/FutureSplitter.h \
        futures/InlineExecutor.h \
        futures/ManualExecutor.h \
-       futures/OpaqueCallbackShunt.h \
        futures/Promise-inl.h \
        futures/Promise.h \
        futures/QueuedImmediateExecutor.h \
@@ -239,6 +255,7 @@ nobase_follyinclude_HEADERS = \
        io/async/DecoratedAsyncTransportWrapper.h \
        io/async/DelayedDestructionBase.h \
        io/async/DelayedDestruction.h \
+       io/async/DestructorCheck.h \
        io/async/EventBase.h \
        io/async/EventBaseLocal.h \
        io/async/EventBaseManager.h \
@@ -248,7 +265,6 @@ nobase_follyinclude_HEADERS = \
        io/async/EventUtil.h \
        io/async/NotificationQueue.h \
        io/async/HHWheelTimer.h \
-       io/async/ssl/OpenSSLPtrTypes.h \
        io/async/ssl/OpenSSLUtils.h \
        io/async/ssl/SSLErrors.h \
        io/async/ssl/TLSDefinitions.h \
@@ -273,7 +289,9 @@ nobase_follyinclude_HEADERS = \
        io/async/test/TimeUtil.h \
        io/async/test/UndelayedDestruction.h \
        io/async/test/Util.h \
+       Iterator.h \
        json.h \
+       Launder.h \
        Lazy.h \
        LifoSem.h \
        Likely.h \
@@ -287,6 +305,7 @@ nobase_follyinclude_HEADERS = \
        Math.h \
        Memory.h \
        MemoryMapping.h \
+       memory/UninitializedMemoryHacks.h \
        MicroSpinLock.h \
        MicroLock.h \
        MoveWrapper.h \
@@ -318,6 +337,7 @@ nobase_follyinclude_HEADERS = \
        portability/Memory.h \
        portability/OpenSSL.h \
        portability/PThread.h \
+       portability/Semaphore.h \
        portability/Sockets.h \
        portability/Stdio.h \
        portability/Stdlib.h \
@@ -334,8 +354,8 @@ nobase_follyinclude_HEADERS = \
        portability/SysUio.h \
        portability/Time.h \
        portability/TypeTraits.h \
-       portability/Windows.h \
        portability/Unistd.h \
+       portability/Windows.h \
        Preprocessor.h \
        PriorityMPMCQueue.h \
        ProducerConsumerQueue.h \
@@ -360,9 +380,11 @@ nobase_follyinclude_HEADERS = \
        SpookyHashV2.h \
        ssl/OpenSSLCertUtils.h \
        ssl/OpenSSLHash.h \
+       ssl/OpenSSLPtrTypes.h \
        ssl/OpenSSLVersionFinder.h \
        ssl/SSLSession.h \
        ssl/detail/SSLSessionImpl.h \
+       stats/detail/Bucket.h \
        stats/BucketedTimeSeries-defs.h \
        stats/BucketedTimeSeries.h \
        stats/Histogram-defs.h \
@@ -430,16 +452,14 @@ libfollybase_la_SOURCES = \
        FormatTables.cpp \
        MallctlHelper.cpp \
        portability/BitsFunctexcept.cpp \
-       StringBase.cpp \
        String.cpp \
        Unicode.cpp
 
 libfolly_la_SOURCES = \
        Assume.cpp \
-       Bits.cpp \
        Checksum.cpp \
        ClockGettimeWrappers.cpp \
-       detail/CacheLocality.cpp \
+       concurrency/CacheLocality.cpp \
        detail/IPAddress.cpp \
        dynamic.cpp \
        ExceptionWrapper.cpp \
@@ -449,7 +469,6 @@ libfolly_la_SOURCES = \
        FingerprintTables.cpp \
        futures/Barrier.cpp \
        futures/Future.cpp \
-       futures/InlineExecutor.cpp \
        futures/ManualExecutor.cpp \
        futures/QueuedImmediateExecutor.cpp \
        futures/ThreadWheelTimekeeper.cpp \
@@ -524,6 +543,7 @@ libfolly_la_SOURCES = \
        SharedMutex.cpp \
        Shell.cpp \
        MicroLock.cpp \
+       Optional.cpp \
        Singleton.cpp \
        SocketAddress.cpp \
        SpookyHashV1.cpp \
@@ -531,7 +551,10 @@ libfolly_la_SOURCES = \
        ssl/OpenSSLCertUtils.cpp \
        ssl/OpenSSLHash.cpp \
        ssl/detail/SSLSessionImpl.cpp \
-       stats/Instantiations.cpp \
+       stats/BucketedTimeSeries.cpp \
+       stats/Histogram.cpp \
+       stats/MultiLevelTimeSeries.cpp \
+       stats/TimeseriesHistogram.cpp \
        Subprocess.cpp \
        ThreadCachedArena.cpp \
        ThreadName.cpp \