move CallOnce to synchronization/
[folly.git] / folly / Makefile.am
index cb6c1074e30a8289f9dda588e5b3cda43a6f1973..344dc3aedb0a94c336cc0ed9487b1ade837c71fa 100644 (file)
@@ -27,7 +27,6 @@ lib_LTLIBRARIES = \
 follyincludedir = $(includedir)/folly
 
 nobase_follyinclude_HEADERS = \
-       ApplyTuple.h \
        Arena.h \
        Arena-inl.h \
        Array.h \
@@ -45,8 +44,6 @@ nobase_follyinclude_HEADERS = \
        Benchmark.h \
        Bits.h \
        CachelinePadded.h \
-       CallOnce.h \
-       Checksum.h \
        Chrono.h \
        ClockGettimeWrappers.h \
        ConcurrentSkipList.h \
@@ -59,13 +56,13 @@ nobase_follyinclude_HEADERS = \
        concurrency/CacheLocality.h \
        concurrency/ConcurrentHashMap.h \
        concurrency/CoreCachedSharedPtr.h \
+       concurrency/GlobalThreadPoolList.h \
        concurrency/detail/ConcurrentHashMap-detail.h \
        ConstexprMath.h \
        detail/AtomicHashUtils.h \
        detail/AtomicUnorderedMapUtils.h \
        detail/AtomicUtils.h \
        detail/BitIteratorDetail.h \
-       detail/ChecksumDetail.h \
        detail/DiscriminatedPtrDetail.h \
        detail/FileUtilDetail.h \
        detail/FingerprintPolynomial.h \
@@ -89,6 +86,7 @@ nobase_follyinclude_HEADERS = \
        executors/BlockingQueue.h \
        executors/CPUThreadPoolExecutor.h \
        executors/Codel.h \
+       executors/DrivableExecutor.h \
        executors/FiberIOExecutor.h \
        executors/FutureExecutor.h \
        executors/GlobalExecutor.h \
@@ -97,13 +95,16 @@ nobase_follyinclude_HEADERS = \
        executors/IOThreadPoolExecutor.h \
        executors/LifoSemMPMCQueue.h \
        executors/NamedThreadFactory.h \
+       executors/NotificationQueueExecutor.h \
        executors/PriorityLifoSemMPMCQueue.h \
        executors/PriorityThreadFactory.h \
+       executors/ScheduledExecutor.h \
        executors/SerialExecutor.h \
        executors/ThreadFactory.h \
        executors/ThreadPoolExecutor.h \
        executors/ThreadedExecutor.h \
        executors/UnboundedBlockingQueue.h \
+       functional/ApplyTuple.h \
        Demangle.h \
        DiscriminatedPtr.h \
        DynamicConverter.h \
@@ -203,8 +204,9 @@ nobase_follyinclude_HEADERS = \
        FormatTraits.h \
        Format.h \
        Format-inl.h \
+       functional/Invoke.h \
+       functional/Partial.h \
        futures/Barrier.h \
-       futures/DrivableExecutor.h \
        futures/Future-pre.h \
        futures/helpers.h \
        futures/Future.h \
@@ -215,8 +217,6 @@ nobase_follyinclude_HEADERS = \
        futures/ManualExecutor.h \
        futures/Promise-inl.h \
        futures/Promise.h \
-       futures/QueuedImmediateExecutor.h \
-       futures/ScheduledExecutor.h \
        futures/SharedPromise.h \
        futures/SharedPromise-inl.h \
        futures/ThreadWheelTimekeeper.h \
@@ -225,6 +225,8 @@ nobase_follyinclude_HEADERS = \
        futures/detail/FSM.h \
        futures/detail/Types.h \
        futures/test/TestExecutor.h \
+       hash/Checksum.h \
+       hash/detail/ChecksumDetail.h \
        hash/SpookyHashV1.h \
        hash/SpookyHashV2.h \
        gen/Base.h \
@@ -241,7 +243,6 @@ nobase_follyinclude_HEADERS = \
        gen/ParallelMap-inl.h \
        gen/String.h \
        gen/String-inl.h \
-       GlobalThreadPoolList.h \
        GroupVarint.h \
        Hash.h \
        IPAddress.h \
@@ -322,12 +323,12 @@ nobase_follyinclude_HEADERS = \
        LockTraitsBoost.h \
        Logging.h \
        MacAddress.h \
-       MallctlHelper.h \
        Malloc.h \
        MapUtil.h \
        Math.h \
        Memory.h \
        MemoryMapping.h \
+       memory/MallctlHelper.h \
        memory/UninitializedMemoryHacks.h \
        MicroSpinLock.h \
        MicroLock.h \
@@ -338,7 +339,6 @@ nobase_follyinclude_HEADERS = \
        Overload.h \
        PackedSyncPtr.h \
        Padded.h \
-       Partial.h \
        PicoSpinLock.h \
        Portability.h \
        portability/Asm.h \
@@ -418,6 +418,7 @@ nobase_follyinclude_HEADERS = \
        stats/MultiLevelTimeSeries.h \
        stats/TimeseriesHistogram-defs.h \
        stats/TimeseriesHistogram.h \
+       synchronization/CallOnce.h \
        stop_watch.h \
        String.h \
        String-inl.h \
@@ -467,9 +468,9 @@ GroupVarintTables.cpp: build/generate_varint_tables.py
 CLEANFILES += GroupVarintTables.cpp
 
 libfollybasesse42_la_SOURCES = \
-       detail/Crc32cDetail.cpp \
-       detail/ChecksumDetail.cpp \
-       detail/RangeSse42.cpp
+       detail/RangeSse42.cpp \
+       hash/detail/ChecksumDetail.cpp \
+       hash/detail/Crc32cDetail.cpp
 
 libfollybase_la_SOURCES = \
        Conv.cpp \
@@ -479,16 +480,16 @@ libfollybase_la_SOURCES = \
        Format.cpp \
        FormatArg.cpp \
        FormatTables.cpp \
-       MallctlHelper.cpp \
+       memory/MallctlHelper.cpp \
        portability/BitsFunctexcept.cpp \
        String.cpp \
        Unicode.cpp
 
 libfolly_la_SOURCES = \
        Assume.cpp \
-       Checksum.cpp \
        ClockGettimeWrappers.cpp \
        concurrency/CacheLocality.cpp \
+       concurrency/GlobalThreadPoolList.cpp \
        detail/Futex.cpp \
        detail/IPAddress.cpp \
        detail/StaticSingletonManager.cpp \
@@ -502,8 +503,8 @@ libfolly_la_SOURCES = \
        futures/Barrier.cpp \
        futures/Future.cpp \
        futures/FutureException.cpp \
+       futures/InlineExecutor.cpp \
        futures/ManualExecutor.cpp \
-       futures/QueuedImmediateExecutor.cpp \
        futures/ThreadWheelTimekeeper.cpp \
        futures/test/TestExecutor.cpp \
        executors/CPUThreadPoolExecutor.cpp \
@@ -513,11 +514,12 @@ libfolly_la_SOURCES = \
        executors/SerialExecutor.cpp \
        executors/ThreadPoolExecutor.cpp \
        executors/ThreadedExecutor.cpp \
+       executors/QueuedImmediateExecutor.cpp \
        experimental/hazptr/hazptr.cpp \
        experimental/hazptr/memory_resource.cpp \
-       GlobalThreadPoolList.cpp \
        GroupVarint.cpp \
        GroupVarintTables.cpp \
+       hash/Checksum.cpp \
        hash/SpookyHashV1.cpp \
        hash/SpookyHashV2.cpp \
        IPAddress.cpp \
@@ -537,6 +539,7 @@ libfolly_la_SOURCES = \
        io/async/AsyncServerSocket.cpp \
        io/async/AsyncSignalHandler.cpp \
        io/async/AsyncSocket.cpp \
+       io/async/AsyncSocketException.cpp \
        io/async/AsyncSSLSocket.cpp \
        io/async/EventBase.cpp \
        io/async/EventBaseLocal.cpp \