move CallOnce to synchronization/
[folly.git] / folly / Makefile.am
index 94b417c27dbd2a6a23d02beab6bca159921ed83e..344dc3aedb0a94c336cc0ed9487b1ade837c71fa 100644 (file)
@@ -27,7 +27,6 @@ lib_LTLIBRARIES = \
 follyincludedir = $(includedir)/folly
 
 nobase_follyinclude_HEADERS = \
-       ApplyTuple.h \
        Arena.h \
        Arena-inl.h \
        Array.h \
@@ -45,7 +44,6 @@ nobase_follyinclude_HEADERS = \
        Benchmark.h \
        Bits.h \
        CachelinePadded.h \
-       CallOnce.h \
        Chrono.h \
        ClockGettimeWrappers.h \
        ConcurrentSkipList.h \
@@ -88,6 +86,7 @@ nobase_follyinclude_HEADERS = \
        executors/BlockingQueue.h \
        executors/CPUThreadPoolExecutor.h \
        executors/Codel.h \
+       executors/DrivableExecutor.h \
        executors/FiberIOExecutor.h \
        executors/FutureExecutor.h \
        executors/GlobalExecutor.h \
@@ -99,11 +98,13 @@ nobase_follyinclude_HEADERS = \
        executors/NotificationQueueExecutor.h \
        executors/PriorityLifoSemMPMCQueue.h \
        executors/PriorityThreadFactory.h \
+       executors/ScheduledExecutor.h \
        executors/SerialExecutor.h \
        executors/ThreadFactory.h \
        executors/ThreadPoolExecutor.h \
        executors/ThreadedExecutor.h \
        executors/UnboundedBlockingQueue.h \
+       functional/ApplyTuple.h \
        Demangle.h \
        DiscriminatedPtr.h \
        DynamicConverter.h \
@@ -204,8 +205,8 @@ nobase_follyinclude_HEADERS = \
        Format.h \
        Format-inl.h \
        functional/Invoke.h \
+       functional/Partial.h \
        futures/Barrier.h \
-       futures/DrivableExecutor.h \
        futures/Future-pre.h \
        futures/helpers.h \
        futures/Future.h \
@@ -216,9 +217,6 @@ nobase_follyinclude_HEADERS = \
        futures/ManualExecutor.h \
        futures/Promise-inl.h \
        futures/Promise.h \
-       futures/QueuedImmediateExecutor.h \
-       futures/Retrying.h \
-       futures/ScheduledExecutor.h \
        futures/SharedPromise.h \
        futures/SharedPromise-inl.h \
        futures/ThreadWheelTimekeeper.h \
@@ -325,12 +323,12 @@ nobase_follyinclude_HEADERS = \
        LockTraitsBoost.h \
        Logging.h \
        MacAddress.h \
-       MallctlHelper.h \
        Malloc.h \
        MapUtil.h \
        Math.h \
        Memory.h \
        MemoryMapping.h \
+       memory/MallctlHelper.h \
        memory/UninitializedMemoryHacks.h \
        MicroSpinLock.h \
        MicroLock.h \
@@ -341,7 +339,6 @@ nobase_follyinclude_HEADERS = \
        Overload.h \
        PackedSyncPtr.h \
        Padded.h \
-       Partial.h \
        PicoSpinLock.h \
        Portability.h \
        portability/Asm.h \
@@ -421,6 +418,7 @@ nobase_follyinclude_HEADERS = \
        stats/MultiLevelTimeSeries.h \
        stats/TimeseriesHistogram-defs.h \
        stats/TimeseriesHistogram.h \
+       synchronization/CallOnce.h \
        stop_watch.h \
        String.h \
        String-inl.h \
@@ -482,7 +480,7 @@ libfollybase_la_SOURCES = \
        Format.cpp \
        FormatArg.cpp \
        FormatTables.cpp \
-       MallctlHelper.cpp \
+       memory/MallctlHelper.cpp \
        portability/BitsFunctexcept.cpp \
        String.cpp \
        Unicode.cpp
@@ -505,8 +503,8 @@ libfolly_la_SOURCES = \
        futures/Barrier.cpp \
        futures/Future.cpp \
        futures/FutureException.cpp \
+       futures/InlineExecutor.cpp \
        futures/ManualExecutor.cpp \
-       futures/QueuedImmediateExecutor.cpp \
        futures/ThreadWheelTimekeeper.cpp \
        futures/test/TestExecutor.cpp \
        executors/CPUThreadPoolExecutor.cpp \
@@ -516,6 +514,7 @@ libfolly_la_SOURCES = \
        executors/SerialExecutor.cpp \
        executors/ThreadPoolExecutor.cpp \
        executors/ThreadedExecutor.cpp \
+       executors/QueuedImmediateExecutor.cpp \
        experimental/hazptr/hazptr.cpp \
        experimental/hazptr/memory_resource.cpp \
        GroupVarint.cpp \