move CallOnce to synchronization/
[folly.git] / folly / Makefile.am
index 54788e69e5d4287ea1d899851392b88e72c958bf..344dc3aedb0a94c336cc0ed9487b1ade837c71fa 100644 (file)
@@ -27,7 +27,6 @@ lib_LTLIBRARIES = \
 follyincludedir = $(includedir)/folly
 
 nobase_follyinclude_HEADERS = \
-       ApplyTuple.h \
        Arena.h \
        Arena-inl.h \
        Array.h \
@@ -45,8 +44,6 @@ nobase_follyinclude_HEADERS = \
        Benchmark.h \
        Bits.h \
        CachelinePadded.h \
-       CallOnce.h \
-       Checksum.h \
        Chrono.h \
        ClockGettimeWrappers.h \
        ConcurrentSkipList.h \
@@ -57,12 +54,15 @@ nobase_follyinclude_HEADERS = \
        CpuId.h \
        CPortability.h \
        concurrency/CacheLocality.h \
+       concurrency/ConcurrentHashMap.h \
        concurrency/CoreCachedSharedPtr.h \
+       concurrency/GlobalThreadPoolList.h \
+       concurrency/detail/ConcurrentHashMap-detail.h \
+       ConstexprMath.h \
        detail/AtomicHashUtils.h \
        detail/AtomicUnorderedMapUtils.h \
        detail/AtomicUtils.h \
        detail/BitIteratorDetail.h \
-       detail/ChecksumDetail.h \
        detail/DiscriminatedPtrDetail.h \
        detail/FileUtilDetail.h \
        detail/FingerprintPolynomial.h \
@@ -80,9 +80,31 @@ nobase_follyinclude_HEADERS = \
        detail/SocketFastOpen.h \
        detail/StaticSingletonManager.h \
        detail/ThreadLocalDetail.h \
-       detail/TryDetail.h \
        detail/TurnSequencer.h \
        detail/UncaughtExceptionCounter.h \
+       executors/Async.h \
+       executors/BlockingQueue.h \
+       executors/CPUThreadPoolExecutor.h \
+       executors/Codel.h \
+       executors/DrivableExecutor.h \
+       executors/FiberIOExecutor.h \
+       executors/FutureExecutor.h \
+       executors/GlobalExecutor.h \
+       executors/IOExecutor.h \
+       executors/IOObjectCache.h \
+       executors/IOThreadPoolExecutor.h \
+       executors/LifoSemMPMCQueue.h \
+       executors/NamedThreadFactory.h \
+       executors/NotificationQueueExecutor.h \
+       executors/PriorityLifoSemMPMCQueue.h \
+       executors/PriorityThreadFactory.h \
+       executors/ScheduledExecutor.h \
+       executors/SerialExecutor.h \
+       executors/ThreadFactory.h \
+       executors/ThreadPoolExecutor.h \
+       executors/ThreadedExecutor.h \
+       executors/UnboundedBlockingQueue.h \
+       functional/ApplyTuple.h \
        Demangle.h \
        DiscriminatedPtr.h \
        DynamicConverter.h \
@@ -119,6 +141,10 @@ nobase_follyinclude_HEADERS = \
        experimental/exception_tracer/StackTrace.h \
        experimental/FunctionScheduler.h \
        experimental/FutureDAG.h \
+       experimental/hazptr/debug.h \
+       experimental/hazptr/hazptr.h \
+       experimental/hazptr/hazptr-impl.h \
+       experimental/hazptr/memory_resource.h \
        experimental/io/FsUtil.h \
        experimental/JemallocNodumpAllocator.h \
        experimental/JSONSchema.h \
@@ -155,14 +181,6 @@ nobase_follyinclude_HEADERS = \
        experimental/observer/SimpleObservable-inl.h \
        experimental/ProgramOptions.h \
        experimental/ReadMostlySharedPtr.h \
-       experimental/symbolizer/Elf.h \
-       experimental/symbolizer/Elf-inl.h \
-       experimental/symbolizer/ElfCache.h \
-       experimental/symbolizer/Dwarf.h \
-       experimental/symbolizer/LineReader.h \
-       experimental/symbolizer/SignalHandler.h \
-       experimental/symbolizer/StackTrace.h \
-       experimental/symbolizer/Symbolizer.h \
        experimental/Select64.h \
        experimental/StampedPtr.h \
        experimental/StringKeyedCommon.h \
@@ -181,12 +199,14 @@ nobase_follyinclude_HEADERS = \
        FixedString.h \
        folly-config.h \
        Foreach.h \
+       Foreach-inl.h \
        FormatArg.h \
        FormatTraits.h \
        Format.h \
        Format-inl.h \
+       functional/Invoke.h \
+       functional/Partial.h \
        futures/Barrier.h \
-       futures/DrivableExecutor.h \
        futures/Future-pre.h \
        futures/helpers.h \
        futures/Future.h \
@@ -197,8 +217,6 @@ nobase_follyinclude_HEADERS = \
        futures/ManualExecutor.h \
        futures/Promise-inl.h \
        futures/Promise.h \
-       futures/QueuedImmediateExecutor.h \
-       futures/ScheduledExecutor.h \
        futures/SharedPromise.h \
        futures/SharedPromise-inl.h \
        futures/ThreadWheelTimekeeper.h \
@@ -207,6 +225,8 @@ nobase_follyinclude_HEADERS = \
        futures/detail/FSM.h \
        futures/detail/Types.h \
        futures/test/TestExecutor.h \
+       hash/Checksum.h \
+       hash/detail/ChecksumDetail.h \
        hash/SpookyHashV1.h \
        hash/SpookyHashV2.h \
        gen/Base.h \
@@ -291,6 +311,8 @@ nobase_follyinclude_HEADERS = \
        io/async/test/TimeUtil.h \
        io/async/test/UndelayedDestruction.h \
        io/async/test/Util.h \
+       io/compression/Utils.h \
+       io/compression/Zlib.h \
        Iterator.h \
        json.h \
        Launder.h \
@@ -301,12 +323,12 @@ nobase_follyinclude_HEADERS = \
        LockTraitsBoost.h \
        Logging.h \
        MacAddress.h \
-       MallctlHelper.h \
        Malloc.h \
        MapUtil.h \
        Math.h \
        Memory.h \
        MemoryMapping.h \
+       memory/MallctlHelper.h \
        memory/UninitializedMemoryHacks.h \
        MicroSpinLock.h \
        MicroLock.h \
@@ -317,7 +339,6 @@ nobase_follyinclude_HEADERS = \
        Overload.h \
        PackedSyncPtr.h \
        Padded.h \
-       Partial.h \
        PicoSpinLock.h \
        Portability.h \
        portability/Asm.h \
@@ -397,11 +418,13 @@ nobase_follyinclude_HEADERS = \
        stats/MultiLevelTimeSeries.h \
        stats/TimeseriesHistogram-defs.h \
        stats/TimeseriesHistogram.h \
+       synchronization/CallOnce.h \
        stop_watch.h \
        String.h \
        String-inl.h \
        Subprocess.h \
        Synchronized.h \
+       SynchronizedPtr.h \
        test/FBStringTestBenchmarks.cpp.h \
        test/FBVectorTestBenchmarks.cpp.h \
        test/function_benchmark/benchmark_impl.h \
@@ -417,6 +440,7 @@ nobase_follyinclude_HEADERS = \
        TimeoutQueue.h \
        TokenBucket.h \
        tracing/StaticTracepoint.h \
+       tracing/ScopedTraceSection.h \
        Traits.h \
        Try-inl.h \
        Try.h \
@@ -444,9 +468,9 @@ GroupVarintTables.cpp: build/generate_varint_tables.py
 CLEANFILES += GroupVarintTables.cpp
 
 libfollybasesse42_la_SOURCES = \
-       detail/Crc32cDetail.cpp \
-       detail/ChecksumDetail.cpp \
-       detail/RangeSse42.cpp
+       detail/RangeSse42.cpp \
+       hash/detail/ChecksumDetail.cpp \
+       hash/detail/Crc32cDetail.cpp
 
 libfollybase_la_SOURCES = \
        Conv.cpp \
@@ -454,18 +478,22 @@ libfollybase_la_SOURCES = \
        detail/RangeCommon.cpp \
        EscapeTables.cpp \
        Format.cpp \
+       FormatArg.cpp \
        FormatTables.cpp \
-       MallctlHelper.cpp \
+       memory/MallctlHelper.cpp \
        portability/BitsFunctexcept.cpp \
        String.cpp \
        Unicode.cpp
 
 libfolly_la_SOURCES = \
        Assume.cpp \
-       Checksum.cpp \
        ClockGettimeWrappers.cpp \
        concurrency/CacheLocality.cpp \
+       concurrency/GlobalThreadPoolList.cpp \
+       detail/Futex.cpp \
        detail/IPAddress.cpp \
+       detail/StaticSingletonManager.cpp \
+       detail/ThreadLocalDetail.cpp \
        dynamic.cpp \
        ExceptionWrapper.cpp \
        Executor.cpp \
@@ -475,17 +503,25 @@ libfolly_la_SOURCES = \
        futures/Barrier.cpp \
        futures/Future.cpp \
        futures/FutureException.cpp \
+       futures/InlineExecutor.cpp \
        futures/ManualExecutor.cpp \
-       futures/QueuedImmediateExecutor.cpp \
        futures/ThreadWheelTimekeeper.cpp \
        futures/test/TestExecutor.cpp \
-       detail/Futex.cpp \
-       detail/StaticSingletonManager.cpp \
-       detail/ThreadLocalDetail.cpp \
-       hash/SpookyHashV1.cpp \
-       hash/SpookyHashV2.cpp \
+       executors/CPUThreadPoolExecutor.cpp \
+       executors/Codel.cpp \
+       executors/GlobalExecutor.cpp \
+       executors/IOThreadPoolExecutor.cpp \
+       executors/SerialExecutor.cpp \
+       executors/ThreadPoolExecutor.cpp \
+       executors/ThreadedExecutor.cpp \
+       executors/QueuedImmediateExecutor.cpp \
+       experimental/hazptr/hazptr.cpp \
+       experimental/hazptr/memory_resource.cpp \
        GroupVarint.cpp \
        GroupVarintTables.cpp \
+       hash/Checksum.cpp \
+       hash/SpookyHashV1.cpp \
+       hash/SpookyHashV2.cpp \
        IPAddress.cpp \
        IPAddressV4.cpp \
        IPAddressV6.cpp \
@@ -503,6 +539,7 @@ libfolly_la_SOURCES = \
        io/async/AsyncServerSocket.cpp \
        io/async/AsyncSignalHandler.cpp \
        io/async/AsyncSocket.cpp \
+       io/async/AsyncSocketException.cpp \
        io/async/AsyncSSLSocket.cpp \
        io/async/EventBase.cpp \
        io/async/EventBaseLocal.cpp \
@@ -521,6 +558,7 @@ libfolly_la_SOURCES = \
        io/async/test/TimeUtil.cpp \
        io/async/ssl/OpenSSLUtils.cpp \
        io/async/ssl/SSLErrors.cpp \
+       io/compression/Zlib.cpp \
        json.cpp \
        detail/MemoryIdler.cpp \
        detail/SocketFastOpen.cpp \
@@ -646,6 +684,27 @@ libfolly_la_SOURCES += \
        fibers/TimeoutController.cpp
 endif
 
+if USE_SYMBOLIZER
+nobase_follyinclude_HEADERS += \
+       experimental/symbolizer/Elf.h \
+       experimental/symbolizer/Elf-inl.h \
+       experimental/symbolizer/ElfCache.h \
+       experimental/symbolizer/Dwarf.h \
+       experimental/symbolizer/LineReader.h \
+       experimental/symbolizer/SignalHandler.h \
+       experimental/symbolizer/StackTrace.h \
+       experimental/symbolizer/Symbolizer.h
+
+libfolly_la_SOURCES += \
+       experimental/symbolizer/Elf.cpp \
+       experimental/symbolizer/ElfCache.cpp \
+       experimental/symbolizer/Dwarf.cpp \
+       experimental/symbolizer/LineReader.cpp \
+       experimental/symbolizer/SignalHandler.cpp \
+       experimental/symbolizer/StackTrace.cpp \
+       experimental/symbolizer/Symbolizer.cpp
+endif
+
 libfollybasesse42_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LT_VERSION)
 libfollybasesse42_la_CXXFLAGS = -msse4.2 -mpclmul