Add <new> header for placement new
[folly.git] / folly / Makefile.am
index ce4319adf2cd41d292a971d717646c2353425af6..2854cd23023e579935ca160a986a60483d014829 100644 (file)
@@ -1,4 +1,8 @@
+if FOLLY_TESTMAIN
+SUBDIRS = . experimental init test
+else
 SUBDIRS = . test
+endif
 
 ACLOCAL_AMFLAGS = -I m4
 
@@ -21,6 +25,7 @@ nobase_follyinclude_HEADERS = \
        ApplyTuple.h \
        Arena.h \
        Arena-inl.h \
+       Assume.h \
        AtomicBitSet.h \
        AtomicHashArray.h \
        AtomicHashArray-inl.h \
@@ -32,11 +37,14 @@ nobase_follyinclude_HEADERS = \
        Baton.h \
        Benchmark.h \
        Bits.h \
+       CallOnce.h \
        Checksum.h \
-       Chrono.h \
        ConcurrentSkipList.h \
        ConcurrentSkipList-inl.h \
+       ConditionallyExistent.h \
+       ContainerTraits.h \
        Conv.h \
+       CppAttributes.h \
        CpuId.h \
        CPortability.h \
        detail/AtomicHashUtils.h \
@@ -45,7 +53,6 @@ nobase_follyinclude_HEADERS = \
        detail/BitsDetail.h \
        detail/CacheLocality.h \
        detail/ChecksumDetail.h \
-       detail/Clock.h \
        detail/DiscriminatedPtrDetail.h \
        detail/ExceptionWrapper.h \
        detail/FileUtilDetail.h \
@@ -57,9 +64,12 @@ nobase_follyinclude_HEADERS = \
        detail/Malloc.h \
        detail/MemoryIdler.h \
        detail/MPMCPipelineDetail.h \
+       detail/RangeCommon.h \
+       detail/RangeSse42.h \
        detail/Sleeper.h \
        detail/SlowFingerprint.h \
        detail/SpinLockImpl.h \
+       detail/StaticSingletonManager.h \
        detail/Stats.h \
        detail/ThreadLocalDetail.h \
        detail/TurnSequencer.h \
@@ -76,10 +86,13 @@ nobase_follyinclude_HEADERS = \
        experimental/AutoTimer.h \
        experimental/Bits.h \
        experimental/BitVectorCoding.h \
+       experimental/DynamicParser.h \
+       experimental/DynamicParser-inl.h \
        experimental/ExecutionObserver.h \
        experimental/EliasFanoCoding.h \
        experimental/EventCount.h \
        experimental/Instructions.h \
+       experimental/bser/Bser.h \
        experimental/fibers/AddTasks.h \
        experimental/fibers/AddTasks-inl.h \
        experimental/fibers/Baton.h \
@@ -113,11 +126,20 @@ nobase_follyinclude_HEADERS = \
        experimental/LockFreeRingBuffer.h \
        experimental/NestedCommandLineApp.h \
        experimental/ProgramOptions.h \
+       experimental/ReadMostlySharedPtr.h \
+       experimental/symbolizer/Elf.h \
+       experimental/symbolizer/ElfCache.h \
+       experimental/symbolizer/Dwarf.h \
+       experimental/symbolizer/LineReader.h \
+       experimental/symbolizer/SignalHandler.h \
+       experimental/symbolizer/StackTrace.cpp \
+       experimental/symbolizer/Symbolizer.h \
        experimental/Select64.h \
        experimental/StringKeyedCommon.h \
        experimental/StringKeyedUnorderedMap.h \
        experimental/StringKeyedUnorderedSet.h \
        experimental/TestUtil.h \
+       experimental/TLRefCount.h \
        experimental/TupleOps.h \
        FBString.h \
        FBVector.h \
@@ -147,13 +169,13 @@ nobase_follyinclude_HEADERS = \
        futures/ScheduledExecutor.h \
        futures/SharedPromise.h \
        futures/SharedPromise-inl.h \
+       futures/ThreadWheelTimekeeper.h \
        futures/Timekeeper.h \
        futures/Try-inl.h \
        futures/Try.h \
        futures/Unit.h \
        futures/detail/Core.h \
        futures/detail/FSM.h \
-       futures/detail/ThreadWheelTimekeeper.h \
        futures/detail/Types.h \
        gen/Base.h \
        gen/Base-inl.h \
@@ -175,7 +197,9 @@ nobase_follyinclude_HEADERS = \
        IPAddressV4.h \
        IPAddressV6.h \
        IPAddressException.h \
+       Indestructible.h \
        IndexedMemPool.h \
+       init/Init.h \
        IntrusiveList.h \
        io/Compression.h \
        io/Cursor.h \
@@ -185,6 +209,7 @@ nobase_follyinclude_HEADERS = \
        io/RecordIO-inl.h \
        io/TypedIOBuf.h \
        io/ShutdownSocketSet.h \
+       io/async/AsyncPipe.h \
        io/async/AsyncTimeout.h \
        io/async/AsyncTransport.h \
        io/async/AsyncUDPServerSocket.h \
@@ -205,6 +230,9 @@ nobase_follyinclude_HEADERS = \
        io/async/EventUtil.h \
        io/async/NotificationQueue.h \
        io/async/HHWheelTimer.h \
+       io/async/ssl/OpenSSLPtrTypes.h \
+       io/async/ssl/OpenSSLUtils.h \
+       io/async/ssl/TLSDefinitions.h \
        io/async/Request.h \
        io/async/SSLContext.h \
        io/async/ScopedEventBaseThread.h \
@@ -215,6 +243,8 @@ nobase_follyinclude_HEADERS = \
        io/async/test/MockAsyncServerSocket.h \
        io/async/test/MockAsyncSSLSocket.h \
        io/async/test/MockAsyncTransport.h \
+       io/async/test/MockAsyncUDPSocket.h \
+       io/async/test/MockTimeoutManager.h \
        io/async/test/SocketPair.h \
        io/async/test/TimeUtil.h \
        io/async/test/UndelayedDestruction.h \
@@ -230,6 +260,7 @@ nobase_follyinclude_HEADERS = \
        Memory.h \
        MemoryMapping.h \
        MicroSpinLock.h \
+       MicroLock.h \
        MoveWrapper.h \
        MPMCPipeline.h \
        MPMCQueue.h \
@@ -238,6 +269,31 @@ nobase_follyinclude_HEADERS = \
        Padded.h \
        PicoSpinLock.h \
        Portability.h \
+       portability/Asm.h \
+       portability/Builtins.h \
+       portability/Config.h \
+       portability/Constexpr.h \
+       portability/Dirent.h \
+       portability/Environment.h \
+       portability/GFlags.h \
+       portability/IOVec.h \
+       portability/Libgen.h \
+       portability/Malloc.h \
+       portability/Memory.h \
+       portability/PThread.h \
+       portability/String.h \
+       portability/Strings.h \
+       portability/Syslog.h \
+       portability/SysFile.h \
+       portability/SysMman.h \
+       portability/SysResource.h \
+       portability/SysStat.h \
+       portability/SysSyscall.h \
+       portability/SysTime.h \
+       portability/SysTypes.h \
+       portability/SysUio.h \
+       portability/Time.h \
+       portability/Windows.h \
        Preprocessor.h \
        ProducerConsumerQueue.h \
        Random.h \
@@ -248,10 +304,12 @@ nobase_follyinclude_HEADERS = \
        SharedMutex.h \
        Singleton.h \
        Singleton-inl.h \
+       SingletonThreadLocal.h \
        SmallLocks.h \
        small_vector.h \
        SocketAddress.h \
        sorted_vector_types.h \
+       SparseByteSet.h \
        SpinLock.h \
        SpookyHashV1.h \
        SpookyHashV2.h \
@@ -261,6 +319,8 @@ nobase_follyinclude_HEADERS = \
        stats/Histogram.h \
        stats/MultiLevelTimeSeries-defs.h \
        stats/MultiLevelTimeSeries.h \
+       stats/TimeseriesHistogram-defs.h \
+       stats/TimeseriesHistogram.h \
        String.h \
        String-inl.h \
        Subprocess.h \
@@ -271,6 +331,7 @@ nobase_follyinclude_HEADERS = \
        test/function_benchmark/test_functions.h \
        test/SynchronizedTestLib.h \
        test/SynchronizedTestLib-inl.h \
+       test/TestUtils.h \
        ThreadCachedArena.h \
        ThreadCachedInt.h \
        ThreadLocal.h \
@@ -278,6 +339,9 @@ nobase_follyinclude_HEADERS = \
        TimeoutQueue.h \
        Traits.h \
        Unicode.h \
+       Function.h \
+       Function-inl.h \
+       Function-pre.h \
        Uri.h \
        Uri-inl.h \
        Varint.h \
@@ -298,30 +362,33 @@ CLEANFILES += GroupVarintTables.cpp
 libfollybase_la_SOURCES = \
        Conv.cpp \
        Demangle.cpp \
+       detail/RangeCommon.cpp \
+       detail/RangeSse42.cpp \
        EscapeTables.cpp \
        Format.cpp \
        FormatTables.cpp \
-       Malloc.cpp \
-       Range.cpp \
        StringBase.cpp \
        String.cpp \
        Unicode.cpp
 
 libfolly_la_SOURCES = \
        Bits.cpp \
+       Checksum.cpp \
        detail/CacheLocality.cpp \
        dynamic.cpp \
        File.cpp \
        FileUtil.cpp \
        FingerprintTables.cpp \
-       futures/detail/ThreadWheelTimekeeper.cpp \
        futures/Barrier.cpp \
        futures/ThreadedExecutor.cpp \
        futures/Future.cpp \
        futures/InlineExecutor.cpp \
        futures/ManualExecutor.cpp \
        futures/QueuedImmediateExecutor.cpp \
+       futures/ThreadWheelTimekeeper.cpp \
        detail/Futex.cpp \
+       detail/StaticSingletonManager.cpp \
+       detail/ThreadLocalDetail.cpp \
        GroupVarint.cpp \
        GroupVarintTables.cpp \
        IPAddress.cpp \
@@ -333,6 +400,7 @@ libfolly_la_SOURCES = \
        io/IOBufQueue.cpp \
        io/RecordIO.cpp \
        io/ShutdownSocketSet.cpp \
+       io/async/AsyncPipe.cpp \
        io/async/AsyncTimeout.cpp \
        io/async/AsyncUDPSocket.cpp \
        io/async/AsyncServerSocket.cpp \
@@ -343,18 +411,33 @@ libfolly_la_SOURCES = \
        io/async/EventBaseLocal.cpp \
        io/async/EventBaseManager.cpp \
        io/async/EventHandler.cpp \
+       io/async/Request.cpp \
        io/async/SSLContext.cpp \
        io/async/ScopedEventBaseThread.cpp \
        io/async/HHWheelTimer.cpp \
        io/async/test/SocketPair.cpp \
        io/async/test/TimeUtil.cpp \
+       io/async/ssl/OpenSSLUtils.cpp \
        json.cpp \
        detail/MemoryIdler.cpp \
        MacAddress.cpp \
        MemoryMapping.cpp \
+       portability/Dirent.cpp \
+       portability/Environment.cpp \
+       portability/Libgen.cpp \
+       portability/Malloc.cpp \
+       portability/String.cpp \
+       portability/Strings.cpp \
+       portability/SysFile.cpp \
+       portability/SysMman.cpp \
+       portability/SysResource.cpp \
+       portability/SysStat.cpp \
+       portability/SysTime.cpp \
+       portability/Time.cpp \
        Random.cpp \
        SafeAssert.cpp \
        SharedMutex.cpp \
+       MicroLock.cpp \
        Singleton.cpp \
        SocketAddress.cpp \
        SpookyHashV1.cpp \
@@ -365,6 +448,9 @@ libfolly_la_SOURCES = \
        TimeoutQueue.cpp \
        Uri.cpp \
        Version.cpp \
+       experimental/bser/Dump.cpp \
+       experimental/bser/Load.cpp \
+       experimental/DynamicParser.cpp \
        experimental/fibers/Baton.cpp \
        experimental/fibers/Fiber.cpp \
        experimental/fibers/FiberManager.cpp \
@@ -386,15 +472,11 @@ libfolly_la_SOURCES += \
        experimental/io/HugePages.cpp
 endif
 
-if !HAVE_LINUX
-libfollybase_la_SOURCES += detail/Clock.cpp
-endif
-
 if !HAVE_WEAK_SYMBOLS
 libfollybase_la_SOURCES += detail/MallocImpl.cpp
 endif
 
-if !HAVE_BITS_FUNCTEXCEPT
+if !HAVE_BITS_FUNCTEXCEPT_H
 libfollybase_la_SOURCES += detail/FunctionalExcept.cpp
 endif