Add <new> header for placement new
[folly.git] / folly / Makefile.am
index 1cf593377a7a548b8ec7ce861d32b3a01e282b47..2854cd23023e579935ca160a986a60483d014829 100644 (file)
@@ -34,15 +34,17 @@ nobase_follyinclude_HEADERS = \
        AtomicLinkedList.h \
        AtomicStruct.h \
        AtomicUnorderedMap.h \
-       CppAttributes.h \
        Baton.h \
        Benchmark.h \
        Bits.h \
+       CallOnce.h \
        Checksum.h \
        ConcurrentSkipList.h \
        ConcurrentSkipList-inl.h \
+       ConditionallyExistent.h \
        ContainerTraits.h \
        Conv.h \
+       CppAttributes.h \
        CpuId.h \
        CPortability.h \
        detail/AtomicHashUtils.h \
@@ -51,7 +53,6 @@ nobase_follyinclude_HEADERS = \
        detail/BitsDetail.h \
        detail/CacheLocality.h \
        detail/ChecksumDetail.h \
-       detail/Clock.h \
        detail/DiscriminatedPtrDetail.h \
        detail/ExceptionWrapper.h \
        detail/FileUtilDetail.h \
@@ -68,6 +69,7 @@ nobase_follyinclude_HEADERS = \
        detail/Sleeper.h \
        detail/SlowFingerprint.h \
        detail/SpinLockImpl.h \
+       detail/StaticSingletonManager.h \
        detail/Stats.h \
        detail/ThreadLocalDetail.h \
        detail/TurnSequencer.h \
@@ -84,6 +86,8 @@ nobase_follyinclude_HEADERS = \
        experimental/AutoTimer.h \
        experimental/Bits.h \
        experimental/BitVectorCoding.h \
+       experimental/DynamicParser.h \
+       experimental/DynamicParser-inl.h \
        experimental/ExecutionObserver.h \
        experimental/EliasFanoCoding.h \
        experimental/EventCount.h \
@@ -137,7 +141,6 @@ nobase_follyinclude_HEADERS = \
        experimental/TestUtil.h \
        experimental/TLRefCount.h \
        experimental/TupleOps.h \
-       SparseByteSet.h \
        FBString.h \
        FBVector.h \
        File.h \
@@ -194,6 +197,7 @@ nobase_follyinclude_HEADERS = \
        IPAddressV4.h \
        IPAddressV6.h \
        IPAddressException.h \
+       Indestructible.h \
        IndexedMemPool.h \
        init/Init.h \
        IntrusiveList.h \
@@ -226,7 +230,9 @@ nobase_follyinclude_HEADERS = \
        io/async/EventUtil.h \
        io/async/NotificationQueue.h \
        io/async/HHWheelTimer.h \
-       io/async/OpenSSLPtrTypes.h \
+       io/async/ssl/OpenSSLPtrTypes.h \
+       io/async/ssl/OpenSSLUtils.h \
+       io/async/ssl/TLSDefinitions.h \
        io/async/Request.h \
        io/async/SSLContext.h \
        io/async/ScopedEventBaseThread.h \
@@ -254,6 +260,7 @@ nobase_follyinclude_HEADERS = \
        Memory.h \
        MemoryMapping.h \
        MicroSpinLock.h \
+       MicroLock.h \
        MoveWrapper.h \
        MPMCPipeline.h \
        MPMCQueue.h \
@@ -262,7 +269,31 @@ nobase_follyinclude_HEADERS = \
        Padded.h \
        PicoSpinLock.h \
        Portability.h \
-       portability/Syscall.h \
+       portability/Asm.h \
+       portability/Builtins.h \
+       portability/Config.h \
+       portability/Constexpr.h \
+       portability/Dirent.h \
+       portability/Environment.h \
+       portability/GFlags.h \
+       portability/IOVec.h \
+       portability/Libgen.h \
+       portability/Malloc.h \
+       portability/Memory.h \
+       portability/PThread.h \
+       portability/String.h \
+       portability/Strings.h \
+       portability/Syslog.h \
+       portability/SysFile.h \
+       portability/SysMman.h \
+       portability/SysResource.h \
+       portability/SysStat.h \
+       portability/SysSyscall.h \
+       portability/SysTime.h \
+       portability/SysTypes.h \
+       portability/SysUio.h \
+       portability/Time.h \
+       portability/Windows.h \
        Preprocessor.h \
        ProducerConsumerQueue.h \
        Random.h \
@@ -278,6 +309,7 @@ nobase_follyinclude_HEADERS = \
        small_vector.h \
        SocketAddress.h \
        sorted_vector_types.h \
+       SparseByteSet.h \
        SpinLock.h \
        SpookyHashV1.h \
        SpookyHashV2.h \
@@ -307,6 +339,9 @@ nobase_follyinclude_HEADERS = \
        TimeoutQueue.h \
        Traits.h \
        Unicode.h \
+       Function.h \
+       Function-inl.h \
+       Function-pre.h \
        Uri.h \
        Uri-inl.h \
        Varint.h \
@@ -352,6 +387,7 @@ libfolly_la_SOURCES = \
        futures/QueuedImmediateExecutor.cpp \
        futures/ThreadWheelTimekeeper.cpp \
        detail/Futex.cpp \
+       detail/StaticSingletonManager.cpp \
        detail/ThreadLocalDetail.cpp \
        GroupVarint.cpp \
        GroupVarintTables.cpp \
@@ -375,18 +411,33 @@ libfolly_la_SOURCES = \
        io/async/EventBaseLocal.cpp \
        io/async/EventBaseManager.cpp \
        io/async/EventHandler.cpp \
+       io/async/Request.cpp \
        io/async/SSLContext.cpp \
        io/async/ScopedEventBaseThread.cpp \
        io/async/HHWheelTimer.cpp \
        io/async/test/SocketPair.cpp \
        io/async/test/TimeUtil.cpp \
+       io/async/ssl/OpenSSLUtils.cpp \
        json.cpp \
        detail/MemoryIdler.cpp \
        MacAddress.cpp \
        MemoryMapping.cpp \
+       portability/Dirent.cpp \
+       portability/Environment.cpp \
+       portability/Libgen.cpp \
+       portability/Malloc.cpp \
+       portability/String.cpp \
+       portability/Strings.cpp \
+       portability/SysFile.cpp \
+       portability/SysMman.cpp \
+       portability/SysResource.cpp \
+       portability/SysStat.cpp \
+       portability/SysTime.cpp \
+       portability/Time.cpp \
        Random.cpp \
        SafeAssert.cpp \
        SharedMutex.cpp \
+       MicroLock.cpp \
        Singleton.cpp \
        SocketAddress.cpp \
        SpookyHashV1.cpp \
@@ -399,6 +450,7 @@ libfolly_la_SOURCES = \
        Version.cpp \
        experimental/bser/Dump.cpp \
        experimental/bser/Load.cpp \
+       experimental/DynamicParser.cpp \
        experimental/fibers/Baton.cpp \
        experimental/fibers/Fiber.cpp \
        experimental/fibers/FiberManager.cpp \
@@ -420,15 +472,11 @@ libfolly_la_SOURCES += \
        experimental/io/HugePages.cpp
 endif
 
-if !HAVE_LINUX
-libfollybase_la_SOURCES += detail/Clock.cpp
-endif
-
 if !HAVE_WEAK_SYMBOLS
 libfollybase_la_SOURCES += detail/MallocImpl.cpp
 endif
 
-if !HAVE_BITS_FUNCTEXCEPT
+if !HAVE_BITS_FUNCTEXCEPT_H
 libfollybase_la_SOURCES += detail/FunctionalExcept.cpp
 endif